Posts created by aduncanzianet

 
 
 posted in Mystika 2: The Sanctuary on Jun 17, 14 6:48 PM
What about the puzzle with the purple cauldron on the second from the left iced over? I haven't found a solution to that one yet. HELP!
 
 
 posted in Mystika 2: The Sanctuary on Jun 8, 14 5:43 PM
I'm stuck on the one with the purple buckets on the left and one of them is iced over, too. Very frustrating.
 
 
 posted in Mystika 2: The Sanctuary on May 23, 14 4:53 PM
Is there a walk-through for this game? I really need help.
 
 
 posted in Mystika 2: The Sanctuary on May 23, 14 4:06 PM
I'm stuck at 201, too. AAaaaaaarrrrrgh!
 
 
 posted in Fishdom 3 Collector's Edition on Dec 14, 12 7:44 PM
You guys are doing better than I am. I'm stuck on L40, and can't for the life of me smash that jewel-covered square in the lower left. I've restarted the blasted game five or six times, and every time I get dynamite or a rocket or something, it's too far away to do any good. Phooey.
 
 
 posted in Zulu's Zoo on May 26, 12 5:34 PM
I can't find the fennec fox or the grizzly bear, even when I use the stars. Where the heck are those guys?
 
 
 posted in Big City Adventure: London Classic on Apr 23, 12 6:56 PM
Really, REALLY needs a skip button! Going nuts here
 
 
 posted in The Scruffs: Return of the Duke on Mar 2, 12 6:50 PM
Never mind. I got the card about the fiftieth time I tried to pick it up. Sheesh!
 
 
 posted in The Scruffs: Return of the Duke on Mar 2, 12 6:48 PM
I uploaded the new version, finished the game, started over, and now I can't pick up the stupid credit card!
 
 
 posted in 1912: Titanic Mystery on Jan 2, 11 12:42 PM
Karin, I finished the puzzle. Now every time I go back to play the game again, I click on "Resume Game," it takes me to the first class dining room, and I get stuck in the first class dining room, with all the items crossed off, the puzzle solved, and I can't get out. Very frustrating. Maybe I'll begin the game again. I downloaded the latest service pack for Windows Vista, so maybe I won't get stuck anywhere again. Grumble.
 
 
 posted in 1912: Titanic Mystery on Jan 2, 11 9:15 AM
I was enjoying this game when all of a sudden, it jammed in the first-class dining room, and I can't get out of it. I found all the clues and put the puzzle together, and it's just stuck there. Help!!!! I don't want to have to replay the whole game only to get stuck there again. Any tips? Or do I need to download it again? Gick.
 
 
 posted in Murder, She Wrote on Mar 14, 10 12:28 PM
That worked! Thanks. I've GOT to stop being so literal.
 
 
 posted in Murder, She Wrote on Mar 14, 10 12:17 PM
I was trying to stick the handle in the hole. I thought I'd try it the other way, too, but I might not have. Will try this and see what happened. I already used my game club credit on another game this month, but there's always April

Thank you!
 
 
 posted in Murder, She Wrote on Mar 13, 10 6:14 PM
Thanks. I've tried to put it together a hundred & ninety times, and it just won't go. Sniffle. It's probably me.
 
 
 posted in Murder, She Wrote on Mar 13, 10 4:34 PM
Yes. The plunger thing is in the first book. I can't get the two parts to go together so I can empty the sink. They just don't fit. Phooey.
 
 
 posted in Murder, She Wrote on Mar 11, 10 3:31 PM
Okay, I was enjoying the heck out of this game, and was about to buy it, but I can't get the stupid plunger handle to go into the stupid plunger. So I quit. How come the plunger handle won't go into the plunger? How come I feel SO STUPID?
 
 
Okay, I have the $6.99 edition. So the bunny's head doesn't fall off? I'm doing the walk through, not being able to deal with the game otherwise. So . . . what now? If I can't get the bunny head to fall off, do I just continue without it?
 
 
 posted in Mystery Case Files®: Dire Grove™ on Dec 16, 09 6:15 PM
I've bashed the bunny with the hammer about thirty times, and the blankety-blank head won't fall off. What am I doing wrong? Do I have to hit a specific spot? Stupid bunny.
 
 
Well, I'm totally stupid. I got to the gnomes and picked up the rock, but now I don't know what to do with it. I'm not good at these mysterious games! I'm better at HOGs that don't confuse me
 
 
 posted in Mystery Case Files: Return to Ravenhearst ™ on Dec 3, 08 3:46 PM
I finally got through this game last night. Yay!!!! I liked it ever so much better than Madame Fate, mainly because Fate gave me the creeps. You'd think this would, too, bit it didn't. Mind you, I was confuzzled most of the time while trying to get through RTR, but I still loved it. Too bad we have to wait another year for the next installment. I only hope it isn't any harder than this one, or I might cry
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator