Posts created by Snooks_1

 
 
 posted in Farmscapes on Jan 7, 18 11:31 PM
I can't get past a level where pieces of fruit and eggs are in separate squares by themselves. Even when I let bombs off near them, it doesn't clear them. The only way seems to be hives but there isn't enough time to collect the number of hives needed. I can't give the level number because I can't see where the level numbers are. Can someone please help?
 
 
 posted in Cake Shop 3 on Jan 7, 18 10:25 PM
Can someone tell me how to finish this game? It just seems to go on even when I have purchased everything and got expert on all levels.
 
 
 posted in Dr. Cares Pet Rescue 911 Collector's Edition on Nov 5, 17 4:54 PM
Can someone please let me know where the mouse is on level 59?
 
 
 posted in Murder, She Wrote 2: Return to Cabot Cove on Mar 27, 16 11:52 PM
I cannot get the red lanterns to hang on the hooks. Any suggestions?
 
 
 posted in Sable Maze: Norwich Caves on Sep 18, 15 11:24 PM
I am having the same problem. Can't work it out.
 
 
 posted in Sable Maze: Norwich Caves on Sep 17, 15 7:56 PM
In chapter 6, I can't get the nippers to cut the wire. The hint keeps pointing to them but no matter where I try to cut, it doesn't work. Does anyone have any ideas? Thanks in advance.
 
 
 posted in Fashion Forward on Jul 5, 14 12:39 AM
My mouse won't work on this game. I have deleted it and reloaded it, but it still won't work. Anyone have any ideas how to fix this?
Thanks in advance.
 
 
 posted in Yummy Drink Factory on Jul 22, 13 6:27 AM
Hi everyone. I am on level 27 and I am following the instructions in making a slime smoothie but the characters are not accepting it. I have triple checked how to make it so don't understand where I am going wrong. Can anyone help please?
Thanks in advance
 
 
 posted in Big City Adventure: London Classic on May 3, 12 6:44 AM
Can someone tell me how to unlock Westminster Abbey? The game keeps telling me to go to it but it isn't highlighted. Help please!!!
 
 
 posted in Golden Hearts Juice Bar on Feb 5, 11 3:02 AM
Can anyone tell me why sometimes when I make the order exactly as shown the order will not be accepted by the customer? The only difference sometimes is the direction the straw is facing. Is there any way to change this and is this relevant?
Thanks in advance.
 
 
 posted in Lost Realms: Legacy of the Sun Princess on Jan 3, 11 2:10 PM
I just got to the end where you put the mask together and after I'd done that the program came up with an error message. I tried again and the same thing happened. More than a little frustrating. Can anyone tell me what happens at the end?
 
 
 posted in Pure Hidden on Oct 9, 10 9:43 PM
I really enjoyed this game and hope that more like it are introduced. The only problem with it is the ending. With the obvious talent these people have with graphics, I would have expected an amazing ending instead of wondering whether you have indeed finished or not. This part was very disappointing.
 
 
 posted in Detective Stories: Hollywood on Sep 21, 10 4:53 AM
Thank you so much TNKOKOBIRD. I tried so many times and was getting really frustrated. Well done.
 
 
 posted in The Mysterious City: Cairo on Jul 24, 10 7:10 AM
I enjoy playing this game but every time I get out of it, the game doesn't save my progress. Each time I have to start at the beginning again. Anyone have any ideas to help??
 
 
 posted in Agatha Christie - Death on the Nile on Jan 22, 10 8:05 PM
The one thing you have to remember about the puzzle box is that not everything has its common name e.g. the bucket is actually called a pail which rhymes with snail and the pig is a hog that rhymes with log etc. You just have to think "outside the box" a little. Lol.
 
 
 posted in Agatha Christie: Dead Man's Folly on Dec 31, 09 7:21 AM
I found the best way to complete the name of the boat is to pick up the letter and then point to the previous letter and click on it. You have to pick up the letters in order but this works quite well. Hope this helps.
 
 
 posted in Agatha Christie: Dead Man's Folly on Dec 27, 09 9:49 PM
Hi everyone. I need some help with the ending. I couldn't complete the final chapter in time and the game suddenly said investigation complete and the game ended without giving me the chance to redo the chapter or guess who the murderer/s is. Has this happened to other people and can you let me know what I can do to fix the problem? I also had trouble with putting the blocks in the correct order in one chapter and the name of the boat in another but got it in the end.
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator