Posts created by BigTfromAV

 
 
I got to the place where I put the arm on the teacher and the music on the stands and then I'm stuck. If I ask for help, it tells me to look at my goals - no help. Can't move on. Looked at the guide, tells me to clean the flute case but there's no flute case to be found.
 
 
 posted in Demon Hunter 3: Revelation Collector's Edition on Apr 18, 16 6:14 AM
Windows 10 - access violation. Won't start - kicks me back to PLAY AGAIN .
 
 
Same problem with the electrical cabinet - keeps kicking me out. Cannot play that puzzle. Will wait for ability to SKIP.
 
 
I could not get the stamp from the cupboard in the Bonus Chapter HOP. I went into and out of the game to try again. Finally, I clicked - starting at the top left to right - every inch of the screen. It finally, randomly allowed it to be taken. It's definitely a bug.
 
 
 posted in Mystery Trackers: Blackrow's Secret Collector's Edition on Aug 28, 14 10:45 AM
I also could not close the repaired lock. I exited the game and got back in, then I was able to hit the button in the middle of the lock to close it.
 
 
Same with me - can't find the leaf. It isn't where the hint says. Third game in a few weeks that has had this kind of problem. So frustrating.
 
 
 posted in Nevertales: The Beauty Within Collector's Edition on Oct 30, 13 6:34 AM
Come on Big Fish - we've been waiting for several days here. Please fix and update!
 
 
 posted in Nevertales: The Beauty Within Collector's Edition on Oct 28, 13 4:31 PM
userfree wrote:
jlbaughn1 wrote:Sorry, but I tried both and I still did not get back the whetstone. My computer is up to date on everything so it has to be a glitch. I really don't feel like re-playing the whole game to get past chapter 7 to get to the bonus. It has happened to others too in the tech problem feed too.


Ditto here; used the whetstone on the chisel first as everyone seems to have that lost the whetstone and can't hone the shears. BF what do we do?


Same thing happened to me. Reported in the technical section - told to uninstall/reinstall but that did nothing.
 
 
 posted in Nevertales: The Beauty Within Collector's Edition on Oct 28, 13 12:16 PM
Uninstalled/reinstalled - still no whetstone.
 
 
 posted in Nevertales: The Beauty Within Collector's Edition on Oct 28, 13 8:12 AM
jlbaughn1 wrote:Same thing happened to me. Used it on the chisel before using on the garden shears and it disappeared from the inventory. Can't finish game. It had to be on Chapter 7 too, right before the bonus chapter. I contacted tech support and did a Dr. Felix attachment. Hope they fix this, loved the game.


Same thing happened to me. I'm totally stuck. Second game in a week that this has happened to. Ugh.
 
 
 posted in Tales of Lagoona 2: Peril at Poseidon Park on Oct 17, 13 6:26 PM
sinfulcashew5 wrote:
KarenLeden wrote:I haven't had the problem of freezing but......it will not let me put the sword in the sheath in the Magic Show. This is way into the game ( I have played for hours) and now I can't go further until I get past this.


Same problem here!
Some times if you leave and come back (in other games) these issues will go away,,,,, but not this time! I even reinstalled it, no go!
Hmph!
Hope it can be remedied?


I'm stuck in the same place. Please fix and send us an update!!
 
 
 posted in Tales of Lagoona 2: Peril at Poseidon Park on Oct 17, 13 1:54 PM
I am finished with the main part of the game - just trying to finish getting my last special item (brick) and I cannot sheath the sword either. Even the hint shows that I can do it, but I can't. Also - no other scenes available to play. Grrr.
 
 
 posted in The Scruffs: Return of the Duke on Nov 30, 12 6:45 AM
Once you put the medallion in the lock, you then have to click on the lock again to make it disappear. Then the spears will move.
 
 
The whole game appears to be in 3D. The reds and greens are separated as if it were a 3D movie and I wasn't wearing the glasses. Is there something I'm missing? Never had a problem remotely like this before. What's up?
 
 
Just bought the game with the anniversary special price - good game but everytime I finish an h/o scene at a certain point in the game - it kicks me out! Started over with a new profile. Has happened 4 times now. What's up?
 
 
5 Stars on this one. Length is great - game is fun. Puzzles are challenging. It reminds me so much of the great Mystery Case Files games. Best game I've played in the last month.
 
 
 posted in Snark Busters: High Society on May 24, 12 2:36 PM
Yesterday I couldn't get the game to play at all. As per recommendations I started with a new user name and it let me play the demo - when the demo ended, there was no way to exit (as I see many have had issues with). Sorry - no buy from BFG for me - too many issues.
 
 
 posted in Snark Busters: High Society on May 23, 12 1:08 PM
I'm sorry but the problem is with the game - not my computer. It won't let me hit "play" it just kicks me out to the game manager - as I've seen is happening with many others.
 
 
 posted in Snark Busters: High Society on May 23, 12 5:22 AM
kris_cross48 wrote:mine downloads ok, but every time I hit play, it tosses me out into manager.
kris


Me too!
 
 
 posted in Jewel Quest Mysteries: The Oracle of Ur on May 22, 12 7:34 AM
Wow I was disappointed! I've loved the oldest Jewel Quest games for many years but the past few have been just awful. Trying too hard. The part I've always loved was the jewel boards - give us more of those and fewer of the very, very dark and hard to complete h/o scenes. Jewel Quest Solitaire was awesome too. Thought I'd finally found a game for my credit - nope.
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator