Posts created by perrik

 
 
 posted in The Tribloos 3 on Apr 12, 18 5:34 PM
I was about to click the BUY button (having enjoyed the previous Tribloos games) but luckily checked the app first... Apple has already killed off 32-bit apps in iOS 11.0 and it looks like they're about to do the same for MacOS apps.

Tribloos 3 was released as a 32-bit app, and I got a warning upon launch that it's not optimized. I confirmed in System Information that it's not 64-bit.

Are there plans to revise the Mac version of Tribloos 3 so we can keep playing it?
 
 
 posted in Vacation Adventures: Park Ranger 7 on Mar 22, 18 8:38 PM
Count me in among the disappointed customers. Did BFG not test this game before releasing it for sale? The resolution options on a Macbook retina display are very limited and I cannot reduce the resolution enough to get to the settings, nor could I reduce the resolution enough on an Airplay display (using my widescreen TV as a monitor). I've submitted a refund request. If this game is fixed, I'll repurchase it immediately because I've enjoyed this series and was eagerly awaiting the next installment - that makes it doubly disappointing that BFG released 7 without verifying that it's actually playable.
 
 
 posted in Green City: Go South on Aug 27, 14 8:03 PM
Yeah, this was a frustrating one! I don't recall the exact sequence, but this is what eventually happened:

1. Along the top row: Repair the suburban house, demolish the abandoned house and replace it with another suburban house, max upgrade all 4 suburban houses and sell them to raise cash.
2. Demolish the larger abandoned house (middle row on the right), restore the flooded area to its left, then build two multistories side by side. Upgrade when you can. I began the second phase of the port construction after both multistories were at level 2.
3. Demolish the junkyard and restore the flooded area below it. When you can afford it, use that space for two carousels and max upgrade both of them.
4. Along the bottom row, purchase and demolish the suburban houses, restore the flooded areas, and build/upgrade two more multistories.
5. Finish the port!
6. Buy back the 4 suburban houses along the top row. Demolish them and replace with promenades. Max upgrade the 4 promenades - and you're done.

This might not be the optimal sequence, but at least you'll meet all the goals and can move on to the next level!
 
 
 posted in Lost in Reefs 2 on Nov 14, 13 6:49 AM
I cannot finish the town! I'm currently on level 103 of the group puzzles, having completed all the swap and chain ones. The only item left to buy is the final upgrade for the Grand Palace. Whenever I buy that last upgrade, the upgraded building appears in the town, fireworks go off - and the game crashes and quits to the desktop.

So I'm advancing in levels (the first time I tried this was 11 levels ago) but cannot buy that last upgrade without crashing the game.

This is the Mac version running on a 1.7GHz Intel Core i5 MacBook Air running OSX 10.9.
 
 
 posted in Sea of Lies: Mutiny of the Heart Collector's Edition on Sep 3, 13 4:45 PM
yowzasma wrote:Big Fish is having a very nice sale on Eipix games and I am now playing their game *Myths of the World: Chinese Healer* which I got soon after it came out & it has a looong wait (10-15 seconds) between scenes with a dark screen and I found the same thing in *Sea of Lies: Mutiny of the Heart* trial. Between Is anyone else finding this also? When it first happened I thought it was crashing but finally opened with the new location and now I just wait for the lag between changes :/

If anyone could let me know if this is normal for Eipix I'll just ignore it as I really like their games.

It seems typical. I take advantage of those lags by popping to the kitchen for more coffee.

However, I won't be doing that for Sea of Lies, not until the books puzzle is fixed. I've run into the same problem as others have reported - the books cannot be moved correctly and there's no "skip" option, so the puzzle cannot be completed and I cannot continue in the game. I was really enjoying the demo so far, too!
 
 
 posted in Mystery Trackers: Silent Hollow Collector's Edition on Jul 18, 13 7:05 AM
May I just note that... can it be true?... Elephant Games appears to have resolved the issue with Macs with the HD3000/4000 graphics card running OS X 10.8 and higher. I've just played the demo for 1/2 hour with absolutely no video issues.

So Mac gamers who have been avoiding Elephant titles due to video problems, give this one a try!

 
 
 posted in Asian Riddles on Jul 2, 13 9:29 AM
lovemybook wrote:One difference in play - usually, in these games, the number clue at the end is "ticked off" when you "finish" the line - here, it is ticked off immediately, before you finish your section. I couldn't figure out why I kept making mistakes. It was because the clue was crossed out the moment I did the line. Those who play these games will understand.

I had the same problem. If you're used to playing the other games like this, you'll have to re-train yourself to deal with the automatic finishing of line sections.

Not sure if I like this game as much as the World Mosaics series (I have all of them!). The music is repetitive and wow, I am tired of stereotypical "Asian" music anyway. There *is* music in East Asia that doesn't sound like my cat walking across a piano keyboard.

One feature I'm finding extremely annoying is that, at least on the Mac version, you cannot command-Q to quit and exit the game. After completing a level, you have to click on the Pause, Menu, back arrow, back arrow, Exit, and "are you sure" buttons. Really, really annoying when you just want to quit the game to do something else!

The levels are appropriately challenging, and the graphics aren't bad (although as noted, the constant use of red & black is a bit much). I spent an earned game credit on it, and might have bought it as a DD. But I'm glad I didn't pay full price for this one. I'll finish the levels and then go back to replay one of the World Mosaics again...
 
 
 posted in The Tribloos 2 on May 1, 13 11:33 AM
die_nike wrote:Hi

I am having quite a lot of problems with the game starting as of level 24 (up to 23 no problems at all) ; I have to appoint the workers several times to do the same task and they just walk by (even if I do not need resources) and even after trying 10 times it still does not work. Twice the game froze completely.

Using the Mac version: Information on my MacBookPro, Mac OS X 10.7.5, Intel Core i7, 2.2 GHz, not sure if you need any other information.

Would be glad if you help me sorting out this problem, then I have never had such problems before with Mac versions.

Thanks a bunch for your help.


I think one of the issues is actually part of the game play. If you send workers past a broken pipe and the pipe starts spouting the red smoke as they walk by, the workers will immediately retreat back to the main building. You have to figure out the timing on when to send workers so that they won't be affected by the broken pipe. For example, on level 24 I send workers to the sawmill about two seconds after the broken pipe at the top of the ladder starts steaming. By the time the workers reach the top of the ladder, the steam has stopped and the workers can pass by safely. (if you played the original Tribloos, the steam here functions like the lava in that game)

However, I am having the same freezing problem on level 24! I've frozen up completely twice, both times just a bit before gold time ends. I'm on a MacBook Air, Intel i5 1.7Ghz, running OSX 10.8.3. The game ran perfectly for the first 23 levels.
 
 
 posted in Surface: The Soaring City Collector's Edition on Jan 24, 13 5:14 AM
Just a reminder to fellow Mac users that recent titles from Elephant Games do not run properly with some newer Macs running OS X 10.7.5.

BFG's thread in the Mac forum: http://forums.bigfishgames.com/posts/list/232841.page

If you have a dual-boot setup on an affected Mac, you should be able to play Elephant Games titles when running Windows. I can vouch for this working with Boot Camp on my MacBook Air and Mac Mini (both affected by the 10.7.5 issue), but I haven't tried it under Parallels or VM Fusion.

(Mods, please consider adding the info from the sticky thread on the 10.7.5 issues to the Mac Game Errors)

EDIT: I tried it out on the Mac side for the heck of it. Video issues continue with missing text, blacked-out cut scenes, and flickering graphics. However, the game is still playable if you're tolerant and patient. If you click on an object and get a blank text box, click again a few times and eventually you'll see the text (keep clicking a few more times in case there is more than one text message with that object). It's not exactly a smooth gaming experience, but this game seems to be working better than other recent Elephant titles did on affected Mac configurations. Might be wishful thinking, but give it a try.
 
 
 posted in Mystery Trackers: Four Aces Collector's Edition on Oct 29, 12 11:58 AM
I've encountered this problem with the last four Mac releases from Elephant Games. That's good in a way, because otherwise I would have purchased the latest in the Mystery Trackers series without even trying it! I've got a MacBook Air and a new Mac Mini, neither of which are compatible due to the graphics card.

FYI: I run the Air as a dual boot and discovered that the Windows version of MT:FA works just fine on this same graphics card. So the issue is not just the card, but the card + operating system.

I had written to Elephant Games support after trying the previous three games without success, but they had no answer at the time (and never followed up with me after they apparently figured out the problem).
 
 
 posted in City of Fools on Sep 13, 12 6:40 PM
I just installed the Mac version, and the characters are silent - there's no voice when a character speaks, and the dialogue boxes are also blank most of the time. Occasionally a dialogue box will contain the dialogue, but it's hit or miss (maybe 1 time out of 5 clicks to bring it up).

Other game sounds and visuals appear to be working normally. It's just the game dialogue that doesn't work.

I played as far as visiting the train station, but since the game hinges on interacting with the other characters, this game is currently unplayable for me!

Any ideas on why this is happening? Is any other Mac user experiencing this issue?
 
 
So far, this game has been nearly unplayable on my Mac!

I'm trying to play the Mac demo of the CE version, but the graphics are a mess. Anything animated only appears as flickers on screen. This includes the red flag on the intro screen as well as various objects in the first game screen (at the barrier). Dialog boxes come up blank. The opening sequence when you first launch the game is nothing but a black screen with a skip button.

I tried reinstalling the game, but the graphics issue doesn't go away. This is on a 1.7GHz MacBook Air with 4GB RAM and tons of HD space available, running OS X 10.8 with all the available updates. Other games are fine - I just finished Dark Strokes: Sins of the Father and just started the latest Redemption Cemetery (lots of animation, all perfectly visible!).

Thank goodness for trial versions, I'd hate to have wasted the money on this.

EDIT: Hmm. I just installed the Mac trial version of another new Elephant Games title (Surface: The Noise She Couldn't Make), and encountered the exact same problem - animated items only appearing as flickers, empty dialog boxes. I've played older Elephant Games offerings with no issues - the first Surface game and all the Mystery Trackers.
 
 
 posted in World Mosaics 5 on Feb 5, 12 7:44 PM
siddalee1970 wrote:The game's graphics are failing to show text. So, e.g., if there are any boxes (Options, Exit, Play, etc.) they show up as boxes that are blank. Any others having this problem?

Yes, I'm having the same problem! I bought the Mac version of WM5 without a trial because I have the other four games already and love them. The game is still playable, though, once you figure out which buttons do what (the interface is similar enough to the previous version that this isn't too tough).
 
 
 posted in The Tribloos on Oct 27, 11 7:14 PM
The graphics make The Tribloos look like a kids' game. The gameplay, though, is definitely adult-level stuff! I agree with the person who thought this game should be categorized as strategy rather than TM. Whatever you call it, it's addictive and loads of fun.

I've completed the game and am now trying for gold on every level. It's tough. Don't let those cute little Tribloos fool you.

Suggestion to the developer for future games: allow the user to disable tutorials in the game options. After you've played the game once, it's irritating as heck to have to click through the multiple instructional word balloons. Just let me get right to chopping and building, please!
 
 
 posted in Pioneer Lands on Aug 26, 11 3:25 PM
Thank you scorpio6616! After many failures I switched to your strategy (hire second male, harvest and mill grain, buy 4 grasses before hiring the female), and earned gold + medal on the first attempt with 6 seconds to spare. Whew...

And now on to the other levels I can't quite conquer!
 
 
 posted in Art Mogul on Aug 5, 11 6:32 PM
When selling paintings at the galleries, the number of hidden objects on a painting is related to the price you'll receive. If there's only one hidden object, the maximum offer is just one "jump" over the original offer. This gallery or another gallery may make you a better offer in a future visit, so if you don't need the room in your portfolio, don't sell yet.

You'll get a better offer if there are two hidden objects to find on the painting. For maximum profit, only sell when you've been tasked to find three hidden objects in the painting.

Visit the auction house whenever you switch cities and pick up the requests whenever offered. You'll make a better profit from fulfilling the request than by selling that particular art at a gallery.

I've yet to dabble in the counterfeit world, so I can't offer any hints there!
 
 
 posted in Art Mogul on Aug 4, 11 10:28 AM
After playing 50 minutes of the demo, I bought this game. Tycoon-type games don't come around often, and I was glad for the change of pace. It's not really on par with a true tycoon game, but it'll do for now.

I'm not a big fan of spot-the-difference games, especially when you can only flip back and forth between the two pictures, but so far it seems to be optional to play those mini-games unless you're going for certain achievements.

The one bit I don't like is the auction. It requires both a quick eye and quick reflexes, and then a quick mouse or trackpad. If you're too slow you can still win the auctions, but you'll pay too much for the artwork. My laptop has a touchpad; once I plugged in a mouse, the auction games were a bit easier to play. Still, the auctions are frantic sessions within an otherwise untimed, restful game - and are too important to be avoided.

There is some strategy involved in selling the artwork, if you want to get the highest selling price, but otherwise it's not much of an intellectual exercise. Well, it's summer and too hot to think anyway...
 
 
 posted in Astroslugs on Aug 2, 11 5:52 AM
The graphics and music are fun (if you like slugs, anyway), and the gameplay itself is simple to learn. I don't see this game having any real replay value unless you wait until you've forgotten the puzzle solutions.

I might pick this one up as a Daily Deal, but not as a regular purchase.

 
 
 posted in RoboRoll on Jul 18, 11 4:45 PM
I played this game for about five minutes - and bought it!

It is indeed a bit of a pain that you can't see the entire field of play, not even when you've zoomed out, and there's no automatic scroll to follow your robot. I also wish you could customize your control keys; this would be worse if it were a twitch-action game, but it's bearable since you don't need speed.

Nevertheless, RoboRoll is a fun strategic brain teaser. If you enjoyed Crazy Machines or the Professor Fizzwizzle games, give this one a try.

Alas, I'm stuck on level 21 right now, and it's too early for any walkthroughs...
 
 
 posted in The Timebuilders: Caveman's Prophecy on Jun 23, 11 4:07 PM
You start with one basic villa and access to three building spots, plus three rock eggs. Upgrade the villa fully and put an egg in each open spot. Meanwhile, clear out the rock piles. After you hatch the eggs and clear out the rock piles, you'll be able to build and fully upgrade four more villas. (you will have enough rock to do this, with 50 rocks left over) Remember to be careful with timing your upgrades so you don't lose out on any rent!

With the five upgraded villas each producing rent, it won't take too long to accumulate 5000 steaks - pay off the bigjaw. When you have 1000 steaks, buy 300 rocks. Then buy another 300 rocks. Build the smoker. Use your leftover rocks to build a crystal and campfire (to speed up the rent payments).

And that's it - keep collecting rent and collecting from the smoker, shake any kittens that emerge, and repair the crystal or campfire if necessary.
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator