Posts created by INGamePlayer

 
 
 posted in The Andersen Accounts: Chapter One Collector's Edition on Apr 8, 18 12:51 PM
Could not find anything positive about this game.

Story atmosphere - dark and demonic feeling. Really sick of those.

Story progression - felt like I was being jerked around by the nose from puzzle to puzzle, conversation to conversation and scene to scene with little development and little input by my character. Did not feel immersed in the story at all, even though it was supposed to be from a first-person point of view.

Graphics - dark and hazy, colorless. Some hidden object scenes were just jumbled line-drawings with few colors and little contrast between items, making them hard to see in an irksome way.

Conversations - really irritating. Most were just interruptions with little motivation or development. After every sentence you are required to click "Continue" even though you are not making any choices of conversation direction or, for that matter, any choice at all--just forced to participate to get out of the scene and on with the conversation or game. Again, this makes it impossible to feel immersed in the story, as it pulls your attention from the story to the mechanics of clicking a mouse just to progress.

Puzzles and HOSs - There were so many in the 30 minutes I managed to last in the demo that I felt less like I was following a story and more like the story was just there to frame all the interruptions (and I normally enjoy and look forward to puzzles.) I had already skipped two puzzles by the time I quit, just out of irritation.

I was looking forward to the start of a new series, but this was certainly not enjoyable.
 
 
 posted in Fairytale Mosaics Beauty And The Beast on Mar 13, 18 2:56 PM
Doing jigsaw puzzles isn't about competition, it's about creating a beautiful picture to enjoy as a result of your efforts. At least this version allows you to choose an untimed profile, but the completed picture disappears almost immediately, and you don't get to see it without the disfiguring puzzle piece cracks, so there is no reward for your work, no beauty to admire. Disappointing.
 
 
 posted in Jigsaws Galore on Feb 28, 18 7:41 PM
This has been my favorite jigsaw program for years and years, but since the update the pieces are so much smaller that I'm finding it hard to see them or see the detail on them. I really don't want to have to change the resolution of my whole computer just to make them larger, especially when the game worked perfectly for me before. Is it possible to roll back the update?
 
 
 posted in Moai V: New Generation on Jan 12, 18 5:59 PM
I love this type of game and own a couple of this series, but this is just ridiculous. It took me three tries to get the very first level finished before the time ran completely out, and I just gave up and quit after the first attempt of the second level. It's like the characters move in extremely slow motion--can't imagine how slow they would go when they get to sand pits or mud! This is nothing but pure frustration, no joy whatsoever.
 
 
Just decided to replay one of my very favorite games, MCF: Dire Grove, CE, and discovered to my dismay that it no longer works because I have Windows 10. Extremely disappointed.

Also, the post by moderator bfgIlinalta offering an update on the situation in late 2016 offers a link to a page with possible helps for Windows 10, but the link is faulty--just gives an error message.

This is ridiculous.
 
 
 posted in Crime Stories: Days of Vengeance on Jul 19, 17 7:22 PM
I loved the music, and the main character's voice and tone of the story reminded me of the OLD Tex Murphy adventure games that got me started on computer games many years ago. But it's not enough to make me want to buy the uninspiring match-3 game. Wish it had been an adventure or even a strategy game (what you call time-management.)
 
 
Windows 10. Hint and Skip will not refill. I was using Custom settings with them set at 30 and 45 seconds, respectively. Tried changing them from within the game to 15 and 30 seconds, but it made no difference. Very aggravating.
 
 
 posted in Gnomes Garden: New home on Mar 18, 17 7:56 AM
The game opened on my secondary monitor rather than the main, higher def large one with the speakers. In order to play it I had to change my display settings to use only the main screen. This is about the fourth game to do this in the past year, and at least one of the other ones was by the same company.


3/29/17 Addition: I downloaded the update to this game that came out today, but it still opens on the wrong monitor. Disappointed.
 
 
Was really enjoying this game until it suddenly backed me out of an active screen and now refuses to go back or move on. It isn't completely frozen, as I can still access the Menu and Guide buttons, but not the Map nor anything else on the screen. I was putting together the scroll picture across the pond where I would need to place the dove figurine (page 45 W in the Guide) when I was kicked back to the shore with the above issues. Have restarted the game 2 or 3 times, but it always goes back to the same scene with no active options. Very irritating. Sounds like the same problem others have had, just in a different location. PC with Windows 10, automatic updates.

Update: I uninstalled the game and reinstalled it--my profile returned to the same spot with the very same problems. Cannot access anything, go forward or back. No way to finish the game. Not happy, especially since it's a CE.

Update: I restarted the game with a new profile and was finally able to finish the entire game and bonus game without any significant problems.
 
 
Glad to see one problem solved that was in the Beta version: The CE game now opens on my main monitor instead of on my secondary one.

But I, too, had the black screen appear after I'd finished the demo and clicked on the Extras. Had to Alt+Tab to minimize the game, then right click to close it. Running Windows 10 with automatic updates.
 
 
 posted in Weather Lord: Graduation Collector's Edition on Feb 1, 17 6:59 PM
This is the third game in the last several months to open on my secondary monitor rather than the main one. I'm not going to change the formatting of my setup just to play a game. I'm pretty sure at least one of the other games was also an [Removed by Moderator] game.
 
 
 posted in Weather Lord: Royal Holidays on Nov 9, 16 11:24 AM
Both the CE version and this SE one started up on my secondary, smaller monitor instead of the main wide-screen monitor, even though the BFG game controller module is always on the main screen. And with this version, when I tried to turn off the game, it froze up and I had to use the Task Manager to dump it. I have no wish to change the configuration of my computer every time I want to play a particular game, so this is a no-buy for me.
 
 
 posted in Weather Lord: Royal Holidays Collector's Edition on Oct 14, 16 11:27 AM
This game started on my secondary (smaller, poorer resolution, no speakers) monitor even though the BFG game module is on my main screen. I don't want to have to change the setup of my computer just to play this one game, so I just dumped it. I think this is only the third game to ever do this. I have a Dell XPS desktop running WIndows 10.
 
 
 posted in Atlantis Evolution on Sep 4, 16 6:56 PM
I have tried several times over the years since I purchased this game to install it and play--on newer and newer computers. Every time it says it has downloaded and is ready to install, but after awhile it says installation failed. I have many, many BFG games purchased over the last decade, and I think this is the only one that has ever given me this problem.

Now using Windows 10 64 bit on a Dell XPS 8900 with 1851.24 GB free, using an NVIDIA GeForce GTX 745 graphics card and 4035 MB video memory.

PS: I would have posted this on the Technical Problems discussion, but it was locked.
 
 
 posted in Fantasy Mosaics 17: New Palette on Aug 31, 16 1:26 PM
I thought the maroon and brown colors were too much alike. Once they were placed in the puzzle grid it was difficult to tell which one it was when I came back from using another more distinct color. Actually caused me to make some errors, which was aggravating.
 
 
CiChDa wrote:Windows 10 PC,
I was unable to add a profile name, every time I tried it would kick me out of the game. So just playing under player, things seem to be ok, I am only on level 5.


I had exactly the same experience. Tried two or three times to create a profile, but the game dumped to a small black window, which I closed. At least I didn't have to restart my computer, was able to immediately restart the game. Also using Windows 10 on a Dell 8900 XPS with NVidia GeForce GTX 745 GPU. Was able to play the entire trial as long as I didn't use a profile.
 
 
 posted in Hidden Clues: New York on Jul 12, 16 12:08 PM
This game started on my smaller side monitor rather than on my main one. Besides having a smaller picture and poorer resolution, the sound is set up for the main speaker, so the audio comes from a different direction than the video.

The BFG game manager is on the main monitor, and this is only the second game out of hundreds and hundreds I've played / own that has done this. I really don't want to change my computer's set-up just for an individual game, so I won't be playing this one.
 
 
 posted in 7 Artifacts on May 3, 16 10:57 AM
Tried this because it was listed in today's Dragon Altar games sale. Game starts to load, then freezes. Couldn't get back to the game manager, to the desktop or even to the task manager. Had to hard-dump the computer (Dell XPS 8900, Windows 10.) Twice. I don't think this should still be offered or listed.
 
 
 posted in Silver Tale on Apr 13, 16 6:07 PM
pjones0066 wrote:I have the same problem. I collected the pick-axe but when I click the upper right on the lock it has a button that says USE but when I go to click on the USE button the box disappears so I can't ever use it. I tried the level numerous times to no avail. Definitely won't be purchasing this game.


UPDATE: If I uncheck the box for full screen so its now in windowed mode I can click on the use button.


Thanks for that post. Sorry you had the same problem, but at least I know I wasn't crazy! I had a few minutes left on the trial, so went back and tried your fix. It worked! When in windowed mode (which I never use normally) I was able to click on the "Use" button and advance in the game. Sounds like a glitch to me.
 
 
 posted in Silver Tale on Apr 12, 16 7:26 PM
Thanks for the replies! I did see a pop-up message which made me think I'd received the pickaxe, but I've never been able to make it work. I click on the locked area and get a text box that says "You have to use the pickaxe," but I've tried clicking on that box, the pickaxe itself and on the lock, and nothing has worked! I've been playing games for years and years and am well aware of this type of situation to move on in the game, but I just can't get this to work. Do you have to use the pickaxe immediately when you see the message or else lose it? That doesn't seem sensible. Maybe I should reinstall, but I only have a few minutes left on the trial, so I will probably just uninstall. Thanks again, fellow Fishies!

UPDATE: Uninstalled and reinstalled. Still won't let me click on the axe itself. If I click on the lock or the rocks I get the popup that says "Needs pickaxe" and gives me a "Use" button. But the instant I move my cursor to try to access that button the whole popup disappears. Forget it--don't need that frustration!
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator