Posts created by huffpatsy

 posted in Endless Fables: Dark Moor Collector's Edition on Apr 20, 18 3:01 PM
I cannot play the game, the hint stopped working and I am at a where to go...needs a fix!
can't get the lever, won't let me proceed w/o the lever....looks like the game needs a we go again. Not a bad game up to this point...would really like to finish what I start.
I also downloaded the CE and still cannot finish the game. both games need the same fix. I tried your suggestions and they did not work for me. These games need fixed please. Would very much like to finish the game.
 posted in Dark Tales: Edgar Allan Poe's Morella on Feb 8, 18 1:53 PM
I did everything you suggested, even redownloaded and started over with a different name, this parts still won't work for me. I sure hope some updates come soon, I would like to finish the game.
 posted in Dark Tales: Edgar Allan Poe's Morella on Jan 16, 18 3:04 PM
After using shovel to dig up chest, the objects will not move, I got most of them but keeps telling me there is not enough room for the stones...I need to find the diary but at this point I am stuck...need help.

I have tried 3 different time to do this puzzle, the items will not move, definitely needs a fix...Please...would really like to finish the game.
I did not enjoy this MCF game, and for me it was one of the worst. The best ones were regarding Ravenhurst.
 posted in Grim Tales: The White Lady Collector's Edition on Aug 6, 17 9:46 AM
I have found all the hidden articles, but it won't let me move on. Hint no help.
 posted in Immortal Love: Blind Desire Collector's Edition on Jul 29, 17 4:53 AM
Just finish tic-tac-toe w/ monster and cannot advance forward. The hint tells me I am done here but can't get an arrow to move on.
 posted in Dark Realm: Guardian of Flames Collector's Edition on Jul 23, 17 10:50 AM
This is the most stupid game I ever bought.
I started the game over w/ a new name and was able to finish the game w/o a fix, but there was a fix needed the first time. Glad I was able to finish the game,
I am stuck in the underground cave. It just will not let me move on, something happened when I had to click on the yellow disappeared and now the game needs a fix. I really would like to finish the game...PLEASE FIX!!!
I have unlocked the bottom & middle but the top lock w/ not open, the design is just will not work and needs fixed. PLEASE FIX THIS GAME!!!!!!
I have all the pieces and have tried and retried, it needs to be FIXED. I have found lately that too many games have bugs...whoever is checking them out before they are released should be more careful.
cannot unlock the top serpent key using the correct designs. need help, the key pops up but that's as far as I can go.
I have found 11 but it will not let me find the 12th using the hint. Need help. That's in Humphrey's chapter.
 posted in Haunted Legends: The Black Hawk Collector's Edition on Mar 29, 17 4:30 AM
The "dipstick" finally figured out that you don't pick up the glass, you pick up the rock w/ moss on it and place it on top of glass. I am in the bonus round now and have been enjoying the game this far. Actually the strategy guide mislead me telling me to pick up the glass.
 posted in Haunted Legends: The Black Hawk Collector's Edition on Mar 22, 17 3:57 AM
Still waiting for a fix on this game...would really like to finish it. Are they going to fix it or not?
 posted in Haunted Legends: The Black Hawk Collector's Edition on Mar 17, 17 9:50 AM
I cannot pick up the glass to clean the grass off rock so I can move the last rock before moving barrels off lift. Needs a fix...please.
 posted in Obscure Legends: Curse of the Ring on Mar 14, 17 2:49 PM
I d/l the game today, played it all the way thru...everything worked great like it was suppose too. Thank you!
Go to:   
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator