Posts created by colieleigh

 
 
 posted in Chronicles of Mystery: Tree of Life on Jan 29, 11 6:13 PM
sarge464646 wrote:I finished the tree relief in the palace, found the seeds, talked to the count, and he told me to run. When I try to get in the gondola, I get "I can't leave yet, there is something else I need to do here". I also picked up the stone pieces under the window, and restored the Mary Celeste plank. Help please!


Having this same issue, any answers to this yet?
 
 
 posted in Sherlock Holmes and the Hound of the Baskervilles on Dec 14, 10 9:39 AM
This game was a lot more fun than most HOG's. I enjoyed the graphics, the storyline, etc. Was a bit easy up until the last 2 puzzles which were difficult, the rest were very easy for me. Dialogue was a little slow, had to skip through some. Overall I'm glad I purchased this one.
 
 
The piano puzzle was the most frustrating for me, couldn't get the screwdriver to open the panel.
 
 
I am such a fan of the MCF games, and this one did not disappoint. I was so excited to see a new one out since Dire Grove and this one was great. Loved the interaction with real actors, loved the story line and location in the swamps of Louisiana. Great job!
 
 
 posted in Echo: Secret of the Lost Cavern on Aug 4, 10 9:23 AM
Does anyone have a review for this game? I dont want to purchase a game w/out reading reviews first. The video, unfortunately doesn't tell me what the premise of the game is... Thanks!
 
 
 posted in The Heritage on Jun 24, 10 11:15 AM
In big fish's defense there is a trial available, so if you are having issues with a game in the trial mode... dont buy the game.
 
 
 posted in Agatha Christie: 4:50 from Paddington on Jun 24, 10 9:33 AM
Why is this game so different than other agatha christie games I really enjoyed like murder on the orient express? Very disappointing.
 
 
 posted in Sherlock Holmes - The Secret of the Silver Earring on Jun 24, 10 9:22 AM
just move your cursor on the chairs that are straight across from the door handle that is turned down in the ballroom... it should turn into a hand for you to pick up the clothes.
 
 
 posted in Sherlock Holmes - The Secret of the Silver Earring on Jun 24, 10 9:21 AM
I got stuck on the first quiz and got really frustrated b/c I knew I had all of the correct evidence selected. Then I realized that I had yes selected to the table setting question. Make sure you have the proper yes/no answers as well as the evidence.
 
 
 posted in Sherlock Holmes - The Secret of the Silver Earring on Jun 24, 10 9:17 AM
Anyone have an idea on how to do this? I am tired of waiting on him to saunter across every screen. Thanks!
 
 
 posted in Sherlock Holmes - The Secret of the Silver Earring on Jun 24, 10 9:15 AM
you can always do a search for a walkthrough as well. I use them as a last resort if I feel I've exhausted all else and still cannot progress in the game. I cant give the site name here but just google the game title and walkthrough, that should help keep you moving.
 
 
 posted in Sherlock Holmes: The Awakened on Jun 24, 10 9:12 AM
I agree 100%, played the silver earring sherlock holmes game and liked it a lot, thank goodness I didn't outright buy this one, the trial gave me a chance to see how much the navigation bothers me. Very dizzying having to bounce from 1st to 3rd person (if thats what you'd call it.) Very irritating.
 
 
 posted in Agatha Christie: Evil Under the Sun on Jun 13, 10 12:28 PM
I found the master key too.. It also let me search Linda's room with her in it.. pretty sure I found some things I dont need until later acts.
 
 
 posted in Agatha Christie: Evil Under the Sun on Jun 13, 10 12:27 PM
I am LOVING this game. Purchased "and then there were none" for the wii and really liked it... thought Id try some here. I love that I am able to work through the kinks myself and not constantly look for a walkthrough to help me. Poirot is totally charming and makes me smile I also really love the music through some parts.. the "sherlock holmes" type detective music is nice.
I am a bit annoyed that the game sticks at times and I have had to start from my last save (which was a ways back in the game.
Also wondering if Poirot will ever go down the ladder he so decidedly refuses to descend?

Will post a full review when I finish the game. Definately glad I purchased this one.
 
 
 posted in Agatha Christie: Evil Under the Sun on Jun 13, 10 12:22 PM
I had this same problem... unfortunately hadn't saved since act 4 started so I had to start all over. ctr. alt del to get out of it and then started the act from the beginning. I saved right before Poirot goes in the post office and then it worked for me.
 
 
 posted in Restaurant Empire on Jun 10, 10 9:21 AM
I purchased (unfortunately) this game and it is just too much. There are about a million different things to toggle through... the way you view restaraunt and go back and forth is just nauseating... You cant keep up with complaints very well b/c they are again hidden by a toggle button... You never know you are doing something wrong until the uncle guy comes back after you've messed up and tells you how to do it differently... seems like the tutorial takes forever and they teach you as you go... frustrating and nerve racking. Not a fan of this one.
 
 
 posted in Rhiannon: Curse of the Four Branches on Jun 10, 10 9:17 AM
I really enjoyed this game. I love games that are lengthy and this one was... took me a couple days to work through. It is challenging and I cant honestly see how someone could figure some of these puzzles out w/o help from a walkthrough... the notes are helpful and give you a bit of guidance. The most irritating thing for this game in my opinion... the audio. There are points where the background is super loud... others where it is deathly quiet... the "spooky" noises when you see the spirits etc are just laughable and the music played at the very end of the game is very annoying. This game was definately worth the purchase for me.
 
 
 posted in Nancy Drew: Message in a Haunted Mansion on Apr 26, 10 1:01 PM
I just finished this one, have purchased tons of ND games in the past, this one was a little more lackluster than some of the others, but still fun to explore the mansion. Not a huge fan of the alarm clock and having to set and reset it, or having to run up to the bedroom to check her journal, other than that it was fun to play.
 
 
 posted in Journey to the Center of the Earth on Apr 21, 10 3:35 PM
I have been trying for hours to get her to put the darn ball on the pipe in the elevator, she wont do it so I go back to the weighing game and try again thinking I must've picked the wrong ball, I cant get the right one. Used the walkthrough on, still not working. I think I'm shelving this game b/c I am so irritated w/ it. she will never go where I ask her to go, the cursor is super sensitive and if you dont have it positioned exactly she just turns around in circles over and over again. Plus sometimes it gives you footprints sometimes it doesn't so you're clicking away constantly thinking maybe you're missing something.
 
 
 posted in NiBiRu: Age of Secrets on Apr 8, 10 9:13 AM
I'm not finding a menu anywhere so I can save the game? all I've got are the inventory items at the bottom of the screen. I'd like to adjust the background volume as well b/c I cant hear the artist over the water in the background. Help Please! Thanks!
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator