Posts created by VLewis138

 
 
Same Issue as jerseygirl. Can't pick up the Amulet to use it to save Dupin. Created new character and tried again. Will try going back in and see if that helps. I liked this game from the start but with this bug, if unresolved, will want my money back.

 
 
Somehow I didn't get the 3rd figure. Dupin is hanging our the window and I cant pick up the death amulet or fix the other one. Will I have to start over as a new player. I seem to be stuck.
 
 
 posted in Dark Romance: The Monster Within on Oct 8, 17 1:50 PM
I was in the first scene at the stage to revive Sybil and suddenly nothing worked. I had already gotten the handkerchief, Champagne bottle, key and diary but when I tried to click on anything, including hint, nothing happened. I exited the game, uninstalled it, reinstalled it and still had the same problem. Anyone else having issues.

I have a Mac desktop, and my OS is Sierra 10.12.6
 
 
 posted in Haunted Legends: The Cursed Gift Collector's Edition on Sep 4, 17 12:00 PM
I found the compass clues, but the solution "914" doesnt open the lock. Any Suggestions out there?
 
 
 posted in Subject 13 on Aug 9, 17 7:05 AM
Made it to the 2nd room using my MAC and wireless mouse. I have the lever, but can't figure out what to do next. Any help out there?
 
 
Like so many others, the professor didn't give me the key. I can't do anything further. I uninstalled and re-installed the game. Replayed the regular game, but the bonus chapter did not restart. I think its time for a refund on this game. BFG has been silent on this except for the "game update" that really didn't help my situation with the bonus chapter.

Can't do anything! Too bad! I was enjoying this game..
 
 
 posted in Nostradamus: The Four Horseman of the Apocalypse on Mar 29, 17 11:45 AM
I tried this game for 10 mins. Couldn't figure out how to use the items in inventory. Game is very slow moving. Don't understand why BFG would release this one. Who Beta tested this game?
 
 
 posted in Grim Tales: Graywitch Collector's Edition on Feb 5, 17 11:14 AM
I cant pick up Abigails ring. It will let me read the note - over and over- but won't let me pick up the ring. Playing on a MAC. Anyone else have this issue?
 
 
 posted in The Wisbey Mystery on Jan 16, 17 7:47 AM
No MAC version of this game?
 
 
 posted in PuppetShow: Bloody Rosie Collector's Edition on Nov 25, 16 7:12 AM
I get the key from the crow to unlock the box in the cemetery and game stops. I have tried uninstalling and reinstalling. Downloaded all the recommended applications per BFG. I have Mac OS Sierra version 10.12.1.

Is there any fix for this?
 
 
I cant pour the skull ingredients into the empty bottle. I can pick up the bottle, but can't find the right spot to put it to get the ingredients to pour prior to putting the bottle on the burner.

Anyone else have this issue?
 
 
I/m in the castle. Stuck on getting the current pirate token box to open. Tried "hint" but it just keeps referring back to the puzzle box. Can't figure this out.

Anyone else experiencing this issue?
 
 
 posted in Nancy Drew: Ghost of Thornton Hall on May 12, 15 5:24 AM
I haven't found any of the eggs. Are they critical to solving the game?
 
 
 posted in Nancy Drew: Ghost of Thornton Hall on May 10, 15 12:21 PM
Can't find the gears. I know they must be in the room under the stairs, but can't locate.
 
 
 posted in Lost Lands: The Four Horsemen Collector's Edition on Jan 24, 15 10:43 AM
Last chapter of regular game began to slow down and finally stopped altogether. I adjusted the options as best I could but finally had to stop playing due to game stop/freezing.

Sorry I couldn't finish. Has anyone else reported these problems.
 
 
Cant get lecture hall HOP to come up. Opened the green curtains. Have several inventory items, brush, bear figure, charm bracelet, 1//2 caduceus, partial plaque, flint. Can't seem to get anything to work. help please
 
 
I seem to be stuck. Got the curtains open, but no sparkles for HOP. Cant seem to go anywhere or do anything. Have brush, 1/2 caduceus, charm bracelet, partial plaque flint and bear figure in inventory. Any help out there.
 
 
 posted in Dark Lore Mysteries: The Hunt for Truth on Aug 12, 14 5:46 PM
How do I get the demons hands open.
 
 
 posted in True Fear: Forsaken Souls on Aug 8, 14 12:34 PM
When is the sequel scheduled to Beta Test or Launch? I would be interested in Beta Testing this sequel.
 
 
 posted in Fright Collector's Edition on Jul 1, 14 1:23 PM
HOS in Room 2

Stuck on the "tuned focus" item with the telescope. Hint says to adjust the top right knob. Guide gives no info as to what I am to focus on. I assume it's the barn.

Game will not let me back out of the HOS without completing it. Any help out there?
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator