Posts created by moxiemoll

 
 
 posted in The Musketeers: Victoria's Quest on Jan 20, 15 1:52 PM
If you click on the cat on the barrel, you'll get a "Sharp Eye" Found the thief trophy. With the 1st trophy the message in the bottle, (for starting the game) you'll get a Cunning Fox trophy for earning 2 trophies in one level. Thought that was cool, but haven't found any other hidden items that can be clicked on. Would have been cool if they had more hidden things to find. You can only view the trophies in the main screen, so that means closing the game just to view them.
 
 
 posted in The Musketeers: Victoria's Quest on Jan 20, 15 1:37 PM
Replayed and was able to get to the balloon.
 
 
 posted in The Musketeers: Victoria's Quest on Jan 20, 15 1:34 PM
I am having problems with not having enough wood to give to the stone idol. It requires 15, but everytime I play, I only have 10. I have to upgrade the gold shack to level 2, and even when I harvest wood from the large pile, I still only end up with 10. Did anyone else have this issue? I can't continue the game.
 
 
 posted in The Musketeers: Victoria's Quest on Jan 20, 15 9:35 AM
Same thing here, hope restarting helps.
 
 
 posted in Agency 33 on Sep 11, 14 8:50 AM
Use your amulets, and play everyday to get the 7 day 400% energy amulet. I've got one more day left... but besides that, I think those scenes were developed earlier and they just forgot to lower the energy to 42, at least I'm hoping so because it's a pain to need 3 of the 3 star items from Rio to craft my next 3 items, and I haven't hit one yet...
So I think they need to lower this one, like they did all the rest. Make their fans happy.

Also use the other amulets for 300% experience and 300% coins. And the 50% crafting one, you can create coffee and anomaly traps for no time stamp! These really help and are so worth the cost of 900-1400 coins.
 
 
 posted in Agency 33 on Sep 11, 14 8:36 AM
FYI There is some really good information in the "Helpful Links for Agency 33" post. Check ~ "Explanation of Challenges: How to Vanish/Summon - FAQ"
This has all the info on each one, and how to both vanish challenges and summon challenges. If it is just to vanish/summon, you don't have to play the scene to complete the task.

Helpful Links for Agency 33
 
 
 posted in Agency 33 on Sep 11, 14 7:36 AM
I got a random chest with 4 items, salad, relic piece, a distortion mirror and an amulet from the english garden.
 
 
 posted in Agency 33 on Sep 11, 14 7:20 AM
cajun69queen wrote:Hey guys, just a heads up, depending on what country you are from may be part of the reason we are having difficulties. I was playing the games and found that if my friend hadn't served overseas in England, I would never have known that they call a "FLASHLIGHT" here but they call it a "TORCH" over there, I was having trouble and he asked me what was I looking for and he was looking at my screen and pointed to the flashlight and told me to click there. So I did and he was correct, so some of these items that we are familiar with by another name may be correct where they are from. But I definitely agree, having to use a hint to decipher what they mean is getting a little frustrating. As is the glitch that I'm having with collecting the awards that you get for completing certain things, like "Faster than Hermes". I'm still trying to find out who to tell that stuff to. I have screen shots and am now up to 15 that I am unable to collect.


Hey cajun, this was reported, the issue with not having the extra pages in achievements. I am lucky that I am only missing page 2 on one of them, others only have page 1. If you have errors, search for them in this forum, and add your info, if it is new list them for others to see, and also put them under the technical issues thread.
I didn't see one for torch that was a flashlight. The artist scene has one that says lamp, and it's a flashlight. There is a torch in the Asian Market and it's an actual torch... I figured that some were language issues, like skittles for a bowling pin, but if you look at the lists, some just cannot be identified, like boom for an arrow or tube for a pipe. It's easy to recognize them after playing a few times, but when the words are scrambled, that means using a hint 20 times... at least hints are plentiful and we have hundreds to spare!
 
 
 posted in Agency 33 on Sep 11, 14 6:28 AM
Doesn't it? I hoped it did make sense, I was making it up, and I could be wrong. LOL! Inquiring minds want to know... that's a good thing annibelle.

I have to agree, so much to do! But that's what makes this game fun. It just takes such a long time to get there! AND I think it's getting worse. I noticed they stopped giving more of the instructions (for crafting), now it's 2 at a time, instead of 4 or more. At least the quests are only 5 each instead of the usual 12 or so, and the cost it going up.

The only glitches I had were the ax/shield glitch at the crypt and not being able to pick up the picture in the mansion courtyard. I started over, since i would have quit if I couldn't progress. This time around I couldn't chop the poisonous flower, but that is minor, since it can be bought for 2 or 3 gems. I am gathering items for the library now, and discovered it cost 60 energy when I leveled up in Rio. That is just crazy! I hope that is changed in the next update! It will mean less play time and more waiting!
 
 
 posted in Agency 33 on Sep 10, 14 12:02 AM
Sorry for not posting back, it was an apple. The hint was right, and that worked. I didn't even realize there wasn't an amulet of good luck, good catch!
 
 
 posted in Agency 33 on Sep 9, 14 11:58 PM
Bridog, you may want to read the info for handing the photos, others had the same issue, but kept trying and they were able to give them to the scientist. There is info on the forum for this. I think you have to click on the photos and place them on the scientist, like you're handing them to him. If that doesn't work, you may have a glitch. I don't remember if anyone was having this issue. You may want to post one that says you're having issues giving the scientist the photos.

You can delete the Agency33 file, (or save it elsewhere) no need to send it through skype... go to

C:\Users\your user name\AppData\Roaming\EleFun Games

Delete the folder Agency33 (or save it elsewhere). When you play again it should create a new game. No need to send it or anything, this will restart your game. If you want to save it just cut and paste it to your desktop or somewhere you can find it. If they ever get a fix for the axes and picture in the ground, then you can go back to it by replacing the one in that same folder. I started over, so I've finally passed that point and my axes worked, I was able to pick up the picture. The only issue I've had this time around, was I could not chop the poison flower, but it only cost 2 or 3 gems, so it was fine. I've made it through the library and I'm working those tasks in the library. So if you want to start over, the same issue does not happen. It would have killed me if it did, I don't think I'd still be playing...
 
 
 posted in Agency 33 on Sep 9, 14 11:47 PM
annibelle, this one may still sparkle because of the directions for the map, since I can't see it ever being used again.
 
 
 posted in Agency 33 on Sep 9, 14 11:45 PM
Okay, this one is just wrong... the compass in the polar station is behind your avatar name... didn't see it at all and had to use a hint to find it. So if you're looking for it, click behind your name it's there.
 
 
 posted in Agency 33 on Sep 9, 14 2:57 PM
Have you played the Rio scene yet? It asks for a bird, and there is a flamingo, rooster, parrot, pigeon.... the bird is the same as the symbol from the Observatory and Fashion Museum. So when it asks for bird in this one, don't look for a canary or finch. lol
 
 
 posted in Agency 33 on Sep 9, 14 2:47 PM
Alikatt8 wrote:Not that at matters (mis naming as we are used to it) but it might help newbies

Alchemy Lab
Comb should be hairbrush (in other scenes, a comb is a comb)

Fungus Hut
Tube should be a pipe
Passionfruit should be Papaya
Wreath should be garland or Lei
Pin should be peg

Library
Flask should be Perfume
Crystal should be Emerald


Thank you for posting. It does helps others to know what is in the scene and what to look for. One in the library I had to use a hint on was the shawl. It's that folded ribbon tied square under the table. You're right that we are used to it, but sometimes one has a memory moment... especially when the timer is counting down and the words are scrambled, and you really want to get that relic piece that is coming up...
 
 
 posted in Agency 33 on Sep 3, 14 8:01 PM
You can get a 50% reduction in time amulet for 900 coins. I usually buy that one to reduce the time it takes and then use my time stamps, and recently not so wisely... so I'm almost out. I guess i have to tackle a scene with anomolies to get more. But using your amulet (and you can also craft these) helps!
 
 
 posted in Agency 33 on Sep 3, 14 7:57 PM
I actually had that happen, could not get the painting AND I lost my axes in the door of the crypt. So I started over. Wasn't sure when they would have a fix. And now I'm a little past that point. Just dissolved the crypt and am waiting to craft my axes and shields to see if this is going to work this time!
 
 
 posted in Agency 33 on Sep 3, 14 7:53 PM
You could use your time stamps to reduce the time to create an item. I have been using 3 - 8 hour stamps to complete some of the items. Makes it go faster. Or use your amulet that reduces the amount of time by 50% or 75%. That last one is great and you can also create these...
 
 
 posted in Agency 33 on Aug 31, 14 4:38 PM
Try the gallery, (where you had to put the picture from the Mansion courtyard grate), this will give you the wine to pour in the grate/drain to get the ax.
 
 
 posted in Agency 33 on Aug 31, 14 4:25 PM
I have a quest to create the Amulet of Good Luck, but the picture is of an apple, which is energy? Do you know what I need to craft here? I looked but didn't find this question, and I'm sure I asked it once before.

Okay, hints point to an apple, so I'm ignoring the Amulet, have to get items needed in order to complete, but I'll post back if it works.
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator