Posts created by Scobeaux

 posted in Cursed House 4 on Nov 16, 17 9:10 PM
Thank you, Aurich. Thanks for sharing your expertise!
 posted in Cursed House 3 on May 24, 16 9:21 AM
[Removed by Moderator]
 posted in Cursed House 3 on May 23, 16 4:32 PM
I too enjoyed the previous two games so much that I bought this one without even bothering with the trial and I am not disappointed. It took a while to understand what was going on but by the fifth level I caught on. In the previous games they would give you a particular type of challenge in each of (I think) 10 levels. In this game they sort of combine several of the challenges in a single level. It pays to just look at the level before doing anything to figure out what is going on and plan your strategy. I am astonished and delighted to see that this developer continues to raise the M3 genre to new and creative heights. While it might be confusing at first, it more than repays your efforts.
 posted in Silver Tale on Apr 18, 16 6:52 PM
It is true that it takes a lot of hovering, sometimes, to be able to use a key on a chest. It seems as if maybe they programmed a very small area to react to the cursor by allowing the use of the key. I have run into this problem dozens of times but in the end it always lets me use the key if I wait around long enough. Sometimes I just go and clear more tiles and then go back to it. It is annoying for sure but doesn't prevent progress in the game. This is the only problem I have run into so far in what I find a very engaging game.
 posted in Imperial Island 3 on Mar 3, 16 8:23 AM
You can try switching from full screen to windowed mode (or vice versa, depending on which mode you are using when the problem occurs) or you can try the compatibility mode fix I described under tech issues in this forum on Feb 24. This happened to me a couple of times and I was able to work around it so don't despair just yet.
 posted in Imperial Island 3 on Mar 1, 16 9:54 AM
I think they repeat levels after a while.
 posted in Imperial Island 3 on Mar 1, 16 9:53 AM
You can't. It is a flaw in the way they have configured the trophies. You also can't get beyond 10 in the trophy category of not using bonuses. But those are not the only, or even the most important, problems with this game. If you can play at all, you are lucky! It is unfortunate, as this is a very fast-moving and otherwise fun game.
 posted in Imperial Island 3 on Feb 24, 16 10:01 AM
I was having problems with game running very slowly so I started running it in compatibility mode (for Windows 7, this is what you do: find location of win8_imperialIsland3.exe, which is probably under x/Big Fish Games/Imperial Island 3, where x is where you store your Big Fish Games. Right click this file and drag it to desktop and create a shortcut there. Right click the shortcut, click on "properties," click on "compatibility" tab, check "run this program in compatibility mode for" and choose Windows Vista (Service Pack 2) in the drop-down menu. Also check "Disable visual themes," "Disable desktop composition" and "Run this program as an administrator" and then click on OK. From then on, when you want to play the game, click on the shortcut. This worked for me (running in windowed mode) until level 60 or so, when I had to start running the game full screen for a number of levels. It started running slowly AGAIN so I went back to windowed mode and it ran OK for another number of levels at which point, I think maybe at level 80 or 90 or so, it ran very slowly for a couple of levels which I suffered through and since then (I am now at level 120) it is running OK. Of course, there are some problems with the trophies (can't get airport gold trophy because I have all the airplanes already and it wants one more) and there are certain levels where you basically just can't play them because blockage at the top makes no tiles available below, but that is another story.
 posted in Fear for Sale: Endless Voyage Collector's Edition on Apr 10, 15 10:49 AM
The same thing happened to me. Annoying.
 posted in Runefall on Feb 14, 15 8:35 AM
In general I really like this game. I enjoy the variety of the game-play and the puzzles, the tiles are adequately differentiated, the dialog is well done and even amusing at times, the music is not annoying at all. The map would be useful if it were not so tiny, but at least it shows you where there are tiles that you might need to uncover. However, there is one GIGANTIC exception which basically ruins it for me. Each level (after about level 4) is so very large that as far as I am concerned there is no way that I can finish it in the timed mode. This is a huge drawback for me because I don't enjoy playing in untimed mode as the challenge is missing. I am not a newcomer to this kind of game - I play dozens of normal M3 games with the timer and, specifically, I finished Paradise Quest and Volcania (both similar to this game, but less complicated and both highly recommended) in the timed mode. So what I want to know is this - is there anybody out there who is playing with the timer, and if so - What is your secret? What am I doing wrong?
 posted in Undiscovered on Feb 2, 15 1:53 PM
For what it is worth, I have had no technical issues with this game and so far I like it a lot.

They key to dealing with the vine levels, which to me are quite difficult, is to start near where the vines are generating and try to get rid of the blue squares that get covered by the vines. You can use your power-ups to help with this. It doesn't matter if the vines grow to cover areas that aren't blue. And make sure the vines don't grow where they block the symbols from falling and create a blank space.

I too don't get why all the threads are locked. I have been running into this more and more recently - on many forums there are almost no unlocked threads.
 posted in Imperial Island 2: The Search for New Land on Aug 25, 14 3:02 AM
On certain levels starting at level 51 and then getting really bad at about level 70, the game is unplayably slow. I had this same issue in the first Imperial Island but solved it by using compatibility mode. That does not work on this game.
 posted in Imperial Island 2: The Search for New Land on Aug 25, 14 2:59 AM
You need to get three stars and break the fast time record on a level, not necessarily in the same turn.
 posted in The Other Side: Tower of Souls on Jul 21, 14 8:09 PM
Wonderful game. Creative, colorful, whimsical and delightful, good plot, original mini-games. Normally I would hate that cat, but they did such a great job with him, not too cutesy, very clever and witty. This is a game that I will definitely replay. Please make more games like this one!

Regarding the hand-holding that some people are objecting too - I can see your point, but in reality, the cat is just telling us in so many words what the black bar hints basically say more circuitously in other games, or what is totally obvious anyway. Plus he says it so cleverly!
 posted in League of Mermaids on Apr 21, 14 10:55 AM
You need to match the pearls starting from the lower left and then moving counter-clockwise around the wheel. Use the seaweed pearls to block the dropped pearl and force it to go all away around.
 posted in Trial of the Gods: Ariadne's Journey on Jan 10, 14 11:25 AM
I am deeply disappointed that I cannot progress beyond level 29 in this game. It's not even close - usually I only get two goats - and I don't think I will ever be able to, although I have tried maybe 20 times so far. (And it's not like I am a novice at M3 games, I have played and beaten dozens of them.) The problem is that the golden pathway is not very visible to me and the time is too short, and the bonuses can't help with either of those two problems. So here I am with a game that I was doing really well on and which I really liked, but because the developers chose not to allow us to switch between timed and untimed within a single profile (so as to get by a problem level), I have to abandon the game. (I don't like to play untimed, plus you can't get all the trophies.) Many other developers allow this kind of switch - so how hard could it be? And from reading the posts on this forum, I see that others are having the same problem. Please, developers, make this change so we can enjoy your game.
 posted in Imperial Island: Birth of an Empire on Nov 20, 13 12:28 PM
You have to make a whole lot of moves in a short time. The sound changes a little to alert you that you are getting close.
 posted in Imperial Island: Birth of an Empire on Nov 8, 13 7:30 AM
I play timed and I don't like the hints because they are distracting and I want to plan my own moves. So as Sherry_Rose says, let us turn them off!
 posted in Vampire Ventures on Oct 22, 13 1:32 PM
You have to move the keys along the pathway until they get to the locks. It is kind of difficult to see, but the tiles are a bit cloudy looking on the path. You have to rotate the screen when the key has fallen as far as it can so where you want to go is below the key. Use the arrows on the side to rotate.
 posted in 2 Planets Fire & Ice on Oct 17, 13 11:20 AM
I hated this game at first, but I went back and played it for another 20 minutes or so and it is beginning to grow on me. I play lots and lots of M3 games and this one is far from the worst. I have a suspicion that there is way more here than initially meets the eye. I agree that the instructions are not very helpful but if you just plow ahead and try different things it becomes clear after a while what you are supposed to be doing. And bear in mind that their descriptions of colors, like "light green" for example, can be very misleading. It is actually more of a grey, at least on my screen.

Go to:   
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator