Posts created by Beadfisher

 
 
 posted in Hidden Fears on Nov 8, 17 10:43 AM
This games does not download properly. The first time, it took forever to install, and then blipped out of existence. The2nd time--oh yes, I did indeed uninstall it,--it said it had installed, but refused to work. So I uninstalled it again. Third time, Big Fish manager refused to work. So I turned off the computer, waited 30 minutes, and will try again.


If it does not work on the next installation, I'm not bothering with this one.



 
 
 posted in Phantasmat: Mournful Loch Collector's Edition on Apr 24, 17 7:23 PM
Beginning a game with a puzzle that cannot be skipped is an excellent way to decrease the pool of buyers.
 
 
 posted in Enchanted Kingdom: A Dark Seed Collector's Edition on Apr 6, 17 3:43 PM
Downloaded the demo, which hung a bit on validation, but installed claiming the demo had expired.
 
 
 posted in Secret Investigations on Dec 27, 16 7:02 PM
If you like old school HOG's where finding the item requires a little work, if you like to sink into a game and concentrate, this game works. The story line links successive HOG's which can be replayed to earn the number of stars to pass to the next level. Very few minigames, thank ghod.Just HOG after HOG, and the ones near the end of the case are more demanding than the early ones. Fun.
 
 
 posted in Adam Wolfe: Blood of Eternity on Dec 21, 16 7:46 PM
Why bother to offer a choice of difficulties when there is no choice? I tried to set it at custom, because 6th time I try something and it doesn't work, I want a hint. I don't want a snide comment. No hint or skip box comes up. So I cleared the profile and set it for Easy, and when the hint box eventually came up, I got the same snide remark. See, I'm not really a fan of adventure games, which are apparently geared to people who are willing to click on every damned thing hoping for a response.I'm a fan of hidden object games. If there is no response, I want to move on. No moving on in this game. No skipping, either. Surprise! This is a no-buy.
 
 
 posted in Haunted Train: Clashing Worlds on Nov 22, 16 10:00 AM
In Parliament Square, we are supposed to rub a pencil over a page. Endlessly. At first I thought only part would appear as a rubbing. I put down the pencil, tried to pick up the page, no go. I requested a hint and was sent back to the pencil and paper. Eventually got the entire tracing but still cannot advance. Every day I enter the game, rub a bit more.Nothing new shows up.Still can't pick up the page or advance. STupid game.
 
 
 posted in Maze: The Broken Tower Collector's Edition on Oct 8, 16 8:49 AM
Anyone who has ever been stuck alone in an elevator will get claustrophobia with this game. AS my life is full of electronic things with their own agendas, I'm deleting this game.
 
 
 posted in Mystery Tales: Eye of the Fire Collector's Edition on Sep 30, 16 7:07 PM
Hint button does not work in Demo. Skip button does not work in Demo. I have no interest in minigames. No skip button means I don't buy it.
 
 
 posted in Occultus: Mediterranean Cabal on Aug 2, 16 3:51 PM
The interface seems odd. I don't know if this is a tech issue or not, but it affected my willingness to play the game. You don't pick things up, you shove them along. The list of objects acquired vanished, never to return. twice. ( deleted the game and downloaded it again, just to make sure. This was not fun..
 
 
 posted in Invasion 2: Doomed on Jun 7, 16 1:26 PM
The first time it happened, I pressed Skip. and within a minute there was anew black screen for a new minigame. When the problems come up this early in the game, I don't want to spend time trying to make it work. Downloaded twice, same problem. I no longer care to try this game.
 
 
 posted in Enchanted Cavern 2 on Jul 21, 15 9:06 AM
How does one start this game? None of the buttons say Play. In spite of that I managed to get 10 minutes last night, but I've spent almost that long today trying to get back into the game... which is nowhere near as intriguing as the original Enchanted Cavern.
 
 
 posted in Grim Tales: The Vengeance Collector's Edition on May 16, 14 2:32 PM
The game will not let me play. I get a Thanks for playing, play again screen, but nothing happens when I click play again,. I deleted and reinstalled the game and the same thing happened. Yes, I have written the help people, but this is so frustrating.

The game takes forever to download, stops midway each time, and if I don't sity on the laptop as it downloads, stops entirely. Stupid.
 
 
 posted in Grim Tales: The Vengeance Collector's Edition on May 15, 14 9:52 PM
When I began running into games with slow and jerky movement, I was eventually advised to check my computer's fan.It was coated with dust,which I removed. It worked better.
 
 
 posted in Strangestone on Mar 4, 14 7:00 PM
I bought the game after playing for 30 minutes. Within 30 more I was cursing, because of multilayer minipuzzles. I love HOGs, but will tolerate minipuzzles , until they impede my progress. When I click Skip for 3 games and am still in the same spot, new layer, that is going just a bit too far.
 
 
 posted in Nancy Drew: The Deadly Device on Feb 13, 14 1:05 PM
Stink, stank, stunk! Based on reviews, I used my punch card bonus to purchase this. Technically I got the game for free, it is isn't worth it.

Bloated with animation, this so-called game takes over the computer for several minutes of exposition at the beginning. By the time it was finished, I had no desire to go further.
 
 
 posted in Dance of Death on Sep 9, 13 9:21 AM
This HO seems to require that things be done in sequence. I was not allowed to put tap anywhere until other things had been accomplished. Infuriating.
 
 
 posted in Dance of Death on Sep 9, 13 9:16 AM
I bought it, and for the most part the hints will get me past rough spots. However. There is an impossible HO that seems to demand that things be done in sequence, BD games says it has a walkthrough, but all I get is a whirling icon that says to check back later. Stuff it.
 
 
 posted in Treasure Island: The Golden Bug on Sep 4, 13 9:47 PM
The bottom of the screen lists what I am supposed to look for. Really? The bottom of the screen featured a black window with nothing in it. I uninstalled and reinstalled, Same thing happened.
 
 
 posted in Forest Legends: The Call of Love on Sep 2, 13 8:50 AM
A lengthy intro read in a hushed voice, followed by cartoon characters squabbling in a forest. Blyeah. I am not thrilled about games with Love in the title. I am thrilled that I turned off the game and learned from the reviews that there are no Hidden Objects. No reason for me to play this one.
 
 
 posted in Suburban Mysteries: The Labyrinth of the Past on Aug 12, 13 1:07 PM
I got to a certain point and got the black screen of death. I could not exit. Control Alt Delete, then uninstall and reinstall...And the black screen of death. As this is a large file game, uninstalling and reinstalling is a large sized pain.
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator