Posts created by swordsdd

 
 
 posted in Moai V: New Generation on Jan 12, 18 4:38 PM
I agree with pennmom36. I just played the demo and I couldn't get any stars. I have the rest of the series and I enjoyed the play and the challenges in the later levels. This one is impossible and playing in casual mode with no timer has no challenge. I won't be buying this game. I don't need the frustration.
 
 
 posted in Roads of Rome: New Generation 2 on Nov 2, 17 11:48 PM
Same problem here, running on Windows 7. Game worked fine until Level 22 and I keep getting kicked out, can't get past it. It's not computer, video card or any of that, it's the game.
 
 
 posted in Lost Artifacts on Oct 3, 17 1:44 PM
There are 3 statues, 2 plain ones to build and the one with gold is a rebuild. The two plain statues are on each side of the gold one.
 
 
 posted in Lost Artifacts on Oct 3, 17 1:35 PM
On Level 31, the Mill that is upgraded to level 3 is the food mill. If you upgrade as far as you can and then click on it you'll see no resources and the little guy figure. That means you've upgraded as far as you can. If you just hover your mouse over it, you'll see the level number and how many resources it gives. I'm thinking you fully upgraded the sawmill instead of the food mill. Hope this helps.
 
 
 posted in Katy and Bob: Safari Cafe Collector's Edition on Sep 28, 17 6:28 PM
I must be missing something too. I've completed all levels, all the level objectives, but there are trophies I don't have such as completing Savannah World, etc. Not sure what I've missed.
 
 
 posted in Lost Artifacts on Sep 3, 17 10:07 PM
The well is right below the bridge. You have to destroy the big roadblock to reach it.
 
 
 posted in Lost Artifacts on Sep 3, 17 9:58 PM
Build the mill and upgrade it, then collect food from the mill and the garden. Trade food at the merchant's house for wood. Stop trading once you have enough wood and then just collect the food.
 
 
 posted in Lost Artifacts on Sep 3, 17 9:53 PM
You have to keep clicking on it, which is very hard to do because it moves so fast. I think it's the third click that will catch the chest.
 
 
 posted in Lost Artifacts on Sep 3, 17 9:51 PM
Don't upgrade the Light Priest house and if you've collected all the iron bars along the road you should have plenty for the well and ancient warrior upgrade.
 
 
 posted in Lost Artifacts on Sep 1, 17 10:46 AM
Just as in the Gnomes Gardens games, I've noticed the altars only provide one of a resource instead of the two it's supposed to provide. This makes it very difficult on later levels to get gold time. Most of your time is spent waiting. Is there a fix for this?
 
 
 posted in Lost Artifacts on Sep 1, 17 9:24 AM
Make your way to the gold mine on the right beneath the mountains, build it and it supplies your gold.
 
 
 posted in Gnomes Garden: New home on Mar 21, 17 12:15 PM
This one seems a little easier than the previous Gnomes game, however, three stars will still be difficult after around level 20. Also, there is no relaxed mode and there are no trophies to win, even though the game description states there are beautiful trophies. I sure couldn't find them and I enjoy going back and winning trophies I didn't get the first time, so that was a disappointment. Perhaps that should be removed from the game description.
 
 
 posted in Weather Lord: Royal Holidays on Dec 5, 16 6:25 PM
There are 18 bonus levels at the top of the map which will bring your total to 60. I was halfway through the game before I realized they were there.
 
 
 posted in Weather Lord: Royal Holidays on Nov 13, 16 12:05 PM
I would have sworn I checked about making gold, silly me. Going back to try again, sure hope it's there and not a glitch. Thanks!
 
 
 posted in Gnomes Garden 3 on Jun 1, 16 8:12 AM
Thank you Audreypeters! Thought I was missing something I needed to do. I hadn't noticed you only get one until I really needed 4 of a resource and thought I had enough time left since I would get two each time it appeared. After only getting one, I moused over the altar to double check and it showed the gain would be two. Of course, I had to start the level over then. Yes, irritating!
 
 
 posted in Gnomes Garden 3 on May 30, 16 5:53 PM
Altars provide random resources and are supposed to provide two of the resource when it appears, however, I'm only receiving one. Anyone else notice this or am I just missing something?
 
 
Went back and tried different things. You have to find the three snakes, so might not be jugs each time, seems we might need to figure out what needs collected.
 
 
Can't see even one jug anywhere. Am I missing something or are the jugs missing?
 
 
Same for me. I have the 18 artifacts, but states I only have 17.
 
 
 posted in Rescue Team 3 on Dec 8, 13 3:42 AM
I've noticed that clicking directly on something often doesn't work, the clicking area is off. Try clicking the mouse just below the item, that's what works for me.
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator