Posts created by reddleman

 
 
k_tgirl I'm stuck in the same place as you. No matter how many times I hit the hint button, it doesn't give me a hint. All it does is show me the action that needs to take place to move on. What a piss-poor hint button and strategy guide.
 
 
 posted in Haunted Hotel: Death Sentence Collector's Edition on Jan 5, 15 2:39 AM
I finally found why I couldn't get the note. Thanks to no one for their help. I guess you need to go elsewhere for help because no one helps others here. Thanks a lot for the no help. Thumbs up to you people. Oh yeah, if you need help just come to the forums. NOT!! Thank you, Google, for your help. I sure as hell didn't get it here. This is why I don't post that often on here. Everyone is stuck in their clique that they may have the answer but if they feel you don't belong they say screw you. BigFishGames forums is one of the most unfriendliest game sites there is to seek help.
 
 
 posted in Haunted Hotel: Death Sentence Collector's Edition on Jan 4, 15 3:05 AM
I'm stuck. I could use some help. In the first scene you go in a boat and there is a HOP to play. I found everything but the note. I clicked on the hint button and it showed right under the bell. I clicked and clicked to no avail. Am I missing something? The item is in white so there should be no other action. Or did the clapper in the bell not appear and that is why I can't ring the bell to create a note? Please help. The strategy guide is useless for this. Whatever happened to the days where they actually had the HOP's in the strategy guides? Did the developers get lazy and say we don't care? I love playing these games but the developers better understand that if we get pissed off because they get lazy, that means no sale. I don't usually use the strategy guide but I needed it this time and no solution whatsoever. Thanks Elephant Games for being lazy and for saying screw the customers. If it wasn't for us you wouldn't be in business.
 
 
 posted in Revived Legends: Titan's Revenge Collector's Edition on Jan 1, 15 2:00 PM
@cookie....sometimes the download doesn't always appear in your game manager when downloading. You have to click on Queue to see it.
 
 
 posted in Myths of the World: Black Rose Collector's Edition on Oct 25, 14 1:23 PM
tictacsix, Google the error code. It will tell you exactly what it is and why you are receiving it. Then you'll be able to fix the problem.
 
 
 posted in Spirit of Revenge: Cursed Castle Collector's Edition on Aug 21, 14 10:15 AM
Uninstall game and then download the game from your game manager. Click bonus and click yes to wipe out what you have played. Then click on the level that you want to play. The bonus game should start for you.
 
 
 posted in The Other Side: Tower of Souls on Jul 20, 14 9:43 AM
How do I stab the evil heart? I tried and tried with the dagger, but nothing happens. The hint doesn't verify how to do it. Plus it takes so long to recharge.
 
 
If someone has no family whatsoever, wouldn't that make the parents dead. If you were 5-years old and your family suddenly disappeared, wouldn't you think that now you are an orphan? There is no family whatsoever. You had to have been created by someone. Not unless they can create babies in a laboratory, then I missed something. Then again, James Patterson's Maximum Ride and her flock were created in a laboratory. Maybe I too came from a laboratory. Then that would explain the expiration date printed on me. Gotta go. 2 days before the date.
 
 
I was under the impression that just about everyone had broadband. I can download 60mbps. I can download as much as my hard drive can hold. I didn't know that some had a limited amount of download. Now I understand the comments you people made. I'm sure glad I use cable as my Internet Service Provider.
 
 
 posted in Tales of Terror: House on the Hill Collector's Edition on May 23, 14 11:28 AM
The fix didn't work. Now the game won't even open after I installed the fix. Looks like I'll boycott this developer since they can't get their heads out of their you know what. I wish BigFish had more balls to tell these idiots that they need to come up with a genuine fix now. Not a day or two from now, but yesterday. This gets real frustrating when you pay for these games with your hard earned pay and then you buy a game from a developer and you get something that doesn't even work. Bigfish needs to let us beta test these games the whole way through and not just a measly 60 minutes worth so such incidents like this doesn't happen in the future. BigFish has pissed a lot of customers off on this one. I've been a member of Bigfish for years but when they pull something this big that angers a lot of customers it tells me that they don't care about us and the only thing that is truly on their minds is the money. I guess I'll have to count this purchase as money down the drain since it will take Bigfish until Tuesday to respond since they don't supply 24/7 support like a respectable business would. I sent them an e-mail and of course they sent me an automated response that it'll be 48 to 72 hours before they get back with me. Hell, I could be dead within that time frame. So what the hell good did it do me to try and contact customer service that only replies with automated e-mails instead of a real concern about the problem. It makes me think that Bigfish has outsourced their customer service to India. To big companies the dollar always outweighs the customers. What a shame it is to live in a land that at one time companies held pride in their products and customers but now sees it all through green-colored glasses. Yes BigFish, that is you. You'll take our dollars, but you won't provide 24/7 support so we can get these issues resolved in a timely manner. You sit back and laugh at your members/customers saying, "We got their money. If we wait long enough to respond, maybe they'll forget about the issue and just buy another game to continue on what they love doing. What a racket we have going. Okay. Time to tally up the money. Man we have gotten rich off these suckers. What saps they are. The longer we wait to respond, the richer we get."
 
 
 posted in True Fear: Forsaken Souls Collector's Edition on Mar 7, 14 2:15 AM
Where do I get the fourth chess piece? I can't go any further without doing the puzzle with the compass because I don't have the fourth chess piece. I tried the hint but it was no help and the strategy guide was no help either. Please help.
 
 
 posted in Shadow Shelter on Jan 23, 14 3:32 AM
I loved this game. A lot of people said it was too dark. It was crystal clear on my computer. The map was very useful and the game was easy to navigate. The only thing I hated about the game was having to sit through the credits. No matter where I clicked or how many times I clicked, I couldn't exit the game until the credits was done.
 
 
 posted in Shadow Shelter on Jan 23, 14 3:26 AM
Just scroll the map to the right. Then click on the exclamation point.
 
 
 posted in Shadow Shelter on Jan 23, 14 3:22 AM
The thistle has to be in the locket. Did you put the owl on the gated door?
 
 
 posted in Who Am I on Jan 17, 14 11:31 AM
They use to be good about putting up a walkthrough, but not any more. I guess they got fat and lazy. All that money they made off of us got them to eating that rich food and bloated them up like a whale so they can't even move and help us out by creating a walkthrough. That's what happens when people get rich. They say, "Screw the poor people. We don't give a damn about them." BigFish is no different than the Donald Trumps in this world. All they care about is the money and screw the little man. If they really cared about their customers they would have had a walkthrough up already. They are a good site with the deals they offer, but they have gotten lazy. And I mean real lazy. If I ran this operation, I would be a slave to my customers. If they want a walkthrough, I would give them one. But BigFish just doesn't care any more. That's why I think they're going under. I think BigFish is going to collapse because of the lack of customer service that at one time they use to rule. Not any more. They suck in that department. If you people at BigFish read this, take heed into what I say. It's so true and it's what all your customers are thinking.
 
 
 posted in Mysterium: Lake Bliss Collector's Edition on Dec 21, 13 6:47 AM
Thanks for the review, JustTheFacts.
 
 
Thanks, KIW0612. I couldn't make heads or tails of what they said. The only word I was able to make out was virus. It's a good thing I don't live in Germany.
 
 
 posted in Enigmatis: The Mists of Ravenwood Collector's Edition on Oct 10, 13 11:11 AM
I thought I collected all three of the pieces but apparently I never got the one from the cell door. I played that part of the game and when I went back I replayed that scene but no piece. How do I get it? Maybe I didn't get from one of the other scenes but I replayed them all and nothing. Now I can't continue the game. Please help. Thanks.
 
 
I'm an American, JustTheFacts, and I take no offense to your comment. If every other historical figure can be used in games then so can the presidents of the good ol' U.S. of A. I like learning about the history of not only this country but every other one as well. Since I never paid much attention at school during history class, I figured I may as well now. Plus I'm older and wiser now. Much older. Much, much older.
 
 
 posted in Nightmare Realm: In the End... Collector's Edition on Jan 11, 13 10:49 AM
You have to keep swinging it back and forth until it gains momentum to break the statues head.
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator