Posts created by 77Emma77

 
 
 posted in Maze: Subject 360 Collector's Edition on Aug 16, 15 12:20 PM
this misplaced glitch prevented me from clicking on one of the collectible spirals in the basement with the coffin. just saying.
 
 
I came to the puzzle (great ones, btw) where I have to hide arrows corresponding to the color of the flags. When I hide yellow arrows, the flag wraps up. But the other flags do not do that when I follow the color order and hide the arrows. Why is that?
 
 
It seems I am one of the unlucky players, too. Exactly as mentioned, the back tracking is not possible and I am stuck. The hint button advises me to do something that is not possible and I do not have any other clue what else to do.

 
 
I have nothing else to do in the game at the moment, except of walking off the Augustine Strasse, which the hint button also suggests. But it does not let me do it and on the map it also does not offer this direction.

What is wrong with this game?
 
 
 posted in Nancy Drew: The Deadly Device on Aug 4, 14 2:59 AM
Well, this forum does not seem to be visited too often. I found a good hint page here: http://www.gameboomers.com/wtcheats/pcNn/ND27/ND27.htm
It helped me with a few puzzles where I really struggled and even if it is not in chronological order according to the game, I actually found it helpful as it gave me an idea what will be needed to do in the future and helped me to solve things quite quickly. Maybe a spoiler for someone, but for me, who wanted just have this game finished, it was a bless. I did not enjoy this game that much.
 
 
 posted in Nancy Drew: The Deadly Device on Jul 27, 14 12:29 PM
I am stuck. Only two tasks remain: investigate the Ryan's threats and Investigate Ryan. None of the persons seem to have something new to tell me and none of the objects I came across seem to have something new to offer to me right now.
 
 
 posted in Nancy Drew: The Deadly Device on Jul 27, 14 6:46 AM
As Sue said, I got it right on the third try. I am ashamed I missed that central piece, it should hot have happened, but finally I got that right. You will know when it is right. Nancy speaks out.
 
 
 posted in Nancy Drew: The Deadly Device on Jul 27, 14 6:44 AM
I figured out to do the tests when he sleeps - during the day. I have tested it, all good But I also got caught - once. Tempted to do it again, then I got this good idea.
 
 
 posted in True Fear: Forsaken Souls Collector's Edition on Mar 18, 14 1:58 AM
tammytheo, thanks, I only scanned first page of posts and did not see this issue, so I posted my own.
However, this is probably the first time I remember being allowed to do the mini-game or puzzle before I have all pieces in hand or being made aware that something is still missing. That was why I did not get it.
 
 
 posted in True Fear: Forsaken Souls Collector's Edition on Mar 17, 14 11:33 AM
One of the puzzles in the second chapter cannot be finished cos one of the vertical straight rail piece is missing. Every time i leave the puzzle and then return back, one appears on the left side, with zero next to it, not being able to pick it up and place on the last missing position. When taking one of those from the already assembled line and putting back to the left, the zero changes to 1 and when taking that piece again, the one that was there previously with the zero disappears. When repeating: leaving the puzzle, then going back to it repeats the thing. Even the doll does not seem to be charging for skipping the puzzle. I have a CE version.
It is a good game otherwise.
 
 
 posted in Brink of Consciousness: The Lonely Hearts Murders on Feb 26, 13 12:32 PM
just finished the game.
lengthy dialogues, but well made, with good british english, some funny moments.
it was boring sometimes, but ok as it was not too frustrating for being too difficult and the hint was helpful. the numerous back and forth was slightly over my liking.
did not like the detective having young frame and face but they made him look old at the same time. it looked artificial.
slow loading, mentioned previously, also did not add to the enjoyment.
the game looks as it will have a continuation.
 
 
 posted in Motor Town: Soul of the Machine on Feb 19, 13 12:52 PM
just finished the game. not bad. the scenes were good, plentiful but sometimes i wished there was more to be done at each as it appeared as a waste of effort to create a scene and do only one or two things in it (maybe i am underestimating).
the code on the locker was a true puzzle to me. but i made it. not wanting to spoil it i want to say that the one who created the code missed one important point about how the numbers are coded with this system and confused people. but i feel proud i managed it on my own without going to walkthroug or asking for help. other interactive hidden objects were also quite illogically placed and hint was helpful.
the man that someone found him like elvis - he reminded me john travolta much more than elvis, lol.
and i do not like very much one HOS after another on the same place. this was the weak point in it.
 
 
 posted in Mystery Legends: Beauty and the Beast on Feb 16, 13 1:47 PM
what a beautiful game it was! i loved the detailed and high definition alike sceneries, music was perfect and the voicovers, especiall the spindler were genious. the number of sentences that were made, i could listen to him for a very long time and enjoy the humour and creativity one has put into the monologue. but the pinocchio was rather bothering with the voice.
this game felt truly like watching a disney. only some hidden objects were too well hidden that i had to use the hint and i dont like the to be punished for fast random clicking, please dont do it again.
some items needed a visionary spark otherwise one could only refer to the walkthrough after running off the idea about what to do or how to use them. i did not have to and that makes me feel an achievement. not going to spoil it by saying which one it was, just mentioning the scorpion fixed. i dont know how i managed to get the idea, lol.
 
 
 posted in The Theatre of Shadows: As You Wish on Feb 8, 13 1:39 AM
same here. the hint keeps pointing me to the book in the cave, otherwise in all other areas it says that i should search elsewhere. but nothing happens. i click like an idiot and the only response is the single sheet of paper with text.
the circle puzzle over the bed keeps saying it is missing part but i cannot find it anywhere. walkthrough does not help. i am missing the last red part for the aura vessel.
 
 
 posted in Grim Tales: The Stone Queen on Feb 5, 13 10:03 AM
this is my input for future improvements, just minor things, i guess.

the game itself is beautifully made, i was quite surprised by the detail and artistic make up. the characters were lovely, especially the three small goblins. there were few funny moments, such as the blacksmith that beated tiny items with its huge hammer to mend them. the voice overs were truly lovely to listen to. and when i thought that i came to an end of the game, it continued - a nice little surprise. but the final ending was quite short and not quite fitting the whole game in comparison how much effort the developers put into making it all.

more critique:

1. firstly, i did not like the reset or continue offer, as there is a risk that one will click on reset by mistake and can start again. not a good idea.

2. i believe the developers were trying to make the characters look like they were living and they incorporated the breathing movements into their body... i would prefer them to avoid it as it looked funny after all. too mechanic.

3. the welding glitch or omission was annoying. the poor goblin kept welding even after the piston was replaced and the mechanism worked. what is more, the sound of welding was heard all the way during solving the puzzle there and it kept welding till the end of the game. what a shame they forgot to mend this.

4. someone has already mentioned some illogical actions in terms of using the items. i truly do not understand why the scare crow had to be burned to get the hexagon key?

5. i am not sure what caused the cursor moving rather slowly during the game and it froze once completely.

that is it.
i liked this game and it reminded me the mystery trackers beautiful make. keep on doing a great job devs.
 
 
 posted in Grim Tales: The Stone Queen on Feb 4, 13 8:05 AM
that was totally annoying. i had to skip it and from what i could see that happened after doing that, i was dead on the half way through...

i guess you have to figure out which of your character is figting in which way and which directions on the field and position them accordingly. but still, some of the enemies kept hitting me while i was not able to return a single hit. i think this puzzle was far too complicated to be a puzzle in such a game.
 
 
 posted in Grim Tales: The Stone Queen on Feb 4, 13 8:03 AM
have you anyone experienced the same?
the game is beautiful, graphics, characters and their animation, including the voice overs... when i brought light to the hole and let the creature speak about how cold it is, the game froze. i could not offer an item from the itinerary, i could not move on, exit the scene, nothing, just control-alt-delete or other way of exiting the programme.
i think my pc is good enough with having 4gb ram, but i have experienced slower response of the cursor to my intentions.
 
 
 posted in The Dark Hills of Cherai: The Regal Scepter on Jan 31, 13 11:16 AM
same here.
the trident does not work at the obelisk, i have got a number of the medallions, mantra, two bags of blue and red powder, flame for ignition of the canon, but no fuse in sight, only two signs in the telescope, and i am not let through the gate as one of the charactes until tara does not finish her things, but nothing worked.
i have tried every single option for several times and there is nothing to do, the hint only keeps telling me to move on or try to place the items onto the peacock, which i did a couple of times with all items - no clue. i guess it is the ladder or anything that would enable me to get the watering can. the key for the third sign is still stuck to the wood and i need to water the roots of the tree in the same scene...
 
 
 posted in Nightmare Adventures: The Turning Thorn on Jan 28, 13 10:21 AM
Mamalita wrote:I put it in sideways. That seemed to work.


is there a way how to make it sideways? when i click on the extinguisher in my itinerary, it only keeps one position all the time. i doubt i can manipulate with the orientation of this extinguisher.
 
 
 posted in Nightmare Adventures: The Turning Thorn on Jan 28, 13 10:19 AM
prpldva wrote:Sorry you are having trouble. The only thing I can think of is to make sure you have talked to Jillian, You will talk to her before you enter the elevator, after you enter the elevator and once again before you leave.

I hope this helps!

Game on!


PrplDva


not at all, mate. was it a joke?
I AM in the elevator which is stuck and the only thing i can do is that I find the way how to block the door from closing. the talk does not happen as i guess i need to sort the door first. even the badge will be given to me after i sort the door, otherwise it is pointless.

i have about 5 minutes left of the trial version. if i dont find out first how to do it, i am not going to purchase the game, which i would like to, actually.
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator