Posts created by monapool

 
 
I have used the light pollen to match the symbols, but can't seem to get the third set matched. Any suggestions?
 
 
 posted in Dreampath: The Two Kingdoms Collector's Edition on Jun 26, 14 12:31 PM
I've gotten to the "find 15 arrows". I keep finding what looks like pieces of another puzzle, eg. part of a cat's head and a face. but still have only 14 arrows and don't know what to do with the other pieces I've found. Guide is not helpful for this puzzle.
 
 
 posted in Surface: The Pantheon Collector's Edition on Oct 20, 13 4:40 PM
I have clicked everywhere on the rock with white circles and can't find an egg anywhere.
 
 
 posted in Hallowed Legends: Templar Collector's Edition on Nov 17, 11 3:20 PM
I'm in the same boat! I have tried clicking on all parts and it keeps falling back inti inventory. HELP!!!!!!!!!!!
 
 
 posted in Lost in Time: The Clockwork Tower on Jan 13, 11 9:16 AM
Why can't I find this? I have looked in the walkthrough to see where it is and when I get into the game, it is not there. Help!
 
 
Thanks. I kept going to the one on the side too forgetting there was one by the wheel barrow.
 
 
How do you get to under the fountain to get the map pieces? I have not found a way to even see it!
 
 
 posted in Dream Chronicles: Book of Air Collector's Edition on Jul 12, 10 8:18 PM
I have played this game from start to finish 3 times and there is no bonus game showing. What's up with that?
 
 
 posted in Dream Chronicles: Book of Air Collector's Edition on Jul 7, 10 7:59 PM
Once you have finished with all there is to do at the clock makers, go back to the air ship, go to the map and ckick on the reveal button on the left side. It will tell you the coodinates for the next place.
 
 
 posted in Special Enquiry Detail: The Hand that Feeds on Jun 8, 10 4:18 PM
I am in the lab and have enhanced pic#4. I have moved he things so that the page is as clear as it can be. There is no other writing on the page except for what is written. When I exit off the computer, it still has those sparkles and if I click on the picture of the guy lower left, nothing happens. How do I get past this?????????? Helppppppppppppp!
 
 
 posted in Masquerade Mysteries: The Case of the Copycat Curator on Apr 30, 10 10:49 AM
I have tried to put the magazines on the table and am having the same problem. I would really like to continue this game but can't. Any suggestions?
 
 
 posted in Masquerade Mysteries: The Case of the Copycat Curator on Apr 28, 10 9:51 AM
Has anyone had problems organizing the the lobby? I have done everything except putting the magazines on the coffee table. Everytime I try to put them on or under the table, they keep going back to inventory. Can someone help?
 
 
Loved this game. So much to do! On to the bonus game. I made it as far as finding the magnifying glass. The strategy guide says to run the glass across the front of the house to find the wires for the alarm system. When I click on the alarm box with the mag. nothing happens. It does not enhanse the box. Any suggestions?
 
 
 posted in The Fall Trilogy: Chapter 1 on Mar 8, 10 12:06 PM
Thanks Fred but how do I get to 360 view?
 
 
 posted in The Fall Trilogy: Chapter 1 on Mar 7, 10 8:47 AM
I am having the same problem with aligning the mirrors. I have gone back several time to start from the tripod and get stuck every time. HELP!!!!!!!!!!!
 
 
 posted in The Fall Trilogy: Chapter 1 on Mar 7, 10 8:45 AM
GEMINICHICK wrote:I down loaded the game a month ago and really enjoy it . I have passed all the puzzles...I think. I am on the aligning the mirrors and i am haveing some trouble i have 4 to go...can anyone give me some pointers please thank you
 
 
 posted in The Fall Trilogy: Chapter 1 on Mar 7, 10 8:43 AM
You have to put the rock in the middle of the scales on the lower part of the scales. The gate will open.
 
 
Loved this game! So much to do. I am having problems in the bonus game however. I seem to have a magnifying glass attached to the cursor that I can't get rid of and it dosen't magnify the box by the front door to disable the alarm system. Any suggestions?
 
 
 posted in Dracula Origin on Feb 24, 10 2:04 PM
Thank you Mr. Russ. I haven't played for a few days as I was finding this frustrating. I'll give it another try.
 
 
 posted in Dracula Origin on Feb 23, 10 2:36 PM
I found my way into the parlor and the map. How do I draw the lines on the map? I"ve tried holding left click and going from piont A to point B. Nothing happens.
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator