Posts created by themaestro023

 
 
 posted in The Tribloos 3 on Apr 22, 18 10:33 AM
Hi Andy,

I asked you about 3 or 4 years ago about another Tribloos and at that time I think you were developing some other ideas, but boy, have you delivered with this! Fantastic mate. Very inventive and difficult in places, especially level 30. I love all the new bits you've included plus an old favourite, the BirdScarer.

I must have played Tribloos 2 at least a hundred times and now I've played Tribloos 3 ten times already but cannot get 3 stars on level 30. I'll keep trying because that's the fun of your Tribloos series. The playability is endless.

You asked during the credits if we want another Tribloos, my answer has to be, Yes Please. (Hopefully it won't take so long to make as this one. Five years?)

Keep up your excellent work.
 
 
 posted in Roads of Rome: New Generation 2 on Nov 4, 17 8:50 PM
Hi All,

Sorry if I upset anybody, won't happen again.

Update: It's not just a problem with this game on BFG. Other forums are reporting the same issues from wherever you download it. Those who can play without issue, think yourselves lucky. It's not a problem specific to an OS or machine.

Let's hope they find a solution soon, it's a good game.
 
 
 posted in Roads of Rome: New Generation 2 on Nov 3, 17 5:22 PM
bfgBeruna wrote:Hello Everyone,

I'm incredibly sorry that this game keeps crashing. I really want to help fix this, so I'll recommend some troubleshooting steps that have helped players in the past.

When a game crashes, updating the computer's video card driver can be useful. This driver is responsible for directing the computer's graphics, and when it's not working properly, the impact can be significant. The following help article contains instructions for that process:

Run Game as Administrator

Please also try running the game in Administrator Mode. This increases the games permissions and can be a really helpful step to take. The help page below will walk you through that process.

Run Game as Administrator

Should these steps not fix the game, or should they not address your inquiry, please contact our Technical Support Team. They'll be able to provide a new solution. The other moderators and I are also reachable by PM, so please let us know if we can answer any questions.

Thank you so much for your patience and understanding.

bfgBeruna


This does not help!! Can't you see how many people are having problems, [Removed by Moderator]

The devs are not the problem either because if you download this game from anywhere other than BFG it plays with no problems whatsoever.

Give me my money back, cancel my membership and I'll buy elsewhere.
 
 
 posted in Roads of Rome: New Generation 2 on Nov 2, 17 7:21 PM
Keep being kicked out of game just like everyone else on here. Am running Win 7 Ultimate. I've been to many forums today to find a solution thinking it was my equipment only to find it was your game with a fault. I nearly reinstalled my OS but fortunately saw this discussion first.

I've tried playing the game with explorer turned off, also turned off Aero 3D and still this game crashes. I've finally made it to the very last bonus level but have been kicked out 3 times and am not touching it anymore until a fix is found. Don't try telling us it is our equipment as if you look at the many posts in your 'tech issues' area, I am not the only one. It has to be a fault with the game. Hire better devs next time!!
 
 
 posted in Roads of Rome: New Generation 2 on Nov 2, 17 8:29 AM
I've played 30 levels so far and it's nice to see this old favourite brought up to date but am stuck finding all the hidden caches on 25 and 26. I've found all but one on 25 and am missing two on 26.

I know if you demolish some buildings after ensuring you have enough wood to rebuild them that the caches can sometimes be found behind them, but on both these levels I am really stumped. Can someone please tell me where they are?
 
 
 posted in Haunted Hotel: The Axiom Butcher Collector's Edition on May 1, 16 6:42 AM
Win 7 Ultimate, twin Radeon R9 200 series graphics, water-cooled system.

I mentioned the above (water-cooled) because the problem I'm having has been suggested due to over-heating of the graphics cards, but that is not the case this time.

The screen flickers with horizontal lines when I play any game from Elephant Games. This only happens a few times per scene but does not help when I am trying to complete an HO scene. It also occurs during the video cut scenes. I have manually adjusted the frame rate to 55fps which usually cures this problem but with this particular game any setting does not work and the flickering continues.

I particularly like this game and would like to buy the CE but with the flickering, it's not worth it. What do Elephant Games have running that would cause this problem?
 
 
 posted in Delicious: Emily's Home Sweet Home Collector's Edition on Jan 17, 16 7:31 AM
I can do the level (57) but cannot find the mouse. Any help would be appreciated.
 
 
 posted in Moai 3: Trade Mission Collector's Edition on Jan 10, 16 4:39 PM
Lieke60 wrote:Clear everything to the right, then cut enough trees to build a hut to get 6 workers, repair temple and then you should be on your way. Hope it helps


Thank you so much, I was tearing my hair out trying to think of a way forward. You're a star!
 
 
 posted in Moai 3: Trade Mission Collector's Edition on Jan 10, 16 4:35 PM
Am stuck on level 50A. You only start with 60 manna and there is no way to get more but you have to build the temple and appease the god but there is no way of getting any more manna. If someone knows the answer to this (have read the inbuilt guide and no luck) then please let me know.
 
 
 posted in Moai 3: Trade Mission Collector's Edition on Dec 27, 15 8:29 PM
Same here. I've got one cut sapphire left after using 3 to open the portal the first time but nowhere can more sapphires be found, plus I also have an amulet.

I beta tested this game and had no issues at all with it, but didn't have this level to test. Seems like they rushed it out and left a few bugs.

Update 04/01/2016

I did as suggested by a few people and checked which hat I was wearing before completing level 39, took a few attempts but I got there in the end. Thanks to those people. As I played the main game I completed each bonus level along the way so just had the extra (CE) levels to finish. I wonder if that was a factor as to why some people got a blank screen when continuing. I continued and no problems whatsoever. Now I am going to start from the beginning again.
 
 
mouldmom wrote:Not sure if this is a tech issues or if I am doing something wrong.

I am in the lock smith workshop and trying to make the key, however, I can not get to the lever to pull to make the indentations in the screen.

When you are in the shot of the whole workshop I can see the handle, but when you click on the key machine the hand is out of the screen shot. '

I cannot proceed. YIKES!

Any suggestions would be appreciated.


You will not be able to access the lever until you have completed the puzzle correctly. So try doing it slightly differently and once you have the key pieces in the correct positions, you will be able to pull the lever and make the key.
 
 
 posted in Rescue Team 5 on Nov 5, 15 9:49 AM
My map screen will not scroll right to left or visa versa, it just judders when I point my cursor at it. Is this a problem with my pc or does anyone else have this issue? Otherwise, the game plays perfectly without any errors.

Win 7 Ultimate
 
 
 posted in Sacred Almanac: Traces of Greed on Jul 31, 15 6:56 PM
pita1234 wrote:Black screens - another game that won't play properly. Windows XP. Sigh.


Until recently I had a similar problem running Win 7 Ultimate in that I couldn't play certain games as all I got when opening a game was a black blank screen.

After sending repeated Dr.Felix reports to BFG and receiving the same non-advice from several people, finally a chap named Barry in Seattle found the problem and a simple solution.

This may not work for you but if you have a similar set-up, at least try it.

I had been using Trusteer Rapport for some time and had forgotten it was even on my pc but I also had Norton Internet Security and apparently they do not like each other and think each other is a virus, so occasionally stopped certain games from running properly.

I uninstalled Trusteer Rapport, restarted my pc and now can play all games from BFG, even ones that had stopped working two years ago because I had installed Trusteer! I can now play Monument Builders series of games and am so happy that finally one of the BFG team actually looked at my problem and solved it instead of making up their own problem and solving that!

If this doesn't work or you do not have both Trusteer and Norton installed then check to see if you have more than one anti virus program running at the same time.

Hope I have helped at least one person.
 
 
 posted in Delicious: Emily's Honeymoon Cruise on Mar 24, 15 7:47 PM
It's ok, I found it. Above the sign on left near the speedboat.

Thanks for looking anyway.
 
 
 posted in Delicious: Emily's Honeymoon Cruise on Mar 24, 15 7:18 PM
Having trouble spotting the mouse in 18-4. Anyone know where it is please?
 
 
 posted in House of 1000 Doors: Evil Inside Collector's Edition on Mar 16, 15 3:26 AM
City of Fools 2 is due out on the 1st April so they tell me, but it may be pushed back a couple of weeks if they find more glitches.

Just thought I'd let you all know.
 
 
 posted in House of 1000 Doors: Evil Inside Collector's Edition on Mar 14, 15 3:46 PM
Screen is in windowed mode. Cannot increase size. When I click on 'full screen' the actual game area gets even smaller! Will not play the demo further until a fix update is sent.

Win 7 Ultimate.
 
 
 posted in The Emptiness on Feb 1, 15 8:11 PM
trixiebellekitty wrote:I don't think it ever ends. Been playing every day for 4 months on my kindle fire, stuck on level 38 waiting for update, can't proceed. Customer service says update months away.


How do you know what level number you are on as I haven't seen any level numbers anywhere and I assume you bought this game elsewhere as its only just come out on BFG?
 
 
 posted in The Emptiness on Feb 1, 15 7:32 PM
I've just played the trial for an hour and have got to the part where I am looking for the fuse. I think this is a great game and want to play further so will have to buy the game or use a credit but would like to know how much more of the game there is? If it is over an hour worth of gameplay then I will go ahead, but don't want to waste money if it only lasts another 30 mins or so.

Thanks for your replies in advance fishes.
 
 
 posted in 12 Labours of Hercules III: Girl Power on Jan 5, 15 5:31 PM
Have completed the game a couple of times now and found all the puzzle pieces in Casual mode but cannot seem to access the bonus levels.

Can someone tell me what I have to do to access the bonus levels, or is it that I have to complete the game in Expert mode first?

Thanks fishies

(Edited ten mins later)

All sorted thanks. You have to complete the jigsaw puzzles to unlock the bonus levels.
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator