Posts created by Maudie18

 
 
 posted in The Secrets of Da Vinci on Dec 5, 12 10:48 AM
There is no paper on the floor anywhere in his room. I have a sheet of paper in my inventory but it won't work. Ive tried to get past the guards from balcony, but every time I get caught and go back to my room, and no paper to use to get out. Please help!
 
 
 posted in The Secrets of Da Vinci on Dec 4, 12 10:46 AM
I am missing a engraved plate. I got the one from the women and the one in the cellar, and the one you put flour on. where is the other. I have gone through the entire walkthrough and can't seem to find where it is.
 
 
 posted in Chronicles of Mystery: The Scorpio Ritual on Mar 20, 11 12:30 PM
Sorry, I didn't realize that you had to step back away from the coffee table to find the right panel with the crack. I finally figured it out. Thanks anyway.
Maudie18
 
 
 posted in Chronicles of Mystery: The Scorpio Ritual on Mar 20, 11 12:16 PM
I did the puzzle, and turned the cross, and she said, I heard something drop, and there was a clicking sound. Back in the study, and there are 2 or 3 cracks in the paneling, on3 different panels. I tried the key and the pen and there is no where to put and it doesn't say blocked or unable to use. I have read the walkthru several times. Also there is no lock on the panel. I even went back to puzzle and I can't move any of the urn pieces as I already solved the puzzle. HELP
Thanks, Maudie18
 
 
 posted in Syberia II on Mar 19, 11 7:08 PM
I finally finished the game. These two games combined were the best two games I ever played. I was sorry it was over. and wondered what happenes to Kate. I am probably older than many of you game players, I'm 59, but loved this game. I would like to say thank you to many of you in the forum. Most of the time the walk thru was not always right and not a lot of help, like on some of the puzzles, but reading thru the forum discussions, I made my way thru, and sometimes had to inprovise. So Thanks to eveyone's help and thanks for the game. It was really great. I loved it. Hope to see more of these games without all the Hidden object stuff. I like those games too, but not as much as the adventure games without the hidden objects. Thanks again. Maudie18
 
 
 posted in Syberia II on Feb 27, 11 1:21 PM
I have tried this 10 times now and the lemming goes into the bottom right hole everytime. I have gone to the lemming first and then activated the prayer wheel, and then back to the lemming again and he still goes into the right hole, I'm stumpted. Someone please help, I've at this same place 4 days now.
thanks
 
 
 posted in Syberia II on Feb 20, 11 3:43 PM
I made the healing candle and talked to Hans, I go to the Temple and cannot find where the key is to the gate.
 
 
 posted in Syberia on Feb 16, 11 10:22 AM
I finally finished the game. I loved this game, best adventure game I've played. But pretty hard, w/o the walkthrough, and even with the walkthrough in places.
Thanks to everyone who helped me in the forum.
 
 
 posted in Syberia on Feb 13, 11 4:12 PM
I left the train, I activated the train winder, I talked to Oscar, and then went to the Hotel and there was no package on the desk. Helena is not at the bar and Hans is not on the pier. I can't figure it out. I've been all over the Hotel and back to the train. Please HELP!!
 
 
 posted in Syberia on Feb 5, 11 1:52 PM
I've talked to the Capt , looked in the telescope, and drank the wine with him, but he will not give me the visa, his glasses are broke.
 
 
 posted in Robin's Quest: A Legend Born on Aug 29, 10 3:48 PM
I am unable to figure out the drawbridge
 
 
 posted in Echoes of the Past: Royal House of Stone on Feb 22, 10 5:45 PM
I'm stuck in the kitchen, when I click on the barrel and it moves to the edge of the fire place, there is another barrel keeping it from going any further, and then it just rolls back to the door. What else can I do? Also I don't have the mitten for the pot. Did I miss it before I got to the kitchen? Help
 
 
 posted in Dracula Origin on Feb 15, 10 5:59 PM
OK, I figured it out. I got one spoonful out and didn't know how I did it. LOL but then I finally figured you had to put the arrow on the gold, not the spoon.
Thanks anyway. I think this is the 3rd message I've done and then figured it out right afterwards.
 
 
 posted in Dracula Origin on Feb 15, 10 5:50 PM
I've got the debons in the Lt side and the stylus in the Rt with 3 spoonfuls of gold, and he says perfect. So now how do I get the gold to the bowl? The spoon won't work any longer. I read thru the forums and don't see where anyone ever really answered this question. Help
 
 
 posted in Dracula Origin on Feb 13, 10 5:08 PM
I figured it out. My lantern had no oil in it. Thanks
 
 
 posted in Dracula Origin on Feb 13, 10 4:51 PM
I found the turbon, and etc.. I'm on the plank of wood again, I combined the linen and the turbon, but it kept saying I was still short. So I combined the belt and got the rope. Now the matches and the lantern won't combine together to lite the lantern. I'm stuck, and went back to see if I forgot anything, but I can't find anything else. I have the pick axe head, oil, but I don't have anything to put the axe head on yet, i figured it must be down below. Please tell me how to get the lantern to light. When I add the matches to the lantern, little gray wheels start to turn, and they don't lite.
 
 
 posted in Dracula Origin on Feb 11, 10 11:45 PM
I finally figured it out. I had to go back and talk to te grave digger again about the watchman and get the Crypy info. Then the poker worked. Thanks anyway.
 
 
 posted in Dracula Origin on Feb 11, 10 11:06 PM
I'm standing at the gate, the poker is in the top Rt corner, but it won't let me pick it up to use it, so I can't widen the bars. How do you pick up the items when there in the corner to use? Also I did not get a new report about the Crypts.
 
 
 posted in Midnight Mysteries: The Edgar Allan Poe Conspiracy on Feb 9, 10 11:14 PM
I am stuck trying to lite the cannon for the first time! The match doesn't lite. I've tried everything! Help!
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator