Posts created by ShazPG

Another blocking issue after installing the update and starting the game over. I have just used the triskelion and the lever has risen. I cannot activate the puzzle to continue. The mouse cursor turns to a magnifying glass when I hover over the area, but the puzzle does not open when I click.

This is NOT a game "crashing, freezing or blank screen" issue - I can move around freely and explore other areas. It is not a Dr Felix issue. It is an issue for the attention of the developers. I can NOT progress in the game because the puzzle that is meant to appear does not appear.
Already got the missing tent bug, downloaded the update, started over.

I've just placed the triskelion and the lever has raised, but I can't get the puzzle to activate. The cursor changes to a magnifying glass but there is no response when I click.

Returned to the menu, went back into game, still no response.
Closed game entirely, started up again, still no response.

This is beyond a joke now. It takes forever to download such a huge game on a slower connection, and I've spent a LOT of time playing already. I've been questioning for the last few episodes whether the Dark Parables games are worth my money and time - ever since they were handed over to Eipix I've found myself quite bored within the first few chapters and going to the guide way too much to enjoy playing. I think I'll be asking for a refund on this one.
Got through it by switching back to casual mode and using the hint as soon as it charged.

The solution in the guide is NOT correct. The object of the puzzle is to press the buttons until all 8 symbols on the pillars are glowing.

The puzzle disappeared too quickly for me to see it, but I THINK the only button that was down was the one at the very top (or it was up and all the others were down).

This is the second place I've found where the guide does not reflect what's in the game. Pity they didn't check that more thoroughly.
I'm near the start of chapter 3 where I've just given the guard talisman to the black swan. The guide says to take the orchid emblem, which I've done, and to select the symbols.

I haven't come across anything that hints at what symbols need to be lit up, and when I select the ones shown in the guide, nothing happens.

Anybody have an idea what needs to be done first? I have the following items in inventory:
- crystal token
- snake totem
- bronze swan
- butterfly
- cryptex
- magnet
- decorated talisman
- orchid emblem
- winch gear
 posted in Big City Adventure: Shanghai on Nov 9, 15 4:32 PM
Yes, you're right. I started playing again last night, paying very specific attention to what the messages were, and going back to check the awards screen. I was just coming back here to say what I found.

These are not bugs at all - the messages pop up and say 1/60 and the awards screen shows the award as not achieved yet, but gives a counter to show how many levels you've completed on your way to achieving it.

I just didn't pay enough attention to the wording
 posted in Big City Adventure: Shanghai on Nov 9, 15 1:15 AM
I also got the Lucky Day award on level 2 after just collecting the two hint tokens. This award (from the wording) should be given after collecting ALL the hint coins on ALL the levels?
 posted in Big City Adventure: Shanghai on Nov 9, 15 1:01 AM
Really enjoyed the game, as I usually do, but was given an award when I didn't earn it, and recalled that the same thing happened with at least one, possibly more of the previous games.

The award is the one given for "finishing all levels without using any hints". The thing is, it was given to me after only level 4 or 5, and I HAD used a hint on at least one level earlier.
 posted in Dark Parables: Queen of Sands Collector's Edition on Jun 6, 15 12:57 AM
You will be back here later.

If you missed anything you need, you wouldn't be able to go down there.
 posted in Dark Parables: Queen of Sands Collector's Edition on May 30, 15 10:59 PM
Can anyone please explain the logic behind the essence puzzle?

"Drag the essence through all the golden dispersal points. Each time it passes through one the counter will go down. Make sure to save enough for each bottle of perfume."

I can't see any indication of what the goal actually is for this puzzle, and the solution seems to have no relevance to the instructions given. One bottle is marked as 1x and the other marked as 2x. But the paths shown go through many more points than 1 or 2.
 posted in The Musketeers: Victoria's Quest on Jan 30, 15 5:09 PM
ugh! I've done this twice now and had that happen. Thanks for explaining how to avoid it.

At least it's a good level to replay - not a next-to-impossible one.

Gotta love that ring!
 posted in The Musketeers: Victoria's Quest on Jan 24, 15 7:53 PM
no, I was wrong. After you lose 3 stars, the timer goes down super fast for the rest of the level.
 posted in The Musketeers: Victoria's Quest on Jan 24, 15 7:35 PM
The timer moves fairly slowly while you still have a chance to get 3 stars, but the moment you miss that first target, the rate the timer goes down is MUCH faster. When you miss the next target it seems to slow down a bit more.

The time should go down at a constant rate.
 posted in The Musketeers: Victoria's Quest on Jan 24, 15 2:34 AM
A link will not be allowed. BFG mods delete all links, regardless of who posts them or what they're for.
 posted in The Musketeers: Victoria's Quest on Jan 22, 15 11:46 PM
I hardly ever use the food quick-grow thing - even with two people running around, by the time they both go and collect one thing each then return to the tent, the pumpkins have grown again. Not to mention there was only a bush for a few levels after receiving it, then no bushes at all for a dozen or so levels.

And the wood and stone 1-up going on the same hand is a bit of a pain, when there is nothing on the other.

It's just making the player work for the sake of making the player work. There's no fun in it.

I've tried the switching every time depending on what it is you're retrieving, and I still run out of resources or go over time. I don't mind games that make you think, and I don't mind games that make you start over if you run out of resources on bonus/challenge type levels - I have quite a few of them. But this, on every single level, and timed so close, is starting to wear thin.
 posted in Risen Dragons on Nov 12, 14 10:05 PM
Each time I entered one of these, it didn't give me the opportunity to select a difficulty level - it just went straight into the level. When I completed them (except the broken one) it gave me a gold star for completing on easy. But it won't let me go back to them to try a more difficult level. There's no response when I click on it, and when I click the portal to replay a previous level, it only shows the regular levels 1-9.

I attached them to the main island after completing them. Don't know if that's what stops me from going back. But when I clicked to attach, I don't recall getting a message asking if I wanted to play again.
 posted in Risen Dragons on Nov 1, 14 10:56 PM
Fire Book is the same.

Ammo correctly deducts gold when purchased.
 posted in Risen Dragons on Nov 1, 14 10:39 PM
I was just given this award, for completing every level in expert mode. But I haven't. I've only completed 5 or 6 different levels in expert mode. I replayed several a few times, on expert, to get gold stars so I could research things. This probably means I've done 12 levels in expert mode, but several of them were repeats of the same level. I haven't done every level, much less on expert.
 posted in Risen Dragons on Nov 1, 14 10:30 PM
I have enough gold to buy 4 jars of energy. It lets me select that many, but when I hit the BUY button, it exits the shop and my gold is not changed. It DOES give me the 4 jars of energy though.

Nice bug
 posted in Weather Lord: In Pursuit of the Shaman on Aug 19, 14 1:20 AM
moondances wrote:It has been a bit since I played the first Weather Lord so I can't be completely sure if it had better instructions, but I believe it did-So, I wonder if the developers think we will remember playing the first game and didn't see a need to include more instructions for this second game-Just thinking out loud =^..^=

That would be okay if you assumed that everyone who downloaded this game had played the first one. I didn't even know there WAS a previous one.
 posted in Weather Lord: In Pursuit of the Shaman on Aug 18, 14 1:27 AM
A LITTLE bit of help with what to do might have been nice. ****'s usually pretty good at teaching you the basics, but this game leaves a lot to be desired.

So when you build a house or a sawmill, you can click on it again and have the option to upgrade, if you have enough resources.

It does explain dragging the sun and rain to one thing each to make things happen, but there's no explanation that when you've chopped all the trees, you can drag the raincloud to the stumps and have them regrow, or that if you make the sawmill BEFORE you chop trees, it boosts the amount of wood you collect, or that when you collect all the gold from the mine you can click it again to have someone go and repair the mine to get even more gold.

I had to play level 2 (or 3?) a few times over as I had no idea where the extra gold or wood was to come from to clear the path or repair the houses.

And apparently your warrior loses health when he fights, so you have to click on him from time to time so he runs back home and tops his health up.

I don't even see a HELP button or a Tutorial option in the menu. Guess you're on your own.
Go to:   
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator