Posts created by SilverBranch

 
 
 posted in Glass Masquerade on Jul 4, 17 8:57 AM
I completed 10 levels within the hour demo - so I'm guessing this is a short game?
 
 
Won't complete download or validation. The progress bar fills up (in the game manager) at 443.6 mb and says vaildating but then never goes beyond that. No pop up boxes open (as is usual for confirmation that I want installation to begin with other games). I clicked the pause button and then the resume button and it changed to "downloading" again - this time the meter says 443.6 out of over 1GB file size! And it was still frozen even with this change.

Windows 10
 
 
 posted in Weather Lord: Royal Holidays on Nov 15, 16 12:01 PM
Wow.... thought it was a glitch too! Good thing the forum was here - I would have never looked there (thinking it was only for making lightbulbs!) They really ought to have explained that before the level. I've played it twice.
 
 
 posted in Legendary Slide on Nov 14, 16 7:58 AM
No real tutorials. If they gave real instructions, this game would have been a keeper. Sadly, I could not get beyond level 5 because I did not know how to clear the sand bricks at all and tried many different things with no luck.
 
 
 posted in Legendary Slide on Nov 14, 16 7:54 AM
I'm on level 5, where you drop the tiles in between rows of sand and bricks. Darned if I can't figure out how to get rid of the sand. None of the tiles on the same row match. There was sand in the previous 2 levels, but moving a tile always mysteriously cleared it. I can find no in game help.
 
 
 posted in Epistory: Typing Chronicles on Oct 3, 16 7:23 AM
I downloaded the trial, opened it and after the BFG and Cactus screens, all I get is a blue screen with a paper airplane cursor and a lot of bird noises. Nothing else. It won't go beyond this.

PC
Windows 10
 
 
 posted in Chronicles of Albian 2: The Wizbury School of Magic on Sep 3, 16 3:40 PM
Sometimes the symbols can be finicky. You should see exactly how to recreate the symbol in your journal (including how large it should be against the background symbol)
 
 
 posted in Weather Lord: Legendary Hero! on Jun 29, 16 7:22 AM
I must have playing this level at least 10 times now. I've even followed the strategy walkthrough (which I akin to cheating because there's no challenge if they tell you what to do step by step) and still can't make gold on this level! I have gold on all other levels can't make it on this one. Anyone else have this problem?

If you've beaten it with gold time - what did you do?
 
 
 posted in Steel LIFE on Mar 2, 16 4:00 PM
As soon as I enter the casino, the game gltiches. Every compass point (the roulette table and the slot machine and the energy transfer machine) show up as big pink boxes. If I click around the pink box, sometimes something happens - like the graphics are gone but the game will still play if I know where to click blindly.

Hopefully I can blindly click through this somehow... but it's hard to know what to do.

Windows 10.

UPDATE: Now all the game inserts and minigames have gone pink. I tried going out and getting back in and that seems to have made the problem worse. I needed to laser burn the token, but I can't see the laser controls - just a pink box! Hint doesn't take me past this, just directs me to use the controls I can't see. I'm so disappointed. Was looking forward to finishing this game.
 
 
 posted in The Hunt for Red Panda on Mar 2, 16 1:46 PM
When I try to open the game, it shuts the game manager and does nothing else at all. No error message, no game, no nothing. And then when I restart the game manager and try to open the game again, it tells me I already have a game running. So I go to task manager and there is NOTHING running but the manager.

Windows 10
 
 
 posted in Defense of Greece on Dec 7, 15 7:53 AM
This game is very choppy on my Windows 8.1 PC. Every time a tree "bounced" (yes, they do that from time to time in the background of the game scenes), the army would stop marching for a second. And as I got more machines, it was nearly impossible to play as everything was choppy with no flow at all. In a non-technical issue, the spelling is horrible in the dialogue cut scenes.
 
 
 posted in Defense of Greece on Dec 7, 15 7:50 AM
Yeah, they didn't make it very clear in the "tutorial". I didn't understand that either.
 
 
 posted in Tasty Blue on Nov 20, 15 7:49 AM
The game is fun, but I find it dizzying and can only play it in short 10 minute spurts.
 
 
 posted in Hospital Manager on Oct 26, 15 8:23 AM
This a creative game and not your usual "collect resources, get rid of obstacles and build resource buildings" time management - finally! I enjoyed the demo and will drop a credit on this. But either I'm losing my touch, or this game is hard right out of the tutorial! I never seem to have enough money or space for rooms to make patients happy.
 
 
 posted in Garden Shop on Oct 12, 15 8:15 AM
Janette5 wrote:
Difficulty & Technical Issues
This game is very difficult and very easy to get confused because you have different people serving and you have to click the person and then click the action they have to take. They can also get into each others way. Here I had a lot of problems, not just keeping it all together but the game would get confused - so it wouldn't allow someone to go to a station as it had triggered the other server was standing there - even when they weren't - so I had to move that server somewhere else to trigger that the counter was clear. Even though I enjoy the complexity of the game it only works if the game actually runs smoothly. This one does not.
frustrating game.


I would like to add a huge YES to that! I would have maybe wasted a credit on this average little game just for something new to play, but this was a very frustrating feature that I did not enjoy.

Thanks for your review!

Did anyone else notice that the manager of the shop changes flesh tone in the game? I kept wondering who my first helper was supposed to be in the story line. Silly me for trying to follow the insipid story!
 
 
 posted in Garden Shop on Oct 12, 15 8:08 AM
This game isn't that great, it's average and basic - but I was compelled to rate it higher (I rated it "ok" when it probably should be "I don't like it") than I normally would if only to encourage BFG to focus more on time management games (and please not just another monument builders/build-a-lot style game - I used to love them but now it's all they do for TMG and I'm sick of them) Now this site isn't just HOG heavy, it's creepy or dark themed HOG heavy.

I miss dash style time management games. I have turned to other game sites similar to BFG to find them. Like the Delicious Emily series and Diner Dash, which have been on other sites for years now.

In all the years I've been a member, I've never had a credit beyond a month - now I have two for the past 2 months saved up! The past few membership credits I had were spent on games that I found in the BFG vaults that were released a long time ago.... nothing current.
 
 
 posted in Letter Quest: Remastered on Oct 5, 15 7:08 AM
It's so funny because (with a lack of any good new time management or word games these days) I revived this game just this week and am almost done replaying it. So I was excited thinking that "remastered" meant a bigger and better game... but my review is still on the main game page so I guess this is the exact same game.
 
 
 posted in Delicious: Emily's Childhood Memories on Jun 29, 15 1:29 PM
Janette5 wrote:No, I found the mouse in Advanced on level 1.

However, they appear much less frequently in advanced mode than in normal mode so they are more difficult to spot.

I have my sounds off so not sure if they make a sound or not.


I never had any problems with the mice in any level until this one. In fact, I've played many levels beyond the first one now in advanced and got the mouse in each one without fail. In the first level, the mouse hole is blatantly placed on the screen and the level is very short - you can't help but to keep you eye on it. So I don't know what's going on here.
 
 
 posted in Delicious: Emily's Childhood Memories on Jun 29, 15 1:27 PM
I seriously think my lack of mouse is a glitch. I had someone else watch the screen as well while I yet again replayed the level (wish I could skip the animations!) and no mouse ever appeared.

I owned this game a long time ago and never had a problem with this as far as I can remember.
 
 
 posted in Delicious: Emily's Childhood Memories on Jun 28, 15 7:50 AM
I found them all when playing in normal mode. I found the best way to know there is a mouse is to turn off the music and only leave on the sound. The mouse sort of squeaks a little before appearing, so you know he's on the screen even before you see him.
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator