Posts created by Timbuctu

 posted in Fantasy Mosaics on May 12, 14 12:39 PM
I just finished playing the last puzzle in the game, which apparently opens an Endless Mode. Problem is, after having left the game and then going back to it, I can't seem to find any way to access that mode again. I certainly hope it doesn't require re-doing the final level again and again...

Also, just as my own personal review, love this title, and it is way better than the way World Mosaics is taking their series...that P2P titles Chroma is a really horrible game in comparison to the titles that came before.
 posted in World Mosaics Chroma on Feb 8, 14 6:03 PM
Yes, these puzzles are a good challenge, as long as you don't want to get all three stars on each puzzle. Fugazo made the previous World Mosaic puzzle games with a large amount of integrity, allowing each puzzle to be solved without ever having to rely on hints. Some of them were quite hard, but they could all be solved if you went about them the right way.

This title is practically demanding that 'helpers' are used. By the time you reach the third puzzle in the second chapter (so, about puzzle 27 or so) the score needed to get the middle star is over 225,000, a number which the game proves on the previous level to only be obtainable by using a bucket 'helper'. And guess how you obtain the bucket helper, or any other helper for that matter? $$, that's right.

Fugazo has gone from a quality game maker to one looking for a fast buck, and their two "free to play" titles prove that. Mourn their passing, as I won't be buying another title from them unless I see a review stating they've gone back to being a developer with integrity.
 posted in Undiscovered on Jan 28, 14 8:53 AM
Played the demo through to level 21. That's when things took a turn for the worse. Like most M3 games, you have to clear coloured blocks in order to progress, and just as in other M3 titles sooner or later those blocks will require breaking or shattering other block to get to them. No problem...

...And then they introduce the 'vine' feature. This is a growing obstacle (those playing Candy Crush will recognize this as chocolate), but it doesn't follow the parameters of a typical growing obstacle. Specifically, you can't kill the vine. Oh, you can clear it out of your way, sure, but the square the vine starts from remains discoloured no matter how many matches you make before it regrows, and it regrows when it wants to with no regard for whether you just matched on it or not. In fact, it will grow right over a place you matched immediately after doing so if it wants to. The only good thing about it is that it doesn't seem to grow on blocks you need to clear to finish the level. It just stops you from getting pieces to drop on or near those blocks so you can't get to them.

On level 22, the vines took over, and no amount of clearing could get me to allow new pieces to drop on the lower left side of the puzzle to finish off the 8 remaining blocks. I gave up the level, came here to let everyone know, and will probably rate this as a pass as a result. Remember: Sometimes it pays to play more than the first chapter to determine the value of these games.
 posted in Mysterium: Lake Bliss Collector's Edition on Dec 21, 13 10:15 AM
Okay, so I played the demo through to it's conclusion, and got to the cutscene that ends it, and realized that I had completed fully half of the map provided, as far as visiting locations, etc.. Can anyone tell me exactly how far the demo took me, because I'm not buying a collector's edition when the remaining gameplay is less than an hour.
 posted in My Singing Monsters on Dec 16, 13 9:32 AM
My problem involves trying to purchase an item and being rewarded with a darkened screen before I can place the item, with the "Come to the Store" advertisement on the screen. It seems the ad is so excited to get involved that it is crashing the game, and I have to Task Manager out. Then, if I got back in, it tells me it can't connect and to try again later, then with one touch of the Play button it let's me back in, just to have the game crash on me again when trying to buy the same item.
Yeah, knowing the arrow box actually moves is all I needed to solve the whole thing. What a pain that was! Goes to show that no matter how much polish a title has, there can still be something unclear to even veteran players.
Okay, the info says the pieces move like a train. They don't move at all. I can click on the arrow box, it does nothing. The door handle slightly turns the gears, but of course won't open the door. I can only seem to click on one of the candles, and the Strategy Guide pictures do nothing to help me figure this out. To top it all off, it keeps saying to click on the gold circles between the pieces to uncouple them. There aren't any gold circles between them.

So, is it glitched or have I missed something obvious? I assume it is the latter, but HELP!!!
 posted in The Happy Hereafter on Oct 15, 13 9:38 AM
Updated graphics drivers, and problem still persists. If I click even faster I can get the Mirbal Games title card to display, but I can get no further.
 posted in The Happy Hereafter on Oct 15, 13 9:11 AM
Shutting down the game manager isn't a glitch, it's a feature on some titles. Royal Envoy's latest title does the same thing but plays just fine.
 posted in The Happy Hereafter on Oct 15, 13 8:07 AM
I downloaded the demo, and when opening it I see the Big Fish logo, and if I click quickly enough I can even get to ****'s new logo, but then everything freezes and I need to use Task Manager to close the non-responsive program.
 posted in World Mosaics 7 on Oct 9, 13 7:58 AM
In one word, disappointing.

Throughout the World Mosaic series I have been thrilled to see that every level can be completed using logic rather than hints, and that if you work diligently each puzzle can be solved without even one random guess. That changed with World Mosaics 6, but only on one or two puzzles where I felt it was possible that I put myself into a corner that I might have been able to think myself out of if I had approached certain puzzles in other ways.

This game, however, has forced me to use hint buttons multiple times already and I am only in the fifth chapter. These instances most often have occurred when a 15x15 or 20x20 puzzle is winnowed down to something like 8x6 or in the most recent case 20x7. After doing a couple of obvious moves, there is just no getting around either guessing or using a hint to progress further.

Add to that the fact that the people at Fugazo no longer care to make the background contrast against the blue pushpins and that as a result you're guaranteed regular mistakes, and you basically have a series that is rapidly running out of gas.

I haven't bought any other series' titles without seeing the demo first, and thought I could always rely on these being top notch games. Next time, I'm doing the demo, and if naught has changed, I might just browse elsewhere from then on.
 posted in World Mosaics 7 on Oct 8, 13 8:21 AM
TigerJo714 wrote:Sorry to hear that Timbuctu. Did you try setting it for exactly that resolution? Also, you might want to go to Options in the game and either Check or Uncheck the Wide Screen Option.

If that still doesn't work, I suggest you post your message in the Tech Thread and/or send a message to Tech Support.- it's the little Green Envelope to your right Good luck.

Couldn't try the first suggestion since I can't enter the game whatsoever, but did sort out another way around, thanks!
 posted in World Mosaics 7 on Oct 8, 13 7:56 AM
Upon attempting to start this game, I keep getting an error message requesting that I set my monitor to be at least 1024x768. I set it way beyond those numbers, but the game won't play.
 posted in Lost in the City on Jul 20, 13 7:59 AM
Unable to set graphics mode - this is the error I'm getting with a brand new computer trying to run this title. I've played it through multiple times on my Windows XP system, but with a new computer running Windows 7 the screen goes black, then this pops up and I am returned to the BFG Manager as if I had just played the title and it is in my recently played list.
 posted in Build-a-lot: Fairy Tales on Jun 17, 13 3:25 PM
I'm having a problem with town charm. On the third level after the tutorial, I built up four houses, three of them cottages, and had 2 stars on two of them and three stars on the other two. The town charm was still at zero, and I couldn't finish the level. What am I missing? I'm on too low a level to have anything negatively affecting my town charm, so where is the problem?
 posted in Aquascapes on May 8, 13 11:16 AM
Playing the demo, I finished the second level and wanted to take a look at the backgrounds that I could open later in the game. I clicked on the little checkmark in the upper right corner, and the turtle zipped away, but nothing else happened to return me to previous menus. So, I pressed the checkmark again, and the game froze, so badly that I couldn't use the Windows button to get back out. I actually had to Control-Alt-Delete to bring up the Task Manager to close the game. I still intend to buy it, as I love the Playrix name and these series of titles in particular (we all know this is Farmscapes, with a wet look!), but this issue needs to be addressed in a patch sometime in the future.
 posted in Isla Dorada - Episode 1: The Sands of Ephranis on Sep 4, 11 4:00 PM
For all those who are having trouble with the mask aspect of this horrible game, here is what I gleaned before I deleted the stupid demo off my computer:

You pick up the mask, move it around the scene, and it glows when it is at the area you are to search. The jiggly thing just reminds you that there is a piece to look for, naught else.

Hope that helps, but honestly, if you are actually purchasing this piece of crap I really gotta question your taste

 posted in Isla Dorada - Episode 1: The Sands of Ephranis on Sep 4, 11 8:24 AM
After 5 minutes, I was tempted to end the demo - after 10 I did do so.

If you can't even translate the words 'incense' or 'thimble' into English for an English audience, then you need to go back and find a different job.

Epic fail, sorry.
 posted in Age of Enigma: The Secret of the Sixth Ghost on Aug 24, 11 2:35 AM
Like the game, but can't find 6th spear piece, can't even see the ones I did find, so not sure if it is a purchase for me.
 posted in Build It Green: Back to the Beach on Jul 31, 11 6:24 PM
Yup, re-did the level, saw the message that preceded it, figured it out...but still, could have been made more clear developers.
Go to:   
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator