Posts created by Homeimps

 
 
 posted in Leaves: The Journey on Jul 31, 17 5:02 PM
I assume this might be a technical issue so am posting it here. I got to the point where I had the magnifying glass, hook, and a thing shaped like a kidney bean with a lot of characters on it. Then I clicked on something (??) and a large pink blob about the size of the kidney bean thing appeared on the screen. Tried everything, could not remove it nor access anything under it as it stayed on every location I went to; could not even exit from the game and then the demo ran out so I am still in the dark. Youtube videos don't show anything like this and it isn't mentioned in any forum. Help anyone?? Thanks!
 
 
 posted in Legendary Slide on Jul 18, 17 7:21 PM
I'm going to try to put this so it doesn't act as a spoiler: Just know that there is a way to do it so you actually get all 3 stars AND complete the level.
 
 
Re: My earlier post about putting out the fire, just wanted to add I'm running Vista 32 bit.
 
 
Cannot put out the right-hand fire as the hose will not move over that far. I tried setting the resolution several different ways but still can't get it to work. Hope there will be a fix for this.
 
 
 posted in Nevertales: The Beauty Within on Nov 28, 15 5:08 AM
sexxygamma wrote:I am having problems on my laptop with playing this game when I push play a screen pops up in small screen mode in black and thats it!! NOTHING ELSE! I have uninstalled and installed and same thing keeps happening? HELP!!
 
 
 posted in Hidden Expedition: Titanic™ on Apr 26, 13 6:57 PM
Hi Everyone:

I just changed my resolution from 1024x768 to 800x600 pixels and the game ran in fullscreen. Go to Control Panel, Personalization and change it from there (Vista). XP is something similar.
 
 
 posted in Fix-It-Up: World Tour on Nov 1, 12 2:23 PM
I get Access Violation Errors when trying to start about half the games on Big Fish, but have found that I can run them straight from my hard drive. Click on "Computer", click on "Partition 1 (C)", then click on "Program Files". Scroll down to the game you are trying to run and click on it. You will see 3 titles that say "Application"; one of these will have an Icon. Click on that and the game will start. I have been able to run all the games that gave me A.V. Errors this way. My video drivers and DirectX are up to date and I have also tried disabling Norton (I don't have any other firewall), but the only thing that worked was running them from my Program Files. Hope this helps other Fishies!
 
 
 posted in Echoes of the Past: The Citadels of Time on Nov 6, 11 5:27 AM
This is the first in the series that I have played and I was impressed, especially by the variety of puzzles. I usually play more complex games like the Myst Series, Syberia, Scratches and the Jonathan Boakes games like Dark Fall: the Journal and Lights Out, so the simple HOG's are usually a bit boring for my taste, but this game kept me well amused until the last, very challenging, puzzle. I plan to try the first two and will hope for a fourth. Thanks to Big Fish for offering it for Halloween!
 
 
 posted in Black Circle: A Carol Reed Mystery on Feb 24, 10 2:32 AM
They may be assamed but they have nothing to be ASHAMED about... LOL at you!
 
 
 posted in Black Circle: A Carol Reed Mystery on Feb 24, 10 2:29 AM
Great twist, making Emil Vogler a transvestite, especially as he/she was played by the creator himself! I lived in Scandinavia for a year back in 1970 and quickly learned even back then that attitudes there are much more accepting than here in the US so I hope the Yanks are more amused than offended by this little quirk in the game!
 
 
 posted in Black Circle: A Carol Reed Mystery on Feb 24, 10 2:11 AM
After I set up the cubes as in the clue, I had to turn away from the box and then back again, click on the cube with the padlock shown in the clue, and it opened. May be a software glitch but keep trying and it will probably work.
 
 
 posted in Black Circle: A Carol Reed Mystery on Feb 24, 10 2:07 AM
Yes, you had to use all three keys before the door opened. Just a little twist to throw us off...
 
 
 posted in Black Circle: A Carol Reed Mystery on Feb 24, 10 2:04 AM
The Carol Reed games are classic! The puzzles are just challenging enough to keep me engaged but most of all, the environments are fantastic. It's a treat to visit Norkopping each time and to wander around just as though I'm actually there. The homes are so real it almost feels like I'm trespassing and it's fun to see some of the same characters again and to find out what they've been up to, just like old friends. As well, the spooky places actually make me lock my doors while I play! I want to go to Norkopping and see where these great games are made. Kudos to Big Fish for carrying the series and I hope the developers keep them coming!
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator