Posts created by eponym

 
 
Barnmaster wrote:MacPro: OS High Sierra 10.13.3

GAME FREEZE - 'Spin the stone discs until a pattern is made" froze up twice. I have a screen shot.

Had to use a hard shut down & restart. I do not know if related, but the USB port my Apple keyboard is plugged into stopped working immediately after the second freeze. I was not able to resolve the problem with the typical SMC resets so Apple Support is scheduled to come onsite to figure out what happened.

I deleted the game & am afraid to download & try again due to the USB issue. I am operating my keyboard off my USB hub, if that stops I am dead in the water!

Anyone have a similar experience?



Same computer Mac OS 10.13.2 same issue crash at stones.
 
 
This happens way too often!
 
 
 posted in PuppetShow: Bloody Rosie Collector's Edition on Nov 19, 16 7:27 AM
debopaints wrote:My game is shutting down repeatedly and time I try to access the cemetery. This started after I got the key from the raven in the window. Able to move around anywhere else on the map except the only next step in the cemetery. A waste of money if this isn't fixed soon! I'm on a mac OS X yosemite.


I am also on a mac OS Yosemite and it is the exact same issue. I want my money back!
 
 
The game has crashed repeatedly, must restart. It is not good enough to warrant such annoyance. One more time and I will request a refund.
 
 
I played the demo for twenty minutes and it froze three times. . . Not a buy for me.
 
 
No game cursor. I am on an iMac OSX 10.10.4 Put game in trash.
 
 
FreedomII wrote:Using Mac OS X Yosemite 10.10.3. Got to the scroll holding the skull but game crashed when I placed the pirate token. When I re-started, the scroll with the token wouldn't play, although it does show I need to interact with the scroll. I'm at the point where I need the item inside the scroll to move forward, but apparently I'll have to restart the game since I can't override, skip, or otherwise manage to get the scroll to autoplay. Not a win...
 
 
 posted in Fear for Sale: The 13 Keys Collector's Edition on Oct 26, 14 10:04 AM
Brendansoma1 wrote:If I remember correctly, you have to put the piece of paper with 'occult' written on it on the silver colored book underneath the shelf with the books.


I cannot do that. I am no longer at the hotel and so cannot return to that bookshelf. I cannot go back. I thought the book was in the same room as the crow but it is in the hotel office with the deer head.

I agree with ihateglitches! This happens far too often. I have slowed down my purchases and have just been replaying games I already own.
 
 
 posted in Fear for Sale: The 13 Keys Collector's Edition on Oct 25, 14 11:29 AM
I never got the book, just the page that said ocult book. I could not take the book from the shelf. Now I cannot do anything. I believe we are almost at the end but by the time the bugs are resolved I will have lost interest. This had been such a great game until this point.
 
 
 posted in Spirit of Revenge: Cursed Castle Collector's Edition on Aug 15, 14 11:30 AM
sfbeck wrote:I also can't get back to the table of contents on the strategy guide, so I'm forced to flip pages between a particular chapter and collectibles. I love the few games where the strategy guide automatically follows your play and sends you to the correct page without searching.


I thought I was missing something but it seems the developers forgot the index. I am glad I checked the forum.
 
 
 posted in Mystika 2: The Sanctuary on Jul 29, 14 12:36 PM
I do not think there is an end. I obtained all of the purchasable items. I seemed to have begun again. There seems to be no reason to continue.
 
 
 posted in Mystika 2: The Sanctuary on Jul 29, 14 12:33 PM
Is there an end to this game? I obtained all of the purchasable items. I seemed to have begun again. Please tell me if there is any reason to continue?
 
 
thyca29 wrote:1. open the ring item.
2. click on the note.
3. while the note is open close the item by pressing X in the right corner.
4. open the item again and it will work.
Found this solution in an other post called "signet"...It really works

Someone said that he uninstalled and reinstalled the game and I didn't want to do it so I kept reading messages
Once You've done the 4, changed the signet, open again the note, click on it and you'll can push the green button

Hope It will helps


This Works!!!
I went looking for a walkthrough since the hint button & strategy guide were not helpful. I did not find a walkthrough but I did see the forums. Updating did nothing and the idea of uninstalling and reinstalling just does not sit well with me. I think it removes all of the excitement for the game.

Thank you Thyca29,
 
 
 posted in Forbidden Secrets: Alien Town Collector's Edition on May 22, 14 3:25 PM
I could not complete this puzzle either. I had the right answers it just would not allow me to put in the runes. I used the strategy guide as well as the forums and finally had to use the skip button. Oh the horror!!

The game has had a couple of bugs but until now nothing I could not work around. I am still loving the game, I am just frustrated.
 
 
Be aware that when you hit SAVE in the photo album, it really does save into your computers picture file! I do not care for that at all. If I want to save an image or a wallpaper, I will do so. Do not make it part of the game. What achievement have I lost since I deleted them from my picture? One that I do not care about!
 
 
 posted in The Others on Mar 12, 14 2:17 PM
Thanks Duke!
I thought I tried all variations but apparently not.
 
 
 posted in The Others on Mar 12, 14 9:34 AM
I am stuck in the cave of the Toy Factory. I cannot get out and I cannot skip. I am not sure if I am having computer issues (iMac). I made a lever and placed the rock but I cannot use the grappling hook or get out on my own.
 
 
ChocPeng wrote:
CiChDa wrote:Thanks to all of you for your suggestions...
What are we suppose to do now about not having the menu button?
What have you others done?
I am at loss on how to proceed now...

I couldn't use the menu the first time I opened this game and tried to go back to the menu from game play. All I had to do was close the game and reopen it and my menu is working perfectly now. I am on a Mac OSX.
 
 
I cannot enter the menu. I am running a Mac OS X 10.7.5

All updates are current. I tried everything to exit and must have hit the right combo to force quit. Do you know what buttons they are? I cruised through the forum and saw something for the PC but am drowning in info here. I just want to know in case it happens again.

I do not want to uninstall and reinstall. I do not want to start over again.

 
 
I dislike feeling like an idiot when I cannot even follow the strategy guide for an answer. I think bugs should be worked out before. It is hard to imagine this was not an issue in the testing phase!
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator