Posts created by rustinator

 
 
 posted in Faded Reality on May 22, 11 7:25 PM
I got to the clue where it says behind the blue cushion. I go to the two places and there is nothing behind the blue cushions. The hint in each scene tells me to go to the other location. Reading the discussions, there are only 2 locations...any suggestions?
Thanks.
 
 
 posted in Hidden Expedition: Amazon ™ on Dec 14, 10 8:51 AM
I got all 4 gears and was trying to assemble them onto the wooden board, when it seemed as if one dropped and dissappeared. I tried shutting down the game and starting up again, but it never appeared. Looked in all the other locations, but nothing. It just vanished and I can't continue without it. Thanks for any help.
 
 
 posted in Agatha Christie: 4:50 from Paddington on Jul 21, 10 4:56 AM
I just started to play, on chapter 1. I got thru the first 12 objects and cannot click on the next stop, which is hyde park. Nothing is highlighted to click on. I did try to start again under another name and the same thing happened. I bought this on the dd, but to pay to find 12 objects is ridiculous. Thanks for any help.
 
 
 posted in Defenders of Law: The Rosendale File on Jun 27, 10 8:38 AM
I made it to the evidence room and the cursor is uncontrollable...goes all over the screen.
Is there any way to stop this or skip this part of the game?
 
 
 posted in Agatha Christie - Death on the Nile on Jun 14, 10 6:05 PM
One room needs to find 5 butterflies. I can only find 4. I tried numerous times, using
hints to find the 5th one but can't do it. I click and click on where the arrows point and
nothing. They point to around the bottom of the bed. I tried clicking until the time ran out,started over again, and again hoping the butterfly clue wouldn't be there, but it
is always there.

Please help!
Thanks.
 
 
 posted in EcoRescue: Project Rainforest on May 23, 10 2:34 PM
I too have been finding this easy until I got to the Tiger Jigsaw puzzle. It looks complete to me, but I have 2 small pieces that don't seem to go anywhere. Did anyone else have this problem, if so, what was the answer. Thanks.
 
 
 posted in The Mystery of the Crystal Portal on Apr 26, 10 5:01 PM
Thanks so much. It was a big help.
 
 
 posted in The Mystery of the Crystal Portal on Apr 25, 10 2:17 PM
got all items except one mask. Hint probably thinks I've finished because it won't
give me a hint. Clicked all around on the screen, but nothing. Can someone tell me
what to do?
Thanks.
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator