Posts created by KathyPW11

 
 
I agree! I had other things to do for a few days, came back and finished the game and thought, "Did I miss something?" I finished the bonus chapter, but I'm still left wondering who the killer was, and what did the tell-tale heart have to do with it. If I didn't understand the whole tell-tale heart thing, I'd be even more in the dark, and it's already pretty dark in here!

I'm glad I came to the forum to discover I'm not the only one who was confused by the ending!
 
 
 posted in Nancy Drew: The Silent Spy on Dec 30, 14 11:08 PM
I feel the subject is clear enough. I seem to be stuck early on, and in lieu of hints, which, if they are available, cannot be found, I could sure use a walkthrough!
 
 
 posted in Nancy Drew: The Silent Spy on Dec 30, 14 11:05 PM
I just started the game tonight, and so far, I am unimpressed. This is my first "Nancy Drew" game, and there was no in-game introduction/training. I'm on the "Amateur Sleuth" setting, but I see no hints option. I'm just kind of wandering around. I was instructed to go some place, but the instructions were so fast, I didn't get it down, nor is it written in my "journal" or as a message on my in-game cell phone, so I am stuck. Plus, I don't have enough money to buy a ticket to anywhere. I'll try it again, later, or maybe I'll just go to another game, one that has hints.
 
 
Thanks, but I've tried that. There are no 0's (zeroes or oh's) in the code. It's pretty much straightforward, I even had my husband read it to check if I was seeing it wrong.

Code: V27AE9
 
 
I've found the password, but it won't work on the computer. And I can't get the game to give me a hint at this point (to skip this puzzle).

Now what?
 
 
 posted in Love Story: The Way Home on Sep 21, 13 1:08 PM
The link to the walkthrough is not working. The error message reads:

"The proxy server received an invalid response from an upstream server.
The proxy server could not handle the request GET /blog/walkthrough/love-story-the-way-home-walkthrough/.

Reason: Error reading from remote server"
 
 
 posted in PuppetShow: Mystery of Joyville ™ on May 27, 13 12:34 AM
Nevermind.
 
 
 posted in Syberia on Sep 13, 12 6:40 PM
I have tried several times to play, or continue to play, Syberia, but have now given up. The inventory is difficult, or sometimes impossible, to use. For example, I have all 4 cogs for the elevator, but can't get them out of my inventory to use them! I walk around with nothing in particular to do, and no hints to help me out. I see that people have given it glowing reviews, but I just don't get it. I've played lots of BigFish's adventure or "find the hidden object" games, but this is the first I have quit midway through after purchasing it.
 
 
 posted in Syberia II on Sep 8, 12 1:31 AM
I haven't finished Siberia 1 for those reasons. I am now stuck and, without a walkthrough, don't think I'll get anywhere.
 
 
I need help with this. I accidentally moved one tentacle, but cannot move the other. Then I quit the game, and when I returned, the first tentacle had reset! I've tried every object I carry, and no object at all, just slowly moving the mouse over all of the tentacles. This is really frustrating! Helllppppp!
 
 
 posted in Hidden Mysteries: Royal Family Secrets on Apr 26, 12 6:13 PM
snowlady423 wrote:I put the items in the colander in the wrong order. What do I do now?


It doesn't matter. Once all the ingredients are added, you can light them.
 
 
 posted in Pet Shop Hop on Nov 14, 11 8:08 PM
How is it possible to reach master status on Week 36?!?!? I've tried it over and over again, using every trick I can think of, but the most I've gotten is $4800 out of the required $7000. What the heck? Any ideas?
 
 
 posted in Pet Shop Hop on Nov 14, 11 8:04 PM
I've made it almost to the end, but can't master a few weeks.. very frustrating.

General tip: try to "chain" as many pets together as possible, i.e. the same kind of pet in a row. Do this even if you have to make customers wait, you get more points if you "chain" them together.
 
 
 posted in Pet Shop Hop on Nov 5, 11 8:05 PM
How is it possible to reach master status on Week 36?!?!? I've tried it over and over again, using every trick I can think of, but the most I've gotten is $4800 out of the required $7000. What the heck? Any ideas?
 
 
 posted in Dark Tales: ™ Edgar Allan Poe's The Black Cat on Mar 9, 11 1:14 PM
You have to put the box of fireworks in the coach, then set the handgun above them, tie the string to the trigger, back out, and then pull the string. Bang! The fireworks blow up the carriage!
 
 
 posted in Lost Chronicles: Salem on Feb 21, 11 12:15 AM
I also thought the ending sequence was rushed. And same deal with the necklace.. what the heck, we find that in the cell only to have the game end? The only reason I got all the familiars, and even through the game, was because I'd check with the walkthru when I was feeling lost. I hate it that so many games nowadays don't include hints for actual puzzles... just hints to help you find hidden objects! I liked the game okay, but they really could have made the ending more satisfying.
 
 
katiepops wrote:[Your walkthrough is included in this game, it is galled the Guide. Click on it and it will give you what you are working on in full hint. It is better than a walkthrough because it is right there instead of having to go look it up on another site. There is no guessing with the Guide included.


Actually, there's quite a lot of guessing, even with the Guide included. At the moment, I'm stuck.. I can't figure out how to get the service elevator running. The only thing I have left in the Guide is telling me where the fourth chess piece is.. somewhere on the next level. I'm walking around carrying a music stand and can't figure out what it is for. I also can't figure out what the Hamlet guy wants to hold (well, knowing the line, "Alas! Poor Yorick, I knew him well!" I'm guessing it's a skull, but I haven't found one I can pick up yet). Again.. that's only a guess. And here I am.. stuck with guesses, even with the handy-dandy guide.
 
 
 posted in Diner Dash 5: Boom Collector's Edition on Mar 2, 10 1:31 PM
I have played all of the "Diner Dash" games and know how these extra foods work, but I cannot get Flo to pick up anything from the Salad Bar. Unlike the other games where the customers just get miffed that they haven't received the extra foods, these ladies hold on and finally leave without the salad.

How the heck do I get the salad bar to work?!?
 
 
 posted in Echoes of the Past: Royal House of Stone on Mar 2, 10 1:35 AM
Thanks for the walkthrough-- I use it as a "nudge through," just getting a hint so I can figure things out on my own. I wonder why game makers don't provide these kinds of hints in games any more!
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator