Posts created by Signing2Worship

 
 
Playing through and couldn't figure out what I was supposed to do next.
Though I hated to do it I checked the guide and was told that I was supposed to pick up a piece of coal to get a clue in the painter's tower.
No matter what I do I canNOT pick up the coal -
any suggestions?
 
 
 posted in Fierce Tales: Marcus' Memory Collector's Edition on Jul 14, 13 4:07 AM
I'm such a goofball. I was moving the root lines off the bucket to the edge, not getting them untangled until they all turn white.
Thanks!
 
 
 posted in Fierce Tales: Marcus' Memory Collector's Edition on Jul 13, 13 3:24 PM
I don't get it - I've moved all the roots and still can't get to the bucket... what am I doing wrong?!
 
 
 posted in Foreign Dreams on Aug 4, 11 5:47 AM
Oy. Okay, found it.
 
 
 posted in Foreign Dreams on Aug 4, 11 5:44 AM
I had enough fun with the trial that I bought it, but now I'm 2nd guessing my decision to go through difficult... can't find the 2nd light bulb for the juke box in the bar... ?
 
 
 posted in Tales From The Dragon Mountain: The Strix on Aug 1, 11 4:05 PM
Check this one out - much more helpful:

[removed by moderator]
 
 
 posted in The Serpent of Isis: Your Journey Continues on Mar 28, 11 12:12 PM
I have tried everything... everything but the right thing, obviously!
HELP!!
I have unlocked the secret panel in the bookstore.
I have done all the hidden object scenes.
Been through the bookseller's house, opened the chest and all.
I can go into the bookstore but can't talk to the seller.
Can't go through the passageway no matter what I do!

HEEEEEEEEELLLLLLLLLPPPPPPPPPPP!!!
 
 
 posted in Mystery Seekers: The Secret of the Haunted Mansion on Mar 10, 11 4:56 AM
Zoesgran wrote: a classic click and point adventure game that was aimed at 7-11 year old children

Really? no self-respecting 7-11 year old I know would enjoy this one - I'm so bummed.

I did look at the "achievements" to see how long it is - 15 "missions", 66 "items", 39 "mini games", 10 "letters"
 
 
 posted in Mystery Seekers: The Secret of the Haunted Mansion on Mar 10, 11 4:49 AM
I'm disappointed because it seemed to have potential!
Clunky is the best word I can think of to describe it though.
 
 
 posted in Scratches Director's Cut on Mar 2, 11 6:46 PM
so bummed. really wanted to enjoy this game and it simply won't run on my computer.
 
 
 posted in Phantasmat on Feb 9, 11 9:53 AM
I have played the trials for both CE and regular but I really don't see a difference. What's in the CE that isn't in the regular?
 
 
 posted in Awakening: Moonfell Wood on Jan 7, 11 5:00 AM
"We had a problem initializing the window. Looks like we won't be able to start the game"?
What the heck is that?
No error number?
No "I'm sorry"?
No suggestions?!
Just," Sorry, Pal, you're out of luck and we didn't want you to play this game anyway"?!?!?!
 
 
 posted in Nightfall Mysteries: Asylum Conspiracy on Aug 16, 10 7:37 AM
Every time I leave the game I have to start over at the very beginning - it doesn't save my progress.
I've gotten *really* good at the first few puzzles, but it's getting kinda old!!
Any suggestions?!
 
 
 posted in The Mysterious Past of Gregory Phoenix on Aug 16, 10 7:33 AM
Oy. Thanks so much for your help!
 
 
 posted in The Mysterious Past of Gregory Phoenix on Jul 21, 10 11:25 AM
I get all the required things but can't get the column to respond when I click - the sparkles are there but nothing happens when I click to play the mini-game to get the ancient disk. Is there a fix? a patch? PLEASE!
 
 
 posted in Island: The Lost Medallion on Apr 3, 10 6:08 PM
Bummer. I'm getting the same error - I was really looking forward to this one.
If anyone has any ideas about the .exe error please post it!
 
 
 posted in Rhiannon: Curse of the Four Branches on Mar 4, 10 4:39 PM
Great game, but is there a patch for the error when you start day 2 and can't keep the crayons and paper in your inventory?
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator