Posts created by saralestes

 
 
 posted in Avalon Legends Solitaire on Sep 9, 17 12:50 PM
Every time I play this game on my computer, the screen flickers annoyingly throughout each session. It's the only game that does this and it happened under Windows 7 before I got this computer running Windows 10. I have a brand new computer with tons of memory and a high-end graphics card (NVIDIA GeForce GTX 1080) with plenty of RAM. I tried to find this issue in the knowledge base but nothing came up, so can anyone tell me how to fix this? Is anyone else having this problem, too?



 
 
 posted in Myths of the World: Chinese Healer Collector's Edition on Jan 25, 14 12:48 PM
The game works fine so far, but after I have played it, I have to re-boot my computer 3 times or more for the startup to work correctly. I have two "Gadgets" on my desktop (Windows 7) that I use frequently and they seem to disappear after I have played the game. They start coming back, one at a time, when I boot and then re-boot twice more. Is there a fix for this?
 
 
 posted in Fishdom 3 Collector's Edition on Aug 6, 13 11:43 AM
I just found the answer to getting past level 125 on the Playrix site, in their knowledge base:

https://playrix.zendesk.com/entries/23114772--Fishdom-3-Level-125-251-walkthrough

"In level 125 / 251 you need to, first of all, blow up the right-hand wooden box and you should do it before exploding the left one. As soon as you have done this, a warhead will fall to the bottom tile. All you need to do then is to explode the warhead by double clicking it and it will destroy the soiled tiles on both sides." (see page on their site for a picture of the game board that makes this perfectly clear -- it worked!)
 
 
 posted in The Legend of the Golden Tome on Jul 17, 11 3:25 PM
The hint, "match up the colors" is the most important clue. It turns out that the pointer in the upper right quadrant is orange (hard to see that it's that color). It won't work until you have all of the orange sections lined up with that section. The other colors will click into position, and you can go crazy lining them up, but the figure will just keep repeating itself until you get the orange section lined up with the pointer. Then the door will open and you will have several hidden object levels in which you have to find all of the pages. Ta-da! You won!
 
 
 posted in Charlotte's Web - Word Rescue on Jun 15, 10 6:15 AM
I am running this game on Windows XP and experiencing a peculiar problem with it -- actually two problems so far, but only one is problematic for me in trying to play the game. When I exit the game and come back to it, it resets the available number of letter swaps to zero. This limits my ability to play the game as it is designed to be played and all I have left as a strategy is the shuffles. Has anyone else encountered this? Has anyone communicated with the company that produced the game to see if there is a fix for this problem?

(The other problem was that the game suddenly hung, minimized, and would not resume itself. I closed it completely and when I reopened it, my letter swaps were gone.)
 
 
 posted in Dragon Empire on Mar 22, 10 4:12 PM
Even though the layouts repeat again, beginning with level 101, you get to keep the advanced power tools, which make it more fun to play. I love this game! You can keep going and going and going...

I also discovered that you can "rebuild" in a different element after you have built all the buildings in one element and meet the requirements for other "titles."
 
 
 posted in Dragon Empire on Mar 22, 10 4:07 PM
busymom48 wrote:Ok, I need help!!! I have gotten to the 67th level and am now stuck. How do you get through this level? I see that there are tools but how do you use them? I have clicked on them and they do nothing. I am so frustrated now that I am almost sorry that I purchased this game. It seems that this is the last level to beat and it is unbeatable.


To get through the 67th level, you have to clear the three isolated boxes at the bottom. If you don't have enough powerups left from previous levels, you can fall back on creating a firecracker (match 3 across and 3 down) near them and when it blows up, it will take them out. I had to use a combination of powerups (the shuriken was very useful in taking out one box at a time) and finally finished the level by using the firecracker.

I discovered that the game has 100 levels, BTW, but you can keep going forever if you want to. The layouts repeat beginning at level 101, and you still have access to the advanced power tools.
 
 
 posted in Dragon Empire on Mar 13, 10 12:38 PM
Can anyone tell me how I can SEE the "quest icons" referred to in the tutorial? I have tried setting my resolution to different settings, but they still don't display. I have discovered that the little trees that give off smoke at certain points are some of the quests, but there are supposed to be icons below the pictures of the buildings in the tier you are working in, and I can't see them.

Also, how can you get all of the achievements in the same game when the requirements conflict with each other? For example, if you build ALL of the buildings in a single element, you get that one but it excludes the other element achievements.

I tried to go to Targem and they don't have a forum for Dragon Empire and their registration system doesn't work.

Does anyone know how to get help on this?
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator