Posts created by Starry10

 posted in Lifeline on Mar 18, 17 6:43 AM
I was getting bored so I hit the sliver button and found fast mode. Unfortunately he died. Then I did it again and same result. No chance of a different outcome that I can see. Anyone know how to make the guy not die?
 posted in Lifeline on Mar 17, 17 2:49 PM
my lifeline is stuck saying taylor is busy, then nothing for many minutes. It just sits there.
 posted in Spirit of Revenge: A Test of Fire Collector's Edition on Feb 14, 17 2:12 PM
I have same problem. Hoping someone helps. The walkthrough doesn't include the bonus game
I can't figure the order of selecting the seedling pictures in the library.
 posted in Forgotten Kingdoms: The Ruby Ring Collector's Edition on Jul 31, 15 2:00 PM
I see many messages of people who can't get the Trigon to do anything. These are from several weeks ago. I have this problem as well. Has this issue been fixed?
 posted in Dark Dimensions: Homecoming on Mar 31, 15 4:30 PM
 posted in Dark Dimensions: Homecoming Collector's Edition on Mar 21, 15 12:54 PM
I have the paints but they don't have a brush with them and I don't have it in inventory and game just says check your inventory.
 posted in Mysteries and Nightmares: Morgiana on Jul 12, 14 6:40 AM
I now have the alpha key but don't know where to use it. The map has no more sparkles so I don't know what scene to go to.
 posted in Dark Tales: Edgar Allan Poe's The Premature Burial on Jan 6, 12 12:29 PM
ok so how do you gain access to the inventory when you have the scene open to the water spouts, I can't get to it and when I go to the large scene, I can't find any place to put the corks in scene that will take.
ok I see a lot of messages but no help, would some kind soul please say how to put the corks in the hole?
 posted in Time Mysteries: Inheritance on Oct 16, 10 3:25 PM
You are right on YaYa, I struggled with the wine bottles endlessly until reading your post and I closed and opened the game and I got the bottles with big x's on them and you are a genius!
 posted in The Seawise Chronicles: Untamed Legacy on Sep 26, 10 3:43 PM
Please help, I'm stuck in a room with a goblin and parrot. The walkthrough says to put ammo pellets where bird food is to kill bird, then hit guard with picture frame. I tried the pellets lots of time but bird won't die, and clicking picture frame doesn't move it. Does anyone know?
Go to:   
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator