Posts created by skyepearl

 
 
 posted in Modern Tales: Age of Invention Collector's Edition on Apr 17, 18 1:16 PM
I don't contribute much but I do read daily. Thank you to the moderators & to all who've posted!! I use your opinions to help me decide in purchasing, as well as seeking help when I'm stuck. I'll vote to keep the forums open, sure. But I highly doubt it matters. So I'll just say my g-byes & thanks while I can. I've REALLY enjoyed my time here...10 years.....over 900 games....WOW! But, like others have said, it's all gone downhill & it seems to be gaining speed at an alarming rate.

I just pray I don't lose my games. I know they'll chime in to reassure, as of THIS moment, they're safe & sound. What about next year or the year after that, when the forums and members have all disappeared....and they don't bother to offer anything but FTP & mobile here anymore. What happens when the software that keeps my purchased games available for me to download needs updating..... If there's a downward spiral in PC gaming, I don't see them springing for that upgrade either.

With the disappearance of the forums, so goes my trust in the website. I'm following the current elsewhere &, once my credits are gone - so am I. I'm not dropping another dime here. Of course my game club credit renewed YESTERDAY.

Looks like Steam just became my wallet's #1 boo. Hope to see some of you there!

 
 
I've owned this game since 2015 & it used to play perfectly. Decided to give it a replay (on the same computer as the original play) during this 2017 season & the animations, starting from launch - including the BF logo, are extremely slow & jerky, as a few others have reported.

Updating Flash, Java, & graphics drivers didn't do anything to resolve it, but playing the game in Win 8 compatibility mode did the trick for me. Animations flow like warm buttah now.

Just a note incase it might help someone else...

EDIT: Playing on Win 8.1 desktop
 
 
 posted in Delicious: Emily's Miracle of Life Collector's Edition on Nov 7, 17 11:25 AM
Not much really...lol But, I supposed it depends upon how much you enjoy it...

I'm pretty sure the extras you get are the "challenge" levels scattered throughout the game, between levels. The first being a stork on the map right after you finish the first level. They are more stand-alone arcade/TM levels such as, "don't let anyone leave angry" while you're bombarded with a metric buttload of impatient people. Or "find 100 mice in the time period" (while serving customers, of course). - not actual examples from the game. I think those optional challenge levels award you diamonds, with which you purchase something that doesn't unlock until you reach a certain level (probably after purchase). I read in the reviews that it unlocks decorations to buy for a baby's room. I believe that the trophies/achievements - (postcards, in this game that you can send to real people? - seemed that way, didn't try) & the usual "collectible" mice are also in the SE versions.

I have purchased both SE & CE versions of the older Delicious: Emily games & would always choose to buy the SE.....IF, & that's a big IF, they offer the SE version. This is the only series on BF (that I noticed anyway) that (sometimes) forces you to buy the CE if you want the game as they do NOT offer the SE version later. I'll put this one in my puddle for awhile & see if they release the SE, otherwise I'll wait for a BOGO. I enjoy this series, but I prefer the regular levels to the challenge levels, so it's not really worth it to me. Speedy & dexterous children may enjoy the extra challenge, so I guess it's up to you to decide what's best.
 
 
 posted in Roads of Rome: New Generation 2 on Nov 5, 17 5:59 AM
Excellent job, LadyMorganFox! Much appreciated!!!

Thank-you very much for doing this!

~skyepearl
 
 
You can request a refund by contacting Customer Service (which is not intuitive to find).

1. Click on the tiny blue "Customer Support" link waaaaay down at the bottom of this page under all of the "check us out" icons.

2. Ignore everything on the page this brings you to &, instead, click "MORE".

3. Click on "Contact Customer Support", which brings you to yet another page.

4. Click on the blue worded "Contact Customer Support by email" in the first paragraph.

5. Fill out the appropriate blanks & submit.

You will get an automated response, that does absolutely nothing to help you, within a few days. REPLY to this auto-email stating this auto-reply doesn't help you. A few more days may go by & then you should get an actual person to reply to you via email. It's takes a bit of time & effort but once you actually talk to a live person, they are pretty helpful.

Hope this helps!

Good luck!
 
 
The sweet spot in the back left corner where it looks like the mirror should go - there are mirrors already in all the other corners. Hover your cursor over that pillar in the back left (nearest the petal area) & it should turn into a gear icon - that is where the mirror goes. Once placed, they'll need to be adjusted so the beam points out which petals to press. Hope that makes sense. Or, if all else fails, you can use a hint - which, I'm sure you're trying to avoid doing for the achievements. Good luck!
 
 
 posted in Legendary Slide on Jan 24, 17 6:25 AM
Thank you, Maddy141! Very helpful
 
 
 posted in Mystery Case Files: Broken Hour Collector's Edition on Dec 4, 16 8:41 AM
The object is to try to reduce the amount of balls on the field. If you get too many, the game resets.

You reduce the amount of balls by using the + sign to combine pairs. Don't think of it like addition. It's just matching numbers equally on each side of the + sign. So try to set it up with a starting pair; for example two 3's together. Then on either side of that pair shoot in the same numbers, for example two 1's. So it would look like this: 1331. Then you get a plus sign & shoot it in the middle of the 3's: 13+31. All five of those balls will now become a single ball with a 5 on it.

 
 
The mouse is not beneath the timer, its literally under it...as in the timer is on top of the mouse & covering most of it. You can only see an ear sticking out toward the top part of the timer. VERY hard to spot.
 
 
 posted in Delicious: Emily's Hopes and Fears Collector's Edition on Sep 13, 16 2:51 PM
This is excellent, thanks!
 
 
 posted in Game of Stones on Apr 21, 16 8:59 AM
Color me excited!!! Can't wait!
 
 
 posted in Steel LIFE on Mar 29, 16 10:04 AM
I had a hard time with this puzzle, too.

I discovered, quite by accident, that when a piece of paper is in the correct spot, it highlights & connects to another paper when you click! So, just lay out the pieces so you can drag one of the pieces slowly over the rest until you see it light up. Then while it's lit, click.

Hope that helps.
 
 
 posted in Spear of Destiny: The Final Journey on Feb 14, 16 5:06 PM
SHIPS:
1. Cell - left side, under table
2. Beneath the Bridge - above the lion head
3. French Mansion Foyer/Main Hall (unlabeled) - right side, top of tall cabinet
4. French Mansion Jail (unlabeled) it's the room to the right of the harp room after the butterfly puzzle - above the left door

TANKS:
1. Old Mine Shaft - center screen, by bucket
2. Very first screen after mine cart crash (unlabeled) - in broken cart, right side
3. Town Gate - next to cup/coin guy on rock
4. Harbor - on the barrel with the red cloth

CANNONS:
1. Tunnel - on the upper left in the red curtain
2. Secret Room (boy runs away) - top of shelf above desk
3. Castle Gates - top of wall, left side, between turret & gate
4. French Mansion Bomb Room (unlabeled) it's the room left of main hall/foyer leading to greenhouse - on the chair

BOMBARDIER PLANES:
1. Town Square - on ground left of old man in front of crate
2. Demolished Hallway - upper right screen in wooden beam
3. French Mansion Greenhouse (unlabeled) - above the light pink flowered arch
4. French Mansion Bakery (unlabeled) it's the room to the left of the harp room - on bread shelf

HUNTER PLANES:
1. Harbor - on the left side on a crate above the anchor
2. Throne Room - on the upper left on a tree branch
3. 1st Icy/Snowy area (unlabeled) - left of the crate, right side of screen, on ground
4. French Mansion Workshop/Blacksmith (unlabeled) - on the ceiling by the wheel & rafter

BOMBS:
1. 1st area right after the minefield with the large hole in the ground (unlabeled) - right side tree roots
2. Secret Passage (room with 2 cat statues needing collars) - middle right screen above archway with bars
3. Ceremonial Chamber - upper left screen by dragon head
4. French Mansion Bar/Spear room - upper screen, left of chandelier & right of mirror

Good luck in your collecting!

 
 
 posted in Spear of Destiny: The Final Journey on Feb 14, 16 4:30 PM
Searched the internet but couldn't find a complete listing on ALL the collectibles - so I ended up making my own list. None of the rooms in the final location of the game - the "French Mansion" area - were "officially" labeled, so I'll do my best to explain where to find them. Hope this helps!

7 FIGURINES:
1. Roosevelt: Apothecary - left counter
2. Eisenhower: Dock (by the tank & minefield) - left side of screen under lamp
3. Truman: Tunnel - lower right screen, behind leaves
4. Stalin: Cliff - left/middle screen, right of statue, on wood post
5. de Gaulle: Sanctuary - between left curtain & altar, on floor
6. Churchill: Icy Bridge - center screen, railing by bare branches
7. Hitler: In French Mansion (unlabeled) room with harp & bust needing green eyes - on top of harp

WAR UNIFORMS: (ALL of these collectibles look like military hats/caps in the game but are actually different articles of clothing for the mannequins)

Army (left mannequin):
1. Spiked Tomb - Shoes (1st collectible able to pick up) - on left spiked wall
2. Town Gate - Pants - near red/black/white guardhouse & gate
3. Apothecary - Hat - on top of left shelving unit
4. House (next to apothecary) - Jacket - behind woman on statue head
5. Dock (by tank & minefield) - Gun - on right railing

Navy
(middle mannequin):
1. Very first screen after mine cart crash (unlabeled) - Shoes - on left bench
2. Secret Room (boy runs away) - Pants - right side screen, on curio cabinet door
3. Lakeside - Hat - on dock post
4. Castle Gate - Jacket - on obelisk
5. Front yard of French Mansion (unlabeled)- Sword - above door on the ledge, left & below the big window.

Marines (right mannequin):
1. Secret Passage (room with 2 cat statues needing collars) - Hat - at the top of the stairs, on the right side
2. Ceremonial Chamber - Shoes - on left most of 3 pillars
3. 1st Icy/Snowy area (unlabeled) - Pants - left of tree on pedestal
4. French Mansion greenhouse (unlabeled) - Jacket - on the floor by the red curtain
5. French Mansion bar/spear area (unlabeled) - Gun - on animal head left wall

To Be Continued....
 
 
 posted in Invasion: Lost in Time on Aug 3, 15 1:36 PM
I, too, had the same issue with the Menu button not working. It would flicker, but then nothing would happen. Win 8.1 desktop here, Nvidia card.

Also, sometimes when in a close up (small zoom window) I was unable to exit the close up via the X in the upper right corner. Nor did clicking outside of the close up box do anything. I could access the map & the diary, but the menu was unresponsive. It would just flicker when pressed, but nothing would happen. This happened when viewing the books for the first time & another when viewing the boat. (Trialed twice in 5 minutes & froze both times in zoom close up w/unresponsive exit & menu). The game didn't "freeze" though, because all of the other buttons worked - including hint. The hint was directing me to another location but I couldn't go there because the close-up box was blocking my way.

The only way to exit was to Ctrl-Alt-Del. The first time it wiped out my progress, the second it didn't & was able to continue from where I left off...well, until it became unresponsive again.

I located the execution file on my computer & ran the compatibility troubleshooting wizard. I accepted the recommended settings & tested again. This time I was able to exit close-ups & the menu button worked! There is still quite a bit of flickering when I close those zoom boxes or use the menu, but it worked.

I really want to buy this game, but I'm a little nervous it will again lock up. It seems highly unstable.

UPDATE: I updated my Adobe Shockwave player when I ran into slowness/graphic troubles with another game. This seems to have also helped this game as the flickering has completely stopped! I have a newer, high-powered computer with a really good graphics card, so I was surprised to have any troubles whatsoever. My graphics cards was up to date, as was my Flash player. Shockwave was the troublemaker for me. I'm buying this now. Woot!
 
 
 posted in Nevertales: Smoke and Mirrors on Jan 4, 15 4:37 PM
4 - 3 = 1
 
 
 posted in Dark Angels: Masquerade of Shadows on Jan 2, 15 9:56 AM
persephonie,

I've installed the game & tested after purchase with no problems (Win 8.1, 64). It's a little slow to load scenes & the menu, but it seems to be working perfectly otherwise. *shrugs*

Did you activate the game from the trial page or did you delete the trial & download the full game from your purchases? If you activated, I would try deleting the game & re-downloading the full game from purchases. Sometimes the downloads/activations get mucked up for whatever reason. Hopefully a re-do will fix things for you. If not, I'd contact CS with a Dr. Felix. They may be able to help you get it running. Good luck!
 
 
 posted in Dark Angels: Masquerade of Shadows on Dec 31, 14 3:47 PM
Thanks, bfgWaimea!

It's fixed & I just purchased it successfully at the $2.99 price!

Happy New Year!
 
 
 posted in Dark Angels: Masquerade of Shadows on Dec 31, 14 1:55 PM
Just a warning....

Today's $2.99 Daily Deal is showing up as $6.99 in the checkout cart.
All of the Buy It buttons say $2.99 but it's not working at checkout.
Hopefully, no one has already purchased it at the switcheroo price.
 
 
 posted in Dark Angels: Masquerade of Shadows on Dec 31, 14 1:43 PM
I'll third that problem. I'm in the same boat as SueB990 & abbcindy.

Comes up as full price in my cart. Hope customer service can help us out. I also wonder how many fishies bought this & didn't notice the price change.
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator