Posts created by gamergirl675

I guess I missed names somewhere because I don't see where the bonus chapter fits into the story line... who is Holly B in relation to the main game?

 posted in Maze: Nightmare Realm Collector's Edition on Aug 20, 17 2:49 PM
Is there a glitch in the scene with the school bus? I found the collectable swirl but when I click on it nothing happens and the notice still says collectable not found. To be sure I checked the guide and it says the swirl is right where I'm clicking.

Having the same swirl for all the collectables is lame enough... the least they could do is be sure they work otherwise why did I pay double?!

What do I need to do to correct this?
Disappointing. It's just the same as every other game out there and that was the one thing MCF always had going for it... they were unique and cutting edge. There's nothing wrong with it really, it's an ok game with all the bells and whistles... but... it didn't draw me in.

November used to be a banner month for big fish... all the fun threads in the forum with hints and clues to solve... so much fun! The pre-game was almost as fun as the game! None of that this year so that could explain some of the loss of excitement. But not all of it. With the other MCF games I was downloading as soon as it was available and almost going without sleep because it was so good. Even when some things weren't perfect or took a while to get used to they were still intriguing and kept you involved. With this one I downloaded when I had time, I wasn't waiting for it. Then I have to force myself to keep playing because it just doesn't have that "I need to see what's next, I want to solve the story" aspect. It's missing. I miss the videos... the live acting... the flash... Dire Grove... the twins in Ravenhearst... 13th Skull... Shadow Lake... yes they were "love 'em or leave 'em" games... that was what made them special. Maybe they'll sell more of this game because it follows the same old same old stale pattern that seems to sell. Do you want a McDonald's hamburger or do you want a Barney's Gourmet hamburger?

I think the forum itself speaks VOLUMES... there are ONLY TWO pages in the review thread... two. There were THIRTY ONE pages on the review thread for Escape from Ravenhearst. That's HUGE. There were even SEVENTEEN for Shadow Lake. Sure some are negative but people were ENGAGED and ACTIVE... this time? Yeah not so much. What a loss.
Valdy wrote:
gameswolf wrote:Where is it? I apologize for posting this here, but since the Chit chat corner was axed, there is no place to ask other fishes what is going on.

It's here:

Took BF a few minutes to get it up and running, but it's been up for a while now.

BTW, your best bet is to click on "PC Games" and then on "New Releases". Then you will see yet another FREE game as TGT.

Sorry Valdy... not the TGT. There seems to be no TGT. Singing Monsters is listed under new release and is available for anyone, not just game club members.
 posted in Mystery Case Files®: Dire Grove™ on Jul 9, 13 10:55 PM
Hespera wrote:Snarky is by far the best and funniest in my opinion. No one does snarky quite like BFG, especially when it comes time to do some of the 'special' things in the game, like with the rabbit.

Couldn't have said it better!
 posted in Corpatros: The Hidden Village on Jul 3, 13 6:08 PM
I tried to like it... loved the intro. But when I''m punished for clicking when the very definition of an adventure game is clicking and exploring options it's a no sale for me. If they had left off the click penalties and even better dumped the H0 scenes I might have stuck it out longer. Too bad the game itself didn't live up to the intro...
 posted in Corpatros: The Hidden Village on Jul 3, 13 5:11 PM
I wanted to like this game... the story was interesting and I liked the intro... but... it just doesn't work. Make up your mind. It pretends to be an old style adventure game but then it throws H0 scenes in the mix!! And worse you are STUCK staring at the boring H0 scenes because if you try to click and try things out the hint button restarts.. BIG MISTAKE. The definition of adventure game is clicking to try things... do NOT punish me for it.

For example... (highlight since it's a spoiler sort of) in the first H0 scene the list is pictures and there is a BLOB of nothingness that you are supposed to find... click everything that looks that shape but NOPE you are supposed to know to click a BUTTON that turns on windshield wipers which displays a graphic that looks NOTHING like the picture you're looking for. And since most cars do NOT have BUTTONS to turn on windshield wipers HOW can you find that without clicking?!?!? But yet you PUNISH me for clicking.

So I have a feeling these devs... if they even exist anymore... will NOT be existing for long since this game is going to be a NO SALE to most people.
 posted in The Game of Life ® on Jul 1, 13 8:55 PM
I don't have that game so I'm not sure. But maybe contact CS and see what they say? Run a DrFelix and include it because that way they can see if anything needs updating for the game to play correctly. Worth a try anyway. Good luck!
 posted in Dreamscapes: The Sandman on Jun 30, 13 7:48 PM
I really regret buying this game....... from big fish!!! I wish I had gone elsewhere and purchased the CE version. SHAME ON YOU BIG FISH FOR NOT OFFERING IT HERE!!!!!!!!!!!!! Far better than some other CE's you've sold.

This game is amazing!!! 5 stars

Beautiful graphics... intuitive game play... fun extras like "beholders" to find... don't miss out on this it's a gem. (But DO go elsewhere and buy the CE version... wish I had!)

I hope the sequel comes out soon... I'll be buying ALL games from this dev from now on.
 posted in Aquascapes on Jun 25, 13 8:57 PM
So I stopped playing and when I came back and started it again my fish were all starving. I don't want a real time game... I can't possibly have to worry about GAME fish starving just because I don't play a game for a while. I know in other games like the tribe type you just have to choose a certain exit mode so that they don't keep "going" when the game is off. How do we do that in this game?

 posted in Off the Record: Linden Shades Collector's Edition on Jun 16, 13 2:52 PM
Cont: ran out of room

One more thing... do NOT NOT NOT give me a screen saying "for best experience play with sound"... I know that. And it's my choice. If I want to play with sound (and I do) then I will... but I don't want an "in your face" screen telling me to play with sound. That has to be one of the most annoying things I've seen in a game so far.

It looks like a good game... but due to the above if I play it will be when I get it for a $2.99 sale or with a freebie code. And the premise and live acting means it would have been almost a sure sale for me. When you turn off someone who is already programmed and in the mode to buy then you are clearly doing something wrong.

ETA: You know what? I think I figured out what is off about this game... it's like two different games pasted together!! There's the cut scenes, acting, jump map etc... which are all wonderful. Then it's like they took that and pasted it onto a dated old graphics style game from a few years back. That's totally the feel I get.
 posted in Off the Record: Linden Shades Collector's Edition on Jun 16, 13 2:46 PM
Could be a good game... love the cut scenes and live acting.

But since Big Fish says the reviews are forwarded to the devs....

Dear Devs,

Here is why I am NOT buying your game:

Difficulty levels... let ME customize my style of play. I do not want sparkles or active areas to be indicated. I want to click around, explore and find them on my own. I do, however, want them to be indicated on the map when I click on it. You don't allow that, it's all or nothing with you. I also want fast hint/skip refills, better yet, NO refill time at all. I may not use them at all and then reach a spot where I need a couple hints in a row. Don't force me to sit bored starting at the screen waiting. Let me click hints when I want. (For the expert choices what's the difference anyway? If someone doesn't want a hint, don't click it. Simple as that.)

Extra content... Once I pay you for the game these items are MINE. Don't force me to finish the game first because once I'm done I don't care anymore. I want to set wallpaper, listen to music, look at artwork WHILE I PLAY. Total immersion. And worse don't force me to finish the "bonus" game first! What if I don't want to finish it? What if I don't like the bonus game? Then I have paid for nothing. ALSO... let us at least have a peek of what is included instead of the big obnoxious locks. It's like what if you walked into Target and the sales guy said "Nope you can't even LOOK at the clothes before you buy them let alone try them on. It's red and a size 7 that's all you need to know." Ridiculous right?! Well that is EXACTLY what you are doing by locking them in the demo. Remember the demo is your sales pitch to me... make it good so I WANT to give you my hard earned money.

Graphics... the cut scenes are great... the other graphics a little sloppy. I'd prefer higher quality. And what is with the total black NOTHINGNESS that is between while things load?! That's sloppy. I almost thought the game had crashed and turned it off... a couple more seconds and I would have which is a lost sale for you. Optimize your graphics for faster loading or at least give me a loading screen so I know it's working.

So it's your choice... you can say "It's OUR game and we'll program it any way we please so deal with it"... and eventually you'll go out of business. Or you can recognize that I am your customer and if you want my money you'll need to give me reasons to give it to you...
 posted in Dark Dimensions: City of Ash Collector's Edition on Jun 16, 13 2:04 AM
I'm not sure... I have to think on this one. I love that they used an actor for the girl. But there are a lot of careless mistakes and annoying contrivances to create game play where really none exists... turns what should be fun game play into busy work to keep the player occupied.

This could be a spoiler but it's pretty mild and happens in the first few minutes... For example... you need a screwdriver but the graphic is of a flat head and the screws are Phillips. So why couldn't they be bothered to make them match? Now granted you COULD in real life make a flat head work on Phillips but it's hard and if the screwdriver is larger than the screws it won't work... and even if it's smaller it's hard. So assuming they intended it to be that way (and I don't think they did, I actually think it was laziness on their part) but giving them the benefit of the doubt then WHY exactly did we need to find a hammer to smash a window... a hammer we got through a long convoluted process that began with finding a large board that could have smashed the exact same window probably just as easily as the hammer?!?! And really much easier than using a flat head screwdriver in a Phillips screw head.

See devs... gamers are SMART and we notice things. We want our games to be logical and we want to figure things out but we don't want to take ten steps to do something that could have been accomplished in two steps. We want creativity and originality in our games... we want to think and become engrossed in the story...

Also... for options... don't tie no click penalties to sparkles... some of us would like to explore on our own and yet we also don't want to be punished for clicking (it's a game... we are supposed to click!) so let us customize our difficulty choices.

Anyway... probably a no sale for me... maybe as a freebie coupon some day if I run out of other games to play.
 posted in Dark Parables: The Final Cinderella Collector's Edition on Jun 15, 13 10:34 PM
Is this a glitch or am I missing something?

I found both pendents and placed them. Followed the clues on the papers and on the small statue thing... have tried every combo of symbols and the right side fountain will NOT empty of water to allow me to pick up whatever is down there. I have the piano keys from the left side. I even resorted to the SG which I never do and it doesn't help... just says to do what I have been doing. Exited and restarted the game just to see if that would help but no luck. Hint button just highlights the fountain (gee thanks for that NO help hint devs)

Am I screwed? Or am I just being stupid and missing something vital? (To recap I have placed both the right and left medallions and tried all the combos of symbols by clicking on the urns... the left side will empty and I got the piano keys, the middle will empty although there's nothing to take, right side will NOT empty.

Thanks so much!
 posted in Chimeras: Tune of Revenge Collector's Edition on Jun 13, 13 1:48 AM
This one I regret buying... it just seems so stale and done already. Don't get me wrong... the voice overs are amazing... the graphics are beautiful... and to be honest I didn't want to click play in the beginning because I was enjoying listening to the poem. But... the game play itself is just very cookie cutter. It doesn't make sense for one thing... like you find HALF of a pair of scissors in one place and then in another place totally unrelated to the first place you find the other half? HUH? I think this game maker has just gotten comfortable... they just write a story, hire a voice actor, and then plug in their same old tired game mechanics from all their other games.

Don't get me wrong... compared to lots of other games this one is beautiful... the graphics... voice over... but... as I said the mechanics are trite and over done. Also I'm playing on advanced but it still seems simplistic. And that's ok... just that the SG isn't needed so why pay for it? We'll see about the bonus play when I'm done... if I finish...

I'm sure I'm the lone voice of dissent... it just doesn't live up to it's potential. I wish the actual game play portion was more engaging and logical to the storyline. It's almost like they just... insert cut scene... oh we need a hidden object scene so toss that in... now we need to keep the player busy so add in a bunch of half parts of things to find and collect to use somewhere else... oh they need to remove some nails but we won't let them use the hammer we'll make them find a crowbar (which they call a nail puller LOL)... at least they did make the hammer the kind not appropriate to nail pulling but we're talking about removing some old boards so really a pop on the other side with the hammer would have worked... and it goes on like that... just... boring. I wish they would put more effort into the actual game play.

Just something for someone to consider who is debating the CE vs. SE... I wish I would have waited and picked this one up with a freebie credit or a $2.99 sale. It's still beautiful and listening to the storyteller is worth the price of admission... just not worth the CE price I don't think.

Still a solid 4 stars... but I don't think it deserves the 5 star rating it has. I think that is based on name and "pretty".

PS: Dogs don't pant while they're eating...
PPS: Dear Devs... if you're thinking who cares she still bought it... yes but next time I probably won't.
What a clever and wonderful game this is!! I haven't had time for game playing in a while but was able to pick this up in the sale today and it's worth every penny. There are other/better reviews before mine but just had to stop playing for a minute to come praise the devs.

Ok... the following may be mild spoilers for those who want to know nothing at all about a game before playing... but not enough to hide with white writing... just wanted to give someone a chance to stop reading if they want to discover everything on their own.

The attention to detail in this game is truly star worthy... no morphing objects but you do have little extras to find and when you find them you actually get to do something with them. A map that allows you to click to go to various locations... an adorable little hamster that stays with you for a while to complete various tasks... oh and one of the BEST things of all... you can customize your game play!!! So instead of just the typical "easy vs hard" choice you actually get to choose how to set it. For me that means I can play with NO sparkles leading my way and telling where to click, no tutorial, no anything and yet I can STILL choose my hint and skip options, the lowest of which is 15 seconds so pretty much no lag time. The hint also functions to tell you a direction to go in if you're stuck.

There are also some clever and cute ways the game entices you to click where the hidden object scenes are... I love it. Another bonus in my book is that the hidden object scenes are not only minimal but very unique... each seems different. I haven't even needed to look at the list much which is perfect for me. No click penalties either. The mini-game/puzzles are PERFECT! As Goldilocks would put it... not too hard... not too soft but JUST RIGHT! I love them all and haven't even been tempted to read the directions or skip them at all.

The game is so good I can't stop playing. And I've been bored with the games I've played lately... so much so that I was thinking maybe I was just getting tired of these types game in general but this one has me addicted again.

PS: I take it back... there ARE morphing objects!! Just not until you get to the bonus game (which is worth the extra CE money.)

5 out 5

Now that I've finished I have one tiny comment... Dear Devs... events do NOT perspire (aka: sweat, exude, emit thru pores) I believe you meant TRANSPIRE aka: take place.
 posted in 100% Hidden Objects on Apr 14, 13 2:15 AM
Oh my. Are you kidding me? If you like junkpile, stock graphics, and having your hand slapped if you click too fast then this game is for you. Otherwise... don't bother.

I liked the idea of a straight hog with achievements to make it interesting but it didn't work... and once I realized there were click penalties as well I stopped trying to find the good and bailed. And let's not even go into the cheezy muzak.

PS: Almost forgot... dear devs "achievements" should actually mean something... playing for 2 or 3 hours without a break is not an achievement.
 posted in Gardens Inc.: From Rakes to Riches on Apr 14, 13 2:01 AM
Has anyone had this happen where you clear the path and fix the bridge but you can't move on because it still shows red and says "the path is blocked" even though it isn't actually blocked??
 posted in Slot Quest: Wild West Shootout on Jan 12, 13 12:12 AM
About as exciting as watching paint dry.
 posted in Jewel Quest: The Sapphire Dragon on Jan 11, 13 11:34 PM
Campy cute story and voice acting. Relaxed mode and nice sound effects. SOLD!
Go to:   
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator