Posts created by micidawn

 
 
 posted in Mystery Case Files: Return to Ravenhearst ™ on Jan 19, 18 11:17 AM
I used the hammer to remove the nails from the bedroom nightstand drawer. Every time I click on it, it tells me that it still has the nail in it. I need whatever is in the drawer but it won't open. I have had this game for a long time and just now reinstalled it to play before I play the latest 2 Ravenhearst games. Help! I am stuck without the item in the drawer.
 
 
 posted in Secrets of the Dark: Mystery of the Ancestral Estate on Apr 25, 13 12:18 PM
I enjoyed the very short demo of the game and I am thinking of buying it, but I have one major qualm. I couldn't play the game on a full screen as the playing field was down and to the left. I had big black spaces on the top and to the right and couldn't read all the words, etc. It is harder to play on a small screen and I am afraid that it would happen if I bought the game.
 
 
 posted in Mystery Trackers: The Void on Apr 6, 13 6:38 PM
I am in the cave at the hotel? I fixed the ladder and it won't let me go up it. No matter where I move my curser, no ladder.
 
 
 posted in Azada: Elementa on Apr 6, 13 12:03 PM
I am 40 minutes into the demo and my game suddenly froze. I had to use control/alt/delete to get out of it. I have Windows 8. I always have loved all the Azada games and now I am afraid to buy it.
 
 
 posted in Ghost Towns: The Cats of Ulthar on Mar 22, 13 10:59 AM
I was looking at the walkthrough for this game and none of the pictures of the scenes would load, only the box with the red x in the left corner. It's hard to use the walkthrough when you can't see the pics.
 
 
 posted in Haunted Legends: The Undertaker on Jan 8, 13 12:15 PM
I was 45 minutes into the trial and the game suddenly had an error code and then Windows closed it out. I was thinking about buying it, but now I am very trepidatious about doing that.
 
 
 posted in Mystery Case Files®: Shadow Lake on Jan 3, 13 12:41 PM
I am trying to play and I can't see the full screen. It is off to the left with a wide back bar on the right side. I also can't see my cursur most of the time. Unable to do anything.
 
 
 posted in Suburban Mysteries: The Labyrinth of the Past on Aug 18, 12 1:32 PM
I have put 3 of the 6 pins in the holes. How do you get the lock to turn to open the holes to put the last 3 pins in?
 
 
 posted in Suburban Mysteries: The Labyrinth of the Past on Aug 18, 12 1:29 PM
You need to pick up the yellow rubber gloves to unplug the hairdryer in the sink to get another metal pin.
 
 
 posted in Secrets of the Titanic 1912-2012 on Aug 11, 12 11:20 AM
I just now tried playing Secrets of the Titanic 1912-2012 and when the screen opens up it is low and to the left. I can't see all the items on the list to find and I can't see the whole screen to find the items in. What is up with that?
 
 
 posted in 1 Moment of Time: Silentville on Jun 16, 12 11:12 AM
I also have a problem with the game not being centered. My game seems to be to the left side of the screen and I also can't see the entire list of HO to find. It makes it hard when you only get 2 lines of items to find. Made it through 2 HOS, but too frustrating to continue.
 
 
 posted in Grim Tales: The Legacy on Feb 9, 12 12:17 PM
I am also having trouble using the screwdriver on the portrait over the fireplace. Everytime I try it says I can't use that item here. It worked on the CE demo, but won't work on this one. HELP!
 
 
 posted in Timeless: The Forgotten Town on Aug 9, 11 12:42 PM
I tried to download it yesterday and it said it couldn't. Today, I tried to again and it now says ready to install and won't do anything. Totally baffled.
 
 
 posted in The Missing: A Search and Rescue Mystery on Jul 25, 11 11:47 AM
I wish I could have tried the game at all. My NEW computer couldn't even download it. It kept saying there was an error while downloading. It would go up to like 4% and then go right back down to 1% dowloaded.
 
 
 posted in Epic Adventures: Cursed Onboard on Mar 17, 11 1:59 PM
This game worked but it was S-------L--------O----------W! I played it though, since most of the BF games lately, I can't. I figured slow was better than not at all!
 
 
 posted in Shadow Wolf Mysteries: Curse of the Full Moon on Mar 7, 11 10:40 AM
I donwloaded the game yesterday and when I opened it, it flickered badly so it was impossible to play. I deleted it and upgraded all my video. Today I downloaded it again, and it still flickers so badly that you can't play it.
 
 
 posted in Dr. Jekyll & Mr. Hyde: The Strange Case on Mar 7, 11 10:36 AM
I downloaded the game and it wouldn't play or open the 1st time. I deleted it and downloaded it again, and this time it played but it had a weird language that I couldn't read. I guessed through the 1st hidden object scene, but I quit after that, too hard. Weird, the title was in English, but all the other instructions were unreadable.
 
 
 posted in Akhra: The Treasures on Mar 2, 11 12:56 PM
birdboysf wrote:The game never started, lost some trial time and reinstalled a few times. Each time Windows gave me a fatal exception error. So I gave up.
The good news is that as the reviews for the game haven't been too great, I guess I am fine with not getting to try this one out. Seems like I won't be missing anything.
It does bother me that BFG guarantees the games to work and then they don't.[/quote

I had the same problem when I tried to open my game also.
 
 
 posted in Reading the Dead on Feb 26, 11 1:59 PM
I also played until the I threw the brick through the grate and then it went black. I had trouble the whole game as it played very slow, but I at least could play it. Wish there wasn't as many problems as there is with BFG, there seems to be more trials that don't work than do work.
 
 
 posted in Mystery Agency: A Vampire's Kiss on Feb 19, 11 11:57 AM
I also got the "This hardware is not supported by Mystery Agency: A Vampire's Kiss" message when I downloaded the trial version. It seems like more games don't work than do work anymore. Very disappointed in the quality as of late and it is the major reason I have ended my membership with BF games.
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator