Posts created by gamertlc

 
 
 posted in Grim Facade: Monster in Disguise Collector's Edition on May 19, 16 9:05 PM
I uninstalled/reinstalled and it shows my full trial available again.
 
 
 posted in Grim Facade: Monster in Disguise Collector's Edition on May 19, 16 5:16 PM
The trial expired right after I downloaded and installed the game. I haven't played it yet!!!
 
 
 posted in Campfire Legends: The Babysitter on Apr 11, 16 6:41 PM
Finally found it!

For anyone stuck here, "the room" refers to the video room and "that box" is a little gray metal case off to the left side of the scene. After you click on it you have to find 9 buttons and then play a mini game to open it.
 
 
 posted in Campfire Legends: The Babysitter on Apr 11, 16 4:20 PM
Can anyone help me? I'm in the basement looking for the fourth tape. Hint asks if I tried looking in the box in the room. Which room? The video room? The office? The food storage room? The workshop? The holding cell? Surgery? I've looked in all of them and can't find it. SO not a helpful hint!
 
 
 posted in Chronicles of the Witches and Warlocks on Apr 10, 15 12:52 PM
Add me to the list of people stuck at the cabaret. The hint button stopped working.
 
 
 posted in Haunted Manor: Painted Beauties Collector's Edition on Jun 9, 14 9:49 PM
FunIt wrote:I used the water on that desert altar BEFORE putting out the fire of the dragon.
Now the decanter is gone, and I can't finish the Bonus Chapter.

Me too! Now I have to play the whole game again to get to the bonus chapter! This sucks, BFG!
 
 
 posted in True Fear: Forsaken Souls Collector's Edition on Mar 4, 14 6:23 PM
Poof11 wrote:I can complete the entire scene except it will not allow me to pick up the knife to open the can for the rattle. I have exited the scene like I did in a previous HOS but the only thing that changed was where the rattle was on the list. I have exited the game twice but nothing.
I absolutely REFUSE to restart yet another game and play up to where I was, I've had to do this to many times recently and it just ruins the gaming experience. I play these games for enjoyment and to forget about the crazy day that I have had but it seems even my bad luck today followed me into this game. So now I am stuck....can't finish the game....what to do, what to do. I guess I'll wait to see if there is a fix. BOOO!

I forgot to add that I am playing on a Win8 using IE. All of my files are up to date which were checked earlier today.

I'm having the same problem and I'm in the process of uninstalling/reinstalling. Will let you know if that works.

ETA: As usual, that didn't work. This sucks! I got this game as a replacement for another game that didn't work!
 
 
I'm having the same problem with the stove pipe and the damp cloth. This sucks! BFG please fix this game.
 
 
 posted in Mysterium: Lake Bliss Collector's Edition on Jan 1, 14 6:35 PM
Add me to the "slowness of the game" group. I really wanted to buy this game, but it is so frustrating. Big Fish please address this!
 
 
 posted in Awakening: The Sunhook Spire Collector's Edition on Aug 22, 13 10:58 AM
I am trying to make Curse Begone. I was at the table earlier and when I clicked on the knife the ghost mushrooms chopped themselves up and they stayed in the inventory. Now that I am back with all the ingredients I cannot put the mushrooms nor the mermaids tears into the mixture. Whenever I move the mortar the chopped mushrooms appear behind it over and over. I cannot proceed until I get this done. I already tried uninstalling and reinstalling to no avail. I am running Windows 7.

Please help!
 
 
 posted in Hypnosis on Jul 2, 13 8:05 PM
I am playing on a PC. I'm in the police officer's subconscious at the vault where she tells me not to look. There is a phobia there, but I can't fight it or skip the fight. I can't even move. The fight/skip symbols are covering the hypnotist and the phobia. The only thing I can do is click on the hint button, which leads me to pick up the police cap, which I also can't do. Uninstalling and reinstalling did not help. Anyone else with this problem?
 
 
Ok, I rebooted the PC and was able to uninstall/reinstall. After reinstalling,the game worked perfectly.
 
 
I installed the demo and it says that my trial expired before I even played it. I tried to uninstall and reinstall, but it won't let me uninstall because it says it's already running and it isn't. Error code 346

EDIT: Closing and reopening the game manager gave me back the demo time, but the game still won't load. Gonna try uninstalling and reinstalling next.

EDIT: Still won't let me uninstall. What next?
 
 
 posted in PuppetShow: Lost Town Collector's Edition on Mar 31, 13 8:54 PM
I bought this game when it was new. I just replayed it and realized that I never played the bonus game. Under extras I have soundtracks, screensavers, concept art, and wallpapers, but no bonus game. Where is it?
 
 
 posted in Nightmare Adventures: The Turning Thorn on Jan 31, 13 10:27 PM
Uninstalling and reinstalling didn't work, but I got a new coupon code, so it's all good.


Hello bfgMonongahela, you must be a fellow Pittsburgher!
 
 
 posted in Nightmare Adventures: The Turning Thorn on Jan 30, 13 5:37 PM
My turn:

I don't know what chapter I'm in, but I opened the case and took the slides for the blood sample and they didn't go into my inventory. How in heck did this game get past the beta test stage?
 
 
 posted in The Gift on Dec 22, 12 3:48 PM
I can't even play the game! It says the trial expired before I got to play it.
 
 
 posted in Twilight School on Dec 20, 12 9:25 PM
Well, I'm stuck in Day 3. I gave Chris his ring and the portal opened and was sucking him in. I went back to the Vampire Hall and Chris was there waiting for his ring. The hint button doesn't work. I uninstalled and reinstalled and I'm still stuck!
 
 
 posted in Phenomenon: City of Cyan on Jul 26, 12 1:53 PM
Add me to the list of people who can't play the game. It wouldn't open at all for me and after uninstalling and reinstalling it said my trial was expired and I never even played it!
 
 
 posted in Grim Facade: Sinister Obsession Collector's Edition on Jul 8, 12 12:05 PM
Nevermind. After I turned on one of the other burners I was able to light a second match.
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator