Posts created by emery419

 
 
Playing on iPad 2. Everything was going along fine--no issues at all--but when handing the antidote recipe to the fisherman the game just quit. Tried several times but still won't work. The worst part of it is that you can't get a refund for these games.
 
 
 posted in The Agency of Anomalies: Mind Invasion on Jan 5, 14 4:00 PM
As with the CE, this version wouldn't open either. Have tried uninstalling and reinstalling with both versions, but no luck. I have played the other Agency of Anomalies with no problems, as well as other games. I would think that with all the problems on the CE of this game, the SE problems would have been fixed before releasing it. Is there a reason for the game not even opening?
 
 
 posted in Botanica: Earthbound Collector's Edition on Jan 4, 14 6:08 PM
I, too, could not find a bonus chapter. Just "extras" like screen savers and re-playing puzzles (which I don't like in the first place) and hidden object scenes, which are of no interest to me. Is there not a bonus chapter after the main game?
 
 
Will not even open for me. Running Mac OS 10.6.8 -- everything up to date. Too bad, too. I really like this series. Anybody else have this problem? I have uninstalled and reinstalled to no avail.
 
 
 posted in Dark Canvas: Blood and Stone on Nov 24, 13 7:42 PM
Solved my own problem with the kitten. Since I was so near the beginning, I just started over with a new profile and it worked this. Finished the rest of the demo with no further problems.
 
 
 posted in Dark Canvas: Blood and Stone on Nov 24, 13 5:54 PM
I've barely started -- after giving the kitten the milk, you are supposed to take the kitten. But no matter where I click or how often, I cannot take the kitten. No way to go further in the game.
 
 
As soon as I saw that skipping puzzles caused the hint to be disabled for several minutes, it was an automatic no-buy for me. Why must we be treated like children? I sometimes skip games in demos to save time; however, this time, I just could not figure out how to make the game work. And the instructions were useless. Just let us play the game without silly punishments, please.
 
 
 posted in Revived Legends: Road of the Kings Collector's Edition on Nov 6, 13 11:11 AM
I got the demo to play fine, and was rather liking the game, especially with a sale today. Then I had to exit to do something else and the game froze -- really froze. Even Force Quit wouldn't work, so I had to turn off the computer with the on/off button (which rarely happens) and restart. I am hesitant to purchase a game that freezes, and after reading the rest of the crash stories, I'm afraid this is a no purchase for me.
 
 
 posted in Stranded Dreamscapes: The Prisoner on Nov 5, 13 9:32 PM
I cannot find the last 2 purple crystals, and the hint system has stopped working for some reason. The walkthrough isn't much help because I have to use the iPad for that, and the picture won't load. All that work, and now I can't finish. Arggh!!
 
 
 posted in Abandoned: Chestnut Lodge Asylum on Sep 13, 13 10:03 PM
Oh, where should I start ... I started out thinking I would like the game; I sort of like creepy asylum games. Then the trouble started. The sound kept cutting in and out. The custom curser and regular cursor got separated to different parts of the screen when I clicked on another area. The lag between scenes was so long, I could have mixed myself a drink. Sometimes the Guide worked, and sometimes I couldn't access it. It is a nice feature for an SE if it works. Also, the HO scenes were very dark; I usually don't have trouble finding objects, even in darker scenes, but for some reason had trouble finding these. When I finally could take no more and clicked on "Menu" to quit, it just froze up and I had to force quit, which also took more time than a normal force quit usually takes. Mac OS 10.6.8. All software up to date.
 
 
 posted in Echoes of the Past: The Kingdom of Despair on Sep 11, 13 8:24 PM
I cannot play the game because it won't even open! This happened with the CE version, too. I thought maybe it would be fixed for the SE. I have really liked the series, but there's no way I can purchase something that won't even play. I'm using Mac OS 10.6.8. Uninstalling and reinstalling does not help; I tried 3 or 4 times with the CE. There must be other Mac gamers who don't even bother to report that a game doesn't work; I can't be the only one having this problem. Other games work fine on the same computer. Maybe if it ever comes out for iPad, I'll try that one.
 
 
Could not get the game to start, despite uninstalling and re-installing twice. Would not even open. Mac OS 10.6.8, so should work. All other games work; everything up to date. This has happened a few other times with other games, but no one was ever able to figure out the reason.
 
 
 posted in Haunted Legends: The Curse of Vox on Aug 1, 13 5:18 PM
I liked the game, but it was very very short -- only took me about 2 1/2 hours, which is hardly worth the money, even on sale. The ending was very abrupt, to the point of not being sure whether it was over or not. The beginning was much more interesting and fun, which is why I purchased it.
 
 
 posted in Fairway Solitaire on Jul 27, 13 8:58 PM
What is the meter made trophy? I don't have that one. Probably a different version, but I thought I'd check.
 
 
 posted in Fairway Solitaire on Jul 27, 13 7:22 AM
Same here. -8 and no stars. Second time this week on daily challenge. Wonder what's up with that?
 
 
 posted in Fairway Solitaire on Jul 24, 13 10:42 PM
How do we get the fix? There is no indication of an update on my iPad.
 
 
 posted in Fairway Solitaire on Jul 12, 13 3:04 PM
I accidentally clicked the "5 more cards" button and it took my $2000 without even asking me to verify that I wanted to purchase them, which I did not. It seems intentional so you'll run through your golf bucks faster and have to actually use real money. It really needs to be relocated.
 
 
 posted in Fairway Solitaire on Jun 30, 13 6:24 PM
I have come to the conclusion that it is mathematically impossible to complete Peppertree. I have almost $900,000 and a best score of -26, and that's still not good enough to advance. I've been on it for days. It's kind of weird, because I'm pretty sure I've been all the way through the game a couple years ago, so I must have gone past it, but I don't remember spending this much time on any course before. Arrggh!
 
 
 posted in Fairway Solitaire on Jun 30, 13 4:53 PM
I do not like the single-profile change, and would like it to change back to multiple profiles. I didn't have any problems with the game the old way. Now I am the only one who can play. I also like to play myself with more than one profile, using the old one for the daily challenges and a new one to start over, since I have completed the game but don't want to give up all the purchases I have made. Please change it back.
 
 
 posted in Grim Tales: The Legacy on May 24, 13 1:10 PM
I have also,had a black screen when returning through the maze from the fisherman's hit. Have quit and retried several times with the same result. There is no way I'm starting over -- it's a very long game and is getting tedious because it just doesn't work that we'll on the iPad. But I would like to finish the game. Why doesn't Bigfish fix these issues when more than one person reports something wrong? It's unlikely to be a hardware issue but more likely some sort of glitch in the game. I am hesitant to,purchase any more iPad games because it seems like I have similar problems frequently.
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator