Posts created by scuther

 
 
 posted in Bejeweled 3 on Jul 27, 13 8:11 PM
You probably have an answer by now but I think you are talking about 4 elements.It is a great game.
 
 
 posted in Royal Envoy on Jul 17, 13 9:05 PM
I am having the same problem, I have built the flower beds, the flower pots and been in and out of the game but it still doesn't recognize that I have the flower beds. Now what????
 
 
 posted in The Promised Land on Jun 14, 13 7:11 PM
I am also havint the same problem. I cannot figure how the rooms are supposed to go. I have four rooms done and when I try to move them around I lose the furniture which tells me it is the wrong way HELP PLEASE????
 
 
 posted in Farmscapes on May 28, 13 12:08 PM
I would love to play farmscapes but in the first scene I have to find a hat. All well and good but when the hint shows mme where it is, I cannot click on it. It is out of the picture. Would it be a resolution problem. Help please.
 
 
 posted in Barn Yarn on May 28, 13 12:04 PM
It's me scuther again. I meant farmscapes, not barn yarn. That goes to prove you shouldn't write for help at 2am. Sorry
 
 
 posted in Barn Yarn on May 28, 13 2:32 AM
I tried the game and liked it but...I can't pick the hat in the first scene. It is out of the viewing area. Any help here?? Resolution adjustment needed and how do I go about it?
 
 
 posted in Gardenscapes 2 on May 25, 13 9:35 PM
In order to wash the dishes you have to start with the bottle of soap which is on the lower left side of the picture. This game is a bit harder to find things.
 
 
 posted in Emerald Tale on Aug 21, 12 10:02 PM
Thank you blooming lilac for your help. I am still playing and the game is keeping my score as I go along. Fascinating, what fun.
 
 
 posted in Emerald Tale on Aug 21, 12 9:50 PM
The game tells me to use the artifacts but how??? I have three artifacts in the space provided for them but how do I get to sue them. Not very clear to me.
 
 
 posted in Emerald Tale on Aug 17, 12 9:25 AM
I have my little guy at the whirlpool and cannot it to accept him in. Nothing happens. What can I do ? I have gone in and out of the game thinking that would trigger it but no, it's not happening. This is my second time thrugh the game [shen I pretty much know what I am doing} The islands are starting to get more color and I wouldn't want tto lose the points I have got now 3357065. Any help out there??
 
 
 posted in Emerald Tale on Jul 23, 12 9:46 PM
sorry folks, this game has me repeating myself. Just bear with me.
 
 
 posted in Emerald Tale on Jul 23, 12 9:45 PM
I have now played this game through and where does it tell you that you heed 300 coins to get to another leel.Also one of the fishies said a little person told her to look to the sky. non of the little people have spoken to me as yet. It's almost like I am playing another game. The tutorial said to listen to the little people but so far no one has said anything. It's almost like I am playing a different game. I do like this game but obviously I am missing somethiing. Help out there someone. Thanks.
 
 
 posted in Heroes of Kalevala on Jun 12, 12 7:38 PM
I finished the game also and I didn't have still hands when I started but I sure did by the time I quit playing, Some people never learn. Lovely game.
 
 
 posted in Heroes of Kalevala on Jun 12, 12 7:33 PM
Found out on my own how to get to another village. I will have to learn to pay more attention. Have finished the game and quite enjoyed it. Not many instructions tho. Have fun.
 
 
 posted in Heroes of Kalevala on Jun 6, 12 1:38 AM
I must be missing something because I don't know how to get another village up and going. I can't see how you get a settler from one village to another. Help anyoneÉÉ
 
 
 posted in Jewels of the East India Company on Jun 4, 12 9:43 PM
Doesn't anybodt edit these remarks. That's a lot of repeats.
 
 
 posted in Caribbean Hideaway on Mar 17, 12 10:09 PM
I was up to chapter 45 and all of a sudden there it was, gone and I am back to the beginning of the game. I like the game but it was hard work to get that far and then to have it gone. I wonder what happened? Any clues anyone. I realize I might not get an answer as it is a fairly old game and maybe noone is checking this forum.Hope someone can clear this up.
 
 
 posted in Caribbean Hideaway on Mar 10, 12 2:56 PM
I am not sure if chapter 30 is level 30 or not. All I know for sure is that I cannot beat it. This is after about 35 tries. I am stubborn enough to keep at it because it is a real good game. Even if I never get past this level. Any clues. I have the pirate, shark and story to clear.As soon as I use the bomb I get failure???
 
 
 posted in Caribbean Hideaway on Mar 10, 12 2:50 PM
I have a problem with chapter 30 [level?] I have tried many times and no go. I always fail.
Any clues?
 
 
 posted in 7 Gates: The Path to Zamolxes on Mar 6, 12 12:20 PM
Looks like a real interesting game and another one that I will be unable to play because it takes 1024mg of ram. Shucks.
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator