Posts created by ladybaskets

I also cannot get the ankh. I also have the symbols in my book, but cannot get the little silver balls to move on the box. Keeps telling me I need the symbols in my book. I have uninstalled and reinstalled and do not lose my progress but can't go any further. This game was sometimes very difficult to play as several mini-games did not work correctly. Would like to finish this game, but your silence is not helping. Have you figured anything out yet?
I have the correct symbols in my diary; but the 3 silver balls won't move on the box to change the symbols. I guess that's because the game doesn't think I have the right symbols, but I do. Uninstalled, re-installed, still no luck. I waded thru this game with all its little problems but would like to finish. I have the 2 flasks and still the matches, but not the ankh. Help!
 posted in Awakening: The Skyward Castle Collector's Edition on Mar 6, 13 9:08 AM
So how do you get the round medallion at the top right of the imaginarium to rotate so the opening is at the bottom; so that you can place the blue medallion inside it? I hav everything else in place. Have kept trying to insert this in order but does not work. Help please.
 posted in Awakening: The Skyward Castle on Mar 6, 13 8:56 AM
I am having problems with the cursor flashing so much you can't see where it is going. I have uninstalled and re-installed several times. The cursor is fine with all the beginning to the game; but once I click on play it starts to flash. thanks for your help
 posted in Mystery Case Files ®: 13th Skull ™ on Mar 11, 11 12:44 PM
I have all 4 keys and know which key goes in what lock hole. However, I cannot get the keys to stay in the holes They just keep returning to my inventory with a message to try something else. I have tried every combination of placing I can think of. Help, please?
 posted in Artifacts of the Past: Ancient Mysteries on Jul 28, 10 8:06 PM
Same thing 3/4 way thru 3rd story and error message. that sucks; finally thought there were going to be some interesting puzzles.
 posted in Artifacts of the Past: Ancient Mysteries on Jul 25, 10 10:11 AM
Look at the bottom right square for a clue for the arrows.
 posted in Safecracker on Apr 17, 10 5:26 PM
every time I try to go back to the game I was playing, nothing happens. I select my key and click on load game but the screen just sits there. Its hard enough getting safes done without having to go back and start all over each time! thanks.
Go to:   
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator