Posts created by VelvetRose55

 
 
 posted in Bridge to Another World: Burnt Dreams on Jul 31, 16 3:56 PM
Bummer. I just reviewed the wrong game. How do I delete it?
 
 
 posted in Facility 47 on May 31, 16 7:14 AM
After playing the game I wondered about the fact that the bacterium cures rats but kills people. Since it is a cancer killing virus, is the conclusion that humans are a cancer? In listening to the final radio broadcast, it seems the virus hasn't decimated the animal population. At least animal deaths were not mentioned.

Is this a moral statement about humans, or a medical one? Does the conclusion mean human cells are inherently cancerous?

Just something I thought was interesting.
 
 
 posted in Facility 47 on May 31, 16 6:57 AM
Nope. No fancy game pointer. No grasping hands or sparkling arrows. It's okay though. LOVED this game.
 
 
 posted in Facility 47 on May 31, 16 6:55 AM
Did you see the body floating in the ice pool?

Like you, after playing the game twice I still had that dart.
 
 
 posted in Facility 47 on May 31, 16 6:50 AM
This IS a great thread. I think someone mentioned MYST. I still have all the disks for that one, and have played the online game, MYST URU. Big Fish should certainly incorporate more games like Facility 47. Are you listening, Big Fish?
 
 
 posted in Facility 47 on May 29, 16 8:20 AM
I finished the game without playing Arctic Escape. I tried but I kept getting error messages so I gave it up. It didn't understand anything I typed.
 
 
 posted in Facility 47 on May 29, 16 8:11 AM
Yes you can. Go to "options." You can restart from there.
 
 
 posted in Facility 47 on May 29, 16 8:06 AM
I LOVED this game. I also loved the Syberia series. The only other game I have seen like this one is a very old game titled Rhiannon.

I just saw one titled Lifeline: Whiteout. I don't know much about it. It's an app for iPhones I think.
 
 
 posted in Dark Alleys: Penumbra Motel on Aug 6, 13 8:28 AM
Did anyone else notice that the figure seated in the chair in front of the camera changes in the zoom in? When you enter the room in the house go past the dead guy. There is another room with three chairs. In the middle one a figure sits wearing a vest and a helmet. When you zoom in on the camera he is replaced by a naked figure without a head.

I know there is often a difference in the appearance of items in zoom in's but this one is the funniest I've seen.
 
 
 posted in Dark Parables: The Exiled Prince on May 29, 12 9:39 PM
That helps. I was looking for them when I first entered the scene. I was just looking for them to find them, not to make the recharger faster. Thanks. Now I can go back and see what I missed.
 
 
 posted in Dark Parables: The Exiled Prince on May 29, 12 4:57 PM
Anyone else having trouble finding the phantom objects? I forget what they call them in this game. They are the object that keep transforming back and forth. I have only found four out of twenty. I look at each scene carefully for a long time waiting for something to change but in most of the scenes so far I see nothing.
 
 
 posted in Haunted Legends: The Queen of Spades on Feb 16, 12 9:32 AM
donrus wrote:I can't find two wheels to put on the carriage in the barn. There is only one wheel which I repair with pitch and spokes. The game keeps reminding me that the carriage needs four wheels. There is an unresponsive broken wheel in the barn and there us a "graveyard for wagon wheels" by the well, but I can't pick up another wheel. This means I can't move the carriage, can't climb to the top, can't....game over.

Has anyone solved this problem? The walkthroughs say "Take the wheel" and then "Put the 2 wheels on the carriage." WHAT TWO WHEELS?


Same here. There is only one wheel.
 
 
 posted in Mystery Legends: The Phantom of the Opera on Dec 25, 11 3:37 PM
I just finished this game and was very disappointed. Actually I'm angry. The game itself was good...until I got to the so called end. The game stopped three fourths the way through. That should never be done. A game should have a conclusion no matter which edition you buy.
 
 
 posted in Drawn™: Trail of Shadows on Nov 30, 11 3:28 PM
Ghanie39 wrote:
vingilot wrote:There's an achievement in the CE for collecting all the pigs. There are no achievements in the SE, so I imagine they simply forgot to remove the pigs.


Well, that's not fun!


That explains it. I also wondered about the pigs. It seems to be a joke. They made it into a real HOG game.

Yuk Yuk.
 
 
 posted in Drawn™: Trail of Shadows on Nov 30, 11 3:24 PM
I loved the first two Drawn games.

Even though this was a prequel I still think it should have been more intense, longer and had the same emotional feel as the previous two.

I as disappointed in this one. It seemed that the creators knew we were waiting for it so they rushed the game. The story is shallow.

I felt insulted when they charged twice as much for a game not even half as long as the others. It takes forever to load, stalls and can't seem to keep up with itself as the graphics sometimes blink out and there is sometimes lag time between a click and an action.

The second game gave a hint that the story was not over. So there may still be another game.

As for the Trail of Shadows, it seems to be an interval to keep us busy until the "real" game comes along.

Boo Hisss.
 
 
 posted in Drawn™: Trail of Shadows on Nov 27, 11 8:58 AM
Very slow to load, if it loads at all. A couple of times the game just stopped loading. The pirate just sat in his ship in the middle of the ocean. The puzzles and new scenes are slow to load also. Sometimes there is a delay when clicking on an object. You click and have to wait for something to happen.
 
 
 posted in Hanging Gardens of Babylon on Oct 8, 11 4:07 PM
When I got to the first room to look for the hidden objects I was told to find a necklace. I saw four. But when I clicked on any of them I got points deducted.
 
 
 posted in Lost in the City on Oct 6, 11 9:15 PM
This was a fun albeit convoluted game. It seemed to be written by a committee. Ever play those writing games when each person writes one chapter of a story? That's what this seems to be. But that made it interesting.

You have to have sharp eyes to find some of the tiny or hidden pieces. If you exit the game in the middle of a chapter you have to start over again. No too big a deal.

If you like dark atmospheric games (I do) you will like this.
 
 
 posted in The Flying Dutchman - In The Ghost Prison on Sep 19, 11 5:51 PM
I bought this game a couple of weeks ago and am enjoying it. But it is buggy. After playing for 20 minutes or so it will either freeze, give me an error message or shut itself off. The problem gets worse in the treasure finding part of the game.
 
 
This game causes my computer to reboot.

Won't be buying this one.
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator