Posts created by zephyr369

 
 
 posted in Roads of Rome: New Generation 2 on Nov 22, 17 4:11 AM
Downloaded the demo and the upper and lower portions of the screen keep blinking. Looking at this thread, maybe I shouldn't buy the full version. Which is unfortunate because I have all the Roads to Rome games.
 
 
 posted in Wanderland on Aug 31, 17 4:58 AM
Just a followup from my earlier posting back in section 60, wherein I described an issue with no longer being able to send ships after being upgraded a level in the sending ships dept. - clicking on them does nothing.

The suggestion to run as administrator was tried but did not solve the problem.

The suggestion to contact tech support was tried, but they have not replied with any information related to the problem. Somehow some spam-ish looking message from them regarding an unrelated game did show up, but I answered that to indicate they didn't read my posting, nor the game title. Nothing to follow that from them at this point.

I am not expecting much in the way of a resolution.
 
 
 posted in Wanderland on Aug 18, 17 2:05 PM
I advanced to the Frigate level with the ship sending and immediately lost all ability to send ships any longer. I can click all day on the sparkling ship but nothing happens. I can summon it as well, but still no go when it comes to trying to interact with the ship.

Just following up: The Run as Administrator suggestion did not solve the problem. I guess I will have to try to get the other folks to fix the game. Can't get treasure chests if I can't send ships.
 
 
 posted in Maggie's Movies: Camera, Action! on Jun 13, 17 3:30 AM
Level 13 - Midway through the level Maggie gets stuck at the ticket booth and she won't go anywhere no matter what I click on.
 
 
 posted in Weather Lord: Royal Holidays on Feb 4, 17 3:19 PM
How do you build up the gold star? Mining gold doesn't add to it.
 
 
I took it exactly the same way as Donnacal. IMO the instructions on this level were misleading.
 
 
 posted in Elven Legend 3: The New Menace on Sep 5, 16 6:17 AM
Was about to buy this and then saw the glitches reported in the forums. Will wait when developers fix this.
 
 
 posted in Moai IV: Terra Incognita Collector's Edition on Jul 31, 16 6:43 AM
Totally agree with Penny1942. I've bought all games of the Moai series, and the hints/dialogs are really getting annoying. In some cases they pop up mid-game when you're busy trying to get things done, makes me want to scream at the screen for them to shut up.
 
 
 posted in Roads of Rome: New Generation on Apr 3, 16 6:33 AM
Love Roads of Rome. I have all the games. That said, I agree with most of the posters about queuing. It's time, developers! Have I said you need queueing? Yes, just making sure you heard it!

Also, please get rid of the extra screen where you have to click to start. That page is totally useless and annoying.
 
 
 posted in Incredible Dracula: Chasing Love on Jan 5, 16 3:41 AM
Nice game but very difficult. Best I could do was to get one-third of the levels in gold stars. Pretty much given up on the rest.
 
 
Love this game but the slow/tired Emily bonus level is absolutely annoying. It's the only level left where I can't get the diamond. I need to stop from time to time because I lose my temper with it.
 
 
 posted in Delicious: Emily's Wonder Wedding on Jun 4, 15 5:39 PM
Some of the challenges are very difficult. But my biggest complaint is that the credits are tied to the last level of the last episode. It is EXTREMELY ANNOYING to have to be forced to go through the credits when all you want to do is to replay the level. So I just gave up.
 
 
 posted in Chicken Invaders 5: Cluck of the Dark Side on Jan 15, 15 3:44 AM
You don't always start from level one. You restart from the first level of the last star system you visited. So if you finish levels 1 - 10 you get to visit the next star system. When you lose all your lives there, you restart from level 11.

Great game but here's my BUT - it is extremely difficult even at rookie level. Gets kinda wearying after you've replayed that star system umpteen times. Takes away the enjoyment of playing. I've been stuck on the third star system for several days now. Don't know if I will have the patience to finish this game. :-(
 
 
 posted in Awakening Kingdoms on Jul 23, 14 5:01 PM
sashaofvashon wrote:The latest update took care of some glitches, but not all. I am on level 71, have 153,00 points and it's still telling me I need 488,880 points to level up. At this rate, I'll never get to level 75 to collect my achievement award. Maybe that's their strategy!


Same issue remains here only on a larger scale...

Before the previous upgrade messed it up I only needed about 180,000 to get from level 89 to 90. But the last revision jumped that up to needing 2,119,270.

For the time between then and now I've only managed to get up to 591,000. It is doubtful level 100 will ever be reached in my lifetime the way the level requirements seem to grow exponentially. I doubt interest in this will last long enough anyways.
 
 
 posted in Viking Saga: Epic Adventure on Jul 12, 14 4:38 AM
I like this game and enjoyed Normal mode. Just a couple of comments. For the Hard level, is it my imagination but advanced clicking is not allowed? It's kind of annoying to have to wait for enough workers to be back in the main home to be able to line up tasks for them.

Also, the clock kicks off immediately. A "Click to Start" would be great so there's a chance to examine the terrain and plan out the play.
 
 
 posted in Awakening Kingdoms on Jul 10, 14 6:26 PM
New Glitch seems to have come up since the latest update, unless something has changed without explanation...

Despite having completed another week of play, the game failed to award the usual Bundle prize. I didn't notice any other award either.
 
 
 posted in Awakening Kingdoms on Jul 1, 14 5:37 PM
I guess this is just to bolster the problem reported elsewhere already regarding the need to acquire 15 mini Centaurs to give for the Byrnwigend Battle mural. I think the last two butto items in that quest are somehow switched.

When I clicked the third item in the list of things to collect (20 Lone Centaur Books) to try to give them I was told I need to find more items despite having 20 in hand. But I found that when I clicked the second item for the 15 Mini Centaurs, which I do not have yet, the Books got accepted instead and their button turned into a checkmark (not the button I was clicking).

Now if I click the second button nothing happens, and the button that probably would process the mini Centaurs that sat next to the books is gone and replaced with the checkmark.
 
 
 posted in Awakening Kingdoms on Jul 1, 14 1:16 PM
I just noticed another problem with the latest version.

The total points required now says I need 2,119,270 points to get to level 90, whereas I only needed maybe around 180,000 before the version update.

I don't think I will be wasting time trying to get there.
 
 
 posted in Awakening Kingdoms on Jul 1, 14 7:21 AM
The latest release which includes the Stone Circle has a troublesome flaw (assuming it is not intentional) that wastes expensive energy. Half the time (or more) it presents and awards objects from the Gnome Village instead of the objects it should be offering. You can even see them in the Items To Find before entering that area when you select it on the map.
 
 
 posted in Royal Envoy 3 Collector's Edition on Jun 8, 14 3:40 AM
Is there going to be a standard edition release?
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator