Posts created by gntpat

From the beginning I have needed to double click on EVERYTHING. My finger is tired. Double click on strategy guide, forward, down, imp, hop, open, close.
 posted in Portal of Evil: Stolen Runes Collector's Edition on Feb 10, 15 1:19 PM
I've adjusted the mirrors many times and can not get the skull to light up. I've clicked SKIP with no help. I need the 9th skull. I have the 10th, but cannot place the skulls without all of them
 posted in European Mystery: The Face of Envy Collector's Edition on Jan 4, 15 12:02 PM
cannot place crystal in light.
The oil can is NOT by the crane like it supposed to be. Clicking on that area fogs the scene and I have to click menu then go back.
 posted in True Fear: Forsaken Souls Collector's Edition on Mar 2, 14 1:50 PM
Directions say to set clock hands at 6:43 -or thereabouts. I cannot make the clock hands move to set them.
I've run out of time. Played only the trial and wont purchase until I know how to set clock hands. I did find other clock hands through binoculars, but dont know if it's the right time.
 posted in Haunted Legends: The Curse of Vox Collector's Edition on Feb 12, 14 2:25 PM
How do I break the chains? I've entered the symbols, but cant break the chains to free the horse and carriage.
I'm on the balcony too. I've slowly moved the bow and arrow around, but no target appears. The game depends on getting the bread from the HOS. I cant go forward

NOW!!!! I let a day pass then went back. This time I saw a bow in the lower right and clicked on it. This time a target appeared.[/size] I had to pay attention to the red ball, but after three tries I hit it and could continue with the game. My hour try was up and I probably wont buy the game.
 posted in The Magician's Handbook II: BlackLore on Feb 21, 13 10:39 PM
I am stuck at the title page and cant play, because there is no cursor. I've heard that this is a great game, but I cant play it.
 posted in Surface: The Soaring City Collector's Edition on Jan 25, 13 9:50 AM
In the very first HO game, I cannot find the flower to put in the vase. Hint tells me to put the flower in the vase. The vase tells me it needs a flower.

Cannot locate flower for vase.
How do I uncurl the gecko tails?
 posted in Jewel Quest Solitaire 3 on Dec 30, 11 10:32 PM
I've used scores, and other number combinations to unlock the safe, but none work.
What is a clue to the 3 digit number to unlock the safe?

 posted in Eternal Night: Realm of Souls on Oct 23, 11 10:51 AM
I am at the beginning and am asked to choose a new player. I click that button, because my name is not mentioned as player. Nothing happens after clicking that button. Therefore, I cannot begin the game.
I'm playing on a Mac with profiles to run Windows.
Other games run smoothly.
 posted in Hidden Expedition: Amazon ™ on Oct 9, 11 5:07 PM
This game has one of the best soundtracks. It didn't really fit the Amazon, but it kept me going all the way to the last game.

It was a game I hated to see end. I could have kept going for new adventures.

Pat (gntpat)
This game has the potential of being a good game. I've tried the "preview" twice and both times it dropped the game after 5 mins. I restarted and found myself back at the beginning every time. I've never gotten beyond the walk in the streets. I'd love to see the rest of the game, but an not willing to purchase. Off I go to uninstall.
 posted in Murder Island: Secret of Tantalus on Feb 12, 11 2:12 PM
I cant find any **** in the North Terrace game. I click on things, but they aren't leaving.
 posted in Murder Island: Secret of Tantalus on Feb 12, 11 2:11 PM
mcurty wrote:
simtique wrote:i am completely stuck got the torch got the matches no lighter fuel in the walkthrough your supposed to get them all at the same time in the h o scene but i didnt get the lighter fuel i started playing again but same thing can anyone help i am stuck

The lighter fluid is in an H0 at the North Terrace Gate. Have you tried that? Each of these 3 items is found in a different H0 scene.
 posted in Eternal Night: Realm of Souls on Jan 18, 11 2:50 PM
My free game play was taken up with the extremelly slow loading. Too many pop up hints, but hints that also took up too much time. I think I got an actual 10 minutes of play time.
 posted in Eternal Night: Realm of Souls on Jan 18, 11 2:46 PM
Lucy_Q wrote:My game took FOREVER to load. I've used up 39 of my free minutes and only got through the first screen puzzle to Anubis' chamber.

Is it just me?
 posted in Curse of the Ghost Ship on Dec 29, 10 12:20 PM
ONLY black screen and sound track like others have posted. I wont purchase until I've had a full 60 minute trial. I'm now down to 45 minutes of nothing.

I got the skulls from the first cannon with no trouble, went on to the next cannon to find my numbers were wrong. By trial and error, I found numbers i,2,3, and 4, but could not get 5, no matter what combination I clicked. Tried the cannon where I took the inflated boat and none of the numbers worked, not even by trial and error. The game has been the most difficult so far, but also much fun. I depend on the walk through often, because get myself in a place and dont know what to do next.
Please, someone, tell me how to get the correct numbers to enter into the cannons so I can have the 2nd and 3rd sets of skulls.
Go to:   
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator