Posts created by saphhire

 
 
the bolt is on the right hand side of the wheel place the wheel 1st though or u won't be able to pick it up again
 
 
Merryweather wrote:I am absolutely STUCK. I have played through to starting the boiler to open the door 3 times and I cannot go further. The hint and help keep telling me that I must connect the wheel, which I thought I did. In the strategy guide it says to use the bolt. I don't have one, cannot locate one and feel like I must be blind.

Other than the above problem, this has been another hit for BFGames.
 
 
I finished the game it's a very good game but I can't play the bonus either it keeps going into a new game I tried everything. help please
 
 
bpurdum2 wrote:
tillybaby wrote:I am having a real problem trying to use items that are in my inventory. The hand icon comes on but then I have to try numerous times to get the things to actually work, it is very frustrating and spoils the whole flow of the game play. At the moment I have to assemble the boiler and must say I have given up because I've been trying for over ten minutes to pick up an item to fix the thing

I am having the same problem. I just started the game and at the gate with the dog. Found the ball but cannot pick up the razor to use. The rope and stick will not combine. I guess I cannot go any into the game. I was going to buy this game but am not happy that I cannot access the strategy guide for help and that it is hard to pick up items with the hand.
 
 
 posted in The Heritage on May 25, 10 10:39 PM
debxania wrote:Hey wager371... How did you get past the locket?
I'm having the same problem can't get passed the locket.
 
 
 posted in The White House on Jan 12, 10 9:22 PM
I just downloaded the game and I'm having the same problem with the cursor. Can't even start the game to see if I like it. My cursor only moves in a small square. Uninstalled and reinstalled the game still no fix.
 
 
I bought this game so sorry I did finished it in 3 hrs Short extra finished that in 5 min no extra game puzzles to play It's a dud big fish wish I waited for the 6.99 version bet not much shorter. DUD DUD DUD Loved all the other games this one is good but not for 19.99 not worth it
 
 
 posted in Adventures of Robinson Crusoe on Feb 1, 09 11:34 AM
the nut is hanging from the tree behind the skeleton just swing the skeleton and it above where his head is
 
 
 posted in Adventures of Robinson Crusoe on Feb 1, 09 11:32 AM
lordkalvan wrote:I haven't gotten that far yet. (honey)

I'm stuck in the swamp, trying to get the last nut. The hint gives me the hat on the skeleton, which I assume means swing the skeleton (which I'm not finding easy to do - although I did get the mushroom). Anybody else found the nut that it's hiding near or behind the skeleton, so I know where to look?
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator