Posts created by s_jjones

 
 
 posted in Rescue Quest Gold on Jan 18, 18 5:36 AM
When this game first was released, I didn't give a very good review. Once I learned exactly how to use the power-ups, started loving the game. I play just about every day, have created and deleted many players names. My only problem now is that none of the achievements ever 'stick', meaning somewhere during game play they all disappear and start over again. Not a deal breaker, just an FYI
 
 
 posted in Rescue Quest Gold on Sep 20, 17 8:17 AM
I have found a French player who has published YouTube videos of all levels - a great help. Just google 'YouTube Rescue Quest Gold Walkthrough'

I learned so much from this player, and I hope this is OK to post. Hope it helps you as much as it has helped me.
 
 
 posted in Rescue Quest Gold on Aug 28, 17 4:35 AM
I've been stuck on Level 77 for almost all of Harvey - what a mess on both counts. I can't kill the slime balls, no matter what I do..I try to only select green and red moves to fill up the hammer and sword, I've sent arrows directly at/on them, but can't get all six within the limited moves. I'd appreciate any suggestions. Thanks

8/30 Update: I feel so dumb...just passed level 77. The trick? To kill two slime balls at a time make sure they get on top of each other, then use sword and arrows, will get both.
 
 
 posted in Solitaire Chronicles: Wild Guns on Jun 28, 17 7:08 AM
When I finished Level 80, I got the panorama of the entire town but no ability to quit, no buttons, and after several minutes did the CAD to end the game. I came to the forum to see if any others had the same issue, and found out in fact there were two more chapters to complete the game.

I then decided to replay those games with only 1 or 2 stars; Chap. 3 worked fine and I got 3 stars on all those games. Chap. 4 no matter how many times I replayed the original status of stars would not change, so can't achieve 3 stars in Chap. 4 All other chapters that I replayed recorded the 3 star change.

So I'm finishing Chap. 9 and 10 without any problems. Other than what has already been posted, if any new developments for getting the stars to reflect 3 correctly, let me know. Thanks.
 
 
Recent updated Win 10 64 bit. Worked before the update, just bought it today. Had the same issue where it would not open. Read the screen resolution suggestion, did that and it worked. Thanks so much for this forum, the help and suggestions, BFG.

I have been a Game Club member forever it seems. While once in a blue moon I've had a problem with a game, BFG has ALWAYS come through, either with a refund or a game credit or both. Yes it's frustrating when a game doesn't work, but BFG has always been good to me. Thank you BFG, keep up the good work!
 
 
This has been (and I'm not finished playing yet) one of the most fun games I've played in a few months. I even went 'off' HO games for a long time because there didn't seem to be anything new or interesting, just the same-o same-o. I like the maze feature, and am happy to see it in the Extras. Thanks! A great game to start off the New Year - hooray for 2017!
 
 
 posted in Jewel Quest: Seven Seas on Dec 9, 16 5:30 AM
My score after finishing 120 in first mode: 4,449,200
 
 
 posted in Jewel Quest: Seven Seas on Dec 2, 16 4:26 PM
That's a very good tip LynneWhitley, unfortunately in the level I'm playing now (clear board before running out of gems) it's very rare to get 5 in a row and a 4 in a row. Once I read your tip, I did accomplish that, but can't seem to get past level 45 just yet. Keep the tips coming!!!

UPDATE: I guess I got confused by the accumulation of 1 to 3 stars for a game and thought that had something to do with the cold coins. Still unsure what the stars are for, and the random scoring (70,000 plus points got 1 star, 11,000 points got 3?). The gold coins in the game can be matched or shot for extra moves, and once I got on to that have progressed well into the game. Keep playing, several different playing modes, my fun factor for this game is improving.
 
 
 posted in Jewel Quest: Seven Seas on Dec 2, 16 10:09 AM
It took me two days to pass 28 (boy did I get tired of that type of game, lol). Much to my surprise, the next two types of games are a whole lot more fun, some seem to be impossible, but as of today I'm at level 45, and stuck. But like everyone else, frustrated that this a totally NO FRILLS game. No skip feature, or ability to change the type of game to one that may enable moving forward in the game. While there may not be 'hundreds' of levels, by the time you play the same one for hours it seems like a million. Cannot turn off the tutorial to get rid of being reminded and reminded of what to do (turning off the tutorial didn't seem to do anything). For the most part, am playing but occasionally think: ****/BoomZap, this is a crummy holiday present.
 
 
 posted in Jewel Quest: Seven Seas on Nov 30, 16 5:10 PM
how does this work, how many do\ you need to get anything
 
 
 posted in Doodle God Fantasy World of Magic on Sep 6, 16 3:22 AM
[Removed by Moderator]
 
 
 posted in The Disappearing Runestones on Aug 2, 16 11:03 AM
I redeemed a free game award and bought this game on Monday. I had previously played the entire demo without any problems. I turn off sound and music (think someone mentioned they did too and didn't encounter all the aforementioned issues). Yesterday, think I was on level 3 and needed to complete the match card game. I started to play, and all of a sudden I clicked on a card and it was frozen in front and could not be used or disappeared. I was able to logically end the game, re-opened and tried again and had the same issue. So I switched to the Equals 14 game and completed that series, went back to the match card game and was able to successfully complete the level. I have been playing for a few hours today without any problems at all - really enjoying the game. However I totally agree that the white explosion when you make a match is so annoying, lol. I'm using HP with Win 10 Pro and 64 bit.

I'm sorry for all of you who are having problems, but you may think about trying to turn off sound and music and see if that helps. Happy gaming!
 
 
 posted in Silver Tale on May 11, 16 10:49 AM
I too have become addicted to this game to such an extent that I have 6 90 min HO games I just can't get to, lol! I decided to replay to try for more medallions, am trying to get as many power ups as I possibly can once I see what the level requires. My strategy is to play all the levels that have gold chests that I don't have the medallion, getting as much resources as possible to buy power ups. I'm down to 16 of those, then 30 levels with no chests. I have a gazillion Phoenix feathers, some of which I wish I could convert to gold, but minor detail. I luckily have not encountered any 'glitches', however on one level I couldn't get the 4th piece to go through the tunnel, turns out I needed a machete to go to the next room, which then opened up the spaces under the debris on the previous room. Since I always like to finish a room before moving to the next one, this stymied me a bit, but now just move from room to room trying to clear them to get that medallion! Great game, thanks to all of you for commenting!
 
 
 posted in Silver Tale on Apr 13, 16 10:51 AM
kdubs you are AWESOME! Thanks so much for the tip on the Help feature. I too have been bombing out on the veins, can't wait now to see how that's supposed to work. I have been enjoying the game very much! This tip will really help! Bless You!
 
 
 posted in Silver Tale on Apr 12, 16 2:28 PM
It would be a great asset to this game to have a built in Help feature. For instance, if you clear the entire board and don't find the mining vein, how do you find it? Is it a series of plays that you need to do? Like 5 of the same matches in a row? If all the board is cleared how can you find anything else?

I like the game, but just getting frustrated with how it is played with little to no instructions.
 
 
 posted in The Lost Tomb on Mar 14, 16 3:18 AM
I had hoped to like this game but it is so flawed. None of the settings are retained upon exiting the game (sound comes back on loud, etc.) When it says 'click anywhere to continue' that really doesn't work - you actually have to click on those words. The fact that the instructions are incessant is so annoying. The guide book, which is needed to complete the mini-games always returns to the first page, however the mini-games are probably the most fun part of this game. Not a 'buy' for me.
 
 
 posted in Antique Shop: Lost Gems Egypt on Mar 6, 16 9:52 AM
For as many hours as I have played this game, that 'no moves/no power ups' has come up consistently, and I too have set up moves just to see that message. I love this game, despite it being fraught with bugs, most have been fixed, just not this one. In one of my profiles I have 3 stars on every level except one game in Cairo, but still cannot obtain the various achievements, even though I know I made numerous matches of the same color many times. But oh well, like I said, I've enjoyed hours playing - thanks for a great game.
 
 
 posted in Antique Shop: Lost Gems Egypt on Jan 16, 16 5:40 AM
Me too, markb
 
 
 posted in Antique Shop: Lost Gems Egypt on Jan 15, 16 5:26 AM
Bummer to read these: lost all my tools also and it's sure not fun. Windows 10, all updates installed.
 
 
When I got to the scene where I was supposed to go 'down' to heat up the cup of cold tea, the map would not work, nor would the down arrow. I exited the game, then reopened and things started working again so I could complete the demo....don't think I'll be buying another game that appears to have glitches. Sorry Eipix, normally an excellent developer.
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator