Posts created by helpqueen

 
 
 posted in Moai V: New Generation on Jan 26, 18 5:52 AM
First of all I play untimed. I saw other posts so went in and played timed. Still no arrow. Do I have to go back and play another level again?
 
 
 posted in Moai V: New Generation on Jan 25, 18 2:00 PM
What is this fire sign and where do I find it?
 
 
Are you able to play in windowed mode if you purchase the game. Anyone else having trouble with windowed mode?
 
 
 posted in The Trials of Olympus III: King of the World on May 11, 17 12:34 PM
Same problem with suns and bombs. I've deleted the game and reinstalled. Still not working.
 
 
 posted in The Trials of Olympus II: Wrath of the Gods on Dec 6, 16 6:25 AM
I've been playing this game for some time but today I move the pieces and they just sit there, no matches. I've even moved the pieces the game tells me to and again they just sit there - no matches. I have restarted the game a number of times, changed users, deleted all other profiles and finally uninstalled and game and reinstalled it. What's going on?
 
 
 posted in Clutter VI: Leigh's Story on Nov 9, 16 5:17 AM
How do you get back to the bonus games that come after the story? I was there yesterday but can't get there today.
 
 
 posted in Avalon Legends Solitaire 2 on May 7, 15 5:30 AM
I'm on level 40 and have tried clicking on the food and wood icons. Nothing happens. What screen should I be in to purchase? This is very frustrating. I'm ready to delete the game - and I bought it!
 
 
 posted in Runaway With The Circus on Feb 15, 13 6:01 AM
Where is the second heart? There's one on the dress hanging on the wall but I cannot find the second one.
 
 
 posted in Wings of Horus on Oct 19, 12 10:43 AM
Cannot run this game. It appears to open but the screen goes away. It shows up in my tray but when I click on it nothing happens. I've uninstalled and reinstalled three times. I give up.
 
 
 posted in Jane Lucky on Feb 24, 12 5:24 AM
I'm trying to repair the well and cannot pick up the pipe piece lying toward the bottom of the screen right in the middle. The hint will highlight the piece but I still can't pick it up. I've tried in both full screen and not full screen and I've also tried restarting. I can't go any further.
 
 
 posted in Golden Trails: The New Western Rush on Oct 1, 10 4:13 PM
Does anyone know why I can't run this game on my netbook?
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator