Posts created by newconcept

 
 
 posted in Syberia II on Apr 6, 14 6:33 AM
I just played Syberia 3 and I want my money back..This is the exact short version of the 1 & 2 games....Nothing is different..I was looking forward to Syberia 3 for yrs. and they do this.....Is this a joke? Why would a gaming company put out a game 3 that is just a collection of situations that happenened in the first 2.....It starts at at the University exit showing the train leaving and driving by the sticks the guard thought all those yrs. was a enemy until he got his glasses back. and get worse from there...No changes . nothing new. Big Fish, I want my credit back. Stop calling this "Syberia 3" newconcept
 
 
 posted in Journey to the Center of the Earth on Mar 13, 11 6:01 PM
This is the 1st game I almost exclusively had to use the walkthrough..If you try to play without it, forget it..You will be walking in circles..She has so many things to do at each station to put the puzzel together for that station, it could never be done without it....The game was fun following the walkthrough most of the time, just to see the outcome...Sorry to say, but if you are not a walkthrough person, stay away.
 
 
 posted in Journey to the Center of the Earth on Mar 10, 11 7:28 AM
you have to go back to the fort, heat up the bone with the lighter then put the bone with the conch..then go over to the horn add the wind pump(you should have taken it from the cave) cick on the horn and the bird will come.....good luck, this is an xtremely hard game...find a walkthrough
 
 
 posted in Mystery Case Files ®: 13th Skull ™ on Feb 19, 11 6:31 AM
cant deliver the gumbo?
 
 
 posted in Syberia on Oct 26, 10 5:40 AM
I do have a wide screen monitor that is set at something like 1366 resolution. I tried to change it, but any I use still dont work. My 1366 says(recomended) next to it.I think I have to loose my money and find a new game. this is the fiest time this has happened, but this is the first time I used a "large file" game.....
 
 
 posted in Syberia on Oct 25, 10 5:18 AM
Thanks, but I run curser along bottom clicking as I go and nothing happens. I cant see the curser...My screen is not big enough to show the bottom and sides. I have to figure out if there is a way to downsize my screen....Does anyone know if I can do that on this game? Thanks for the help. As a matter of fact, if I click on the table with the gear markings, I cant get out of that sceen neither..
 
 
 posted in Syberia on Oct 24, 10 8:25 PM
when I first start I do not go to any cutscene. I go right to the game after the funeral. befor the funeral is just the tittles
 
 
 posted in Syberia on Oct 24, 10 8:21 PM
Every time I read something I cant get out. I keep doing it over and over. Picked up gears in beginning and could not put on table nor get out of scene...help, please
 
 
 posted in Syberia on Oct 24, 10 7:24 PM
My game keeps shutting down..once I click on a letter or something, I can not get out of that screen.I think the game is to big for my screen, yet is gives no option...I am lost, any help?????
 
 
 posted in Return to Mysterious Island 2: Mina's Fate on Sep 20, 10 12:49 PM
something is wrong with your game. it should have six shapes above her when she makes the vases. wet your hands ...pick up the clay(you should have laid it down) then put clay on wheel...then turn wheel...then make the six shapes above her head...sounds like your not at the wheel..
 
 
 posted in PuppetShow: Souls of the Innocent on Jun 21, 10 7:52 AM
I just started game and already I have a problem. I click on bed, try to get down to the sparkling bowl under bed. It keeps taking me out of scene when I do. I get down arrow all the time.
 
 
 posted in Special Enquiry Detail: The Hand that Feeds on Jun 10, 10 10:16 AM
by the way. it took me less than an hour after I figured it out to finish the game. Easy.....
 
 
 posted in Special Enquiry Detail: The Hand that Feeds on Jun 10, 10 10:13 AM
found it. you'll have to start as another person. go quickly to the level. before you go to her room make sure you do everything else first. do not go to her room until the very last. find all the objects first. dont go to the flashing box until you found everything. then go and get key from box. open the door to the puzzle. go to the puzzle. it will say "it needs key" go out of puzzle, then back in again. then put key into lock. it turned for me. The only bad thing is you have to start under another name again. just fast forward past all the conversations. do not "skip" hit "next" instead.
 
 
 posted in Special Enquiry Detail: The Hand that Feeds on Jun 6, 10 6:30 PM
I am stuck too. one of the pieces is sparkling, but the key does not turn to start it.
 
 
 posted in Art of Murder: Hunt for the Puppeteer on May 7, 10 7:11 PM
all you have to do is take a photo of everything you have put together. Don't forget to put clues together that will go together first. round up all clues too.
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator