Posts created by Supernerd

 posted in NiBiRu: Age of Secrets on Mar 4, 18 6:39 PM
I tried it on my Windows 10 PC. It took over my PC completely. I couldn't exit the game, I couldn't get to the menu to save the game. It wouldn't even let me access my desktop. It played well, but don't expect to save your place. You'll have to play through to the end. It also played havoc with the screen settings.
Finally I got so frustrated that the only way I could get out of the game was by restarting my computer.

Hope that gives you some ideas of what will happen.
 posted in The Torment of Mont Triste Collector's Edition on Feb 27, 18 2:43 PM
Due to a hard drive crash, I have redownloaded Mont Triste again. Because I have already paid for my copy, I went to reactivate it again and found this error message:

"Sorry, that item doesn't exist or hasn't been released."

What the ....!!

I no longer can play a game which I have paid for, and works perfectly fine on my Win10 computer!

I want my game back.

 posted in Bingo Battle: Conquest of Seven Kingdoms on Sep 23, 17 3:21 AM
Having a hard time reading the numbers on the cards. The programmers have used a terrible font which is very hard to read. Also it freezes more often than Antarctica in the winter.
 posted in Lost Grimoires: Stolen Kingdom on Mar 6, 17 5:57 PM
Discovered that the game does not support Windowed mode on my PC, so it remained at fullscreen.
This slows the game down badly to the point where I ended up losing patience with it.
I deleted the trial mode. Put me right off.

Also I have visual problems that require me to see games in a small windowed mode. I can't see full screens very well.
 posted in Secret of the Royal Throne on Feb 6, 17 11:54 PM

So much so that I went to change the options, only to find there is no button for System Cursor, and the windowed mode is still huge and gobbling memory.

I think I'll delete this game, which is a pity. But it's too clunky for my PC.
I am getting "Error: Access violation at 0x030B0D50 (tried to read from 0xFFFFFFFF), program terminated."

I have tried all the troubleshooting hints mentioned in your help pages and no joy. This is not the first time this has happened, and I suspect it won't be the last.
It's starting to happen more and more often.

My PC is a Win10 machine.

I'm not going to report this error to helpdesk as all I get is an automatic acknowledgement and a free game code (which I have no use for). Then I hear no more.

This is the second faulty game I've come across within the space of 1 week.
 posted in Shadow Wolf Mysteries: Tracks of Terror on Apr 4, 16 10:19 PM
Me too... same error. But this is now on nearly every game I've got. Can I shoot the Big Fish Games app?
 posted in Beyond: Light Advent Collector's Edition on Oct 30, 15 1:48 AM
AFTERMIDNIGHT wrote:updated to windows 10. beyond: light advent cd says i need to update my graphics driver. what is it and how do i do it. i believe there are other games with the same problem. they played before windows 10, now i can't play them

Same here. But I checked my Graphics drivers and they're 100% up to date.
I'm starting to think I'm wasting my time and money.
 posted in Apothecarium: The Renaissance of Evil on Aug 28, 15 1:01 AM
I've got the same problem too... and on top of that it freezes my keyboard and kills my mouse.
 posted in Fishdom: Depths of Time Collector's Edition on Mar 9, 15 12:27 AM
Same problem here. Annoying isn't it.
 posted in Fright Collector's Edition on Jan 16, 15 5:43 PM
I couldn't get into the game myself. I ended up uninstalling it. Just not for me this game. C'est la vie.

It had more bugs in it than an ant-hill.
 posted in Mysteries and Nightmares: Morgiana on Sep 1, 14 3:25 AM
I've reached that stage myself. There are sparkles indicating that there is a HOG there, but when I enter it, the inventory is blank. So am unable to get the metal flower. The glitch has struck again!
 posted in Slingo Quest Hawaii on May 14, 14 4:35 AM
I'm getting runtime errors every 2 minutes. Brassing me off big time.
Loved the game.... love it... LOVE IT!

I really enjoyed the music soundtrack and I wish I could purchase that separately too. *sigh*
 posted in Spirit Walkers: Curse of the Cypress Witch on Dec 6, 13 9:14 PM
I've got the twigs and cones etc. I've got the stone with the instructions which i followed.... and still it wouldn't work. *sigh* I'm on the verge of giving up.

Too late. I had figured it out, but now the game is crashing all over the place.
I've decided I don't need a game that is buggy, so have deleted it.
 posted in The Far Kingdoms on Nov 21, 13 11:49 PM
Clunky, slow, crap graphics, useless hints. With my crystal in hand, it indicated I should go to the tree. When I got there, the hint told me to go back one step. I did. Hint then showed me to go the the naffin' tree again. In the end I lost patience with the glitches and dreadful storyline, and deleted it. No way.

All in all, I'm glad I got this as a free game, because I'd hate to waste my cash on this white elephant.
 posted in The Legend of the Golden Tome on Oct 14, 13 1:23 AM
You also need to fill up the colour dials on the right hand of the screen before you can go any further.
 posted in Eternal Journey: New Atlantis Collector's Edition on Mar 26, 13 9:07 PM
Spot the clip that is a copy from the old British Sci-Fi movie: Quatermass And The Pit.
I think a bit of plagiarism has happened here.
You pick up one of the tiles and lay it on top of its duplicate. Like a game of Pairs.
Same here. Tempted to ditch the game as not worth the stress over the key.
Go to:   
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator