Posts created by sherales

 
 
 posted in Beyond: Star Descendant Collector's Edition on Jan 30, 18 11:26 PM
In one scene on some planet where the mom got trapped in the cage (before her son escaped from his trap room), I couldn’t find the rocket. Where was it? The walkthrough here doesn’t include rockets in circles like other game walkthroughs to my disappointment. Hope someone knows where to find them. Thanks!
 
 
[Removed by Moderator]
 
 
 posted in Nevertales: The Beauty Within Collector's Edition on Mar 15, 15 10:54 PM
Wait, what update were you speaking of? I didn't see one on the Apple iTunes app. Please advise asap. Thanks!
 
 
 posted in Mysteries of the Mind: Coma Collector's Edition on Jan 30, 15 10:18 PM
I have the same battery issue after I skipped the mini game (it froze up twice). I removed the app and downloaded it again. Then played all over again until I reached the third chapter "myself" and same issue with the battery! When will this be fixed and can someone add the automatic "game saved" feature? It'd save us a lot of trouble!! Thanks!
 
 
 posted in Mysteries of the Mind: Coma Collector's Edition on Sep 9, 14 11:52 PM
I'm stuck at the battery part. Can't pick it up. Hope someone will send in the update to fix the bug. Sigh...
 
 
xxshadowxx - I did but nothing is working.

lunachan - it has to be numbers to follow for both dna and gauge machines to be matched together.
 
 
I followed the numbers to set (according to the instructions aforementioned above) and checked the dials by the preggy woman's bed and pressed the green button but nothing happens. Please help! Thanks!
 
 
Although I understand about the morphing objects and so forth, I still don't understand why the tabs still show "0" (zero) even though I've found the morphing objects during the game, somewhere 1/4 to 1/2 way. Is it malfunctioning or will the numbers appear at the end of the game? Please advise.

Thanks!
 
 
 posted in Lost in the City on Mar 23, 09 2:25 PM
Hi,

I just completed Chp 11 and entered chp 12 and after reading the message (before starting), I clicked on an item, suddenly the game was over. I tried again three times with different items. I don't know if it's the game itself that's having a problem or is it a trick and I need to find something asap before time runs out?

Please advise and many thanks in advance!
 
 
 posted in Lost in the City on Mar 23, 09 1:27 PM
Thanks!
 
 
 posted in Lost in the City on Mar 23, 09 11:48 AM
Hi Kishimojun,

Thanks for replying back. I just edited my post - it's the laptop password I'm stuck with.

Thanks again!

 
 
 posted in Lost in the City on Mar 23, 09 11:39 AM
Hi,

After finding everything on the list (after opening up the chests), I'm stuck at the part where you need to enter the code. Unless I overlooked something, I couldn't figure it out. Please help!

Thanks!

P.S. I mean, laptop password
 
 
 posted in Adventure Chronicles: The Search for Lost Treasure on Mar 7, 09 6:35 PM
Hi again,

I found the picture of the gold dagger, just what I thought it might be and it still won't move or active when I clicked on it. Is it a glitch or something? What can I do? Is there a patch or something like that to fix this?

Thanks again!
 
 
 posted in Adventure Chronicles: The Search for Lost Treasure on Mar 7, 09 6:21 PM
Hi,

I saw the gold dagger on the upper left corner of the scroll bookcase and it won't budge when I clicked on it. I checked the walkthrough provided here and it says, "Sacrifical dagger" and mentioned the location. I tried again and nothing happens.

Is it the gold dagger or some other dagger somewhere above the scroll bookcase? Please help!

Please send me the picture of what it looks like so I'd know what I'm looking for exactly.

Many thanks in advance!
 
 
 posted in The Serpent of Isis ™ on Feb 28, 09 12:25 AM
Hi!

Those of you, who just completed the game - how many chapters are they? Is it replayable kind?

Thanks!
 
 
 posted in The Treasures of Mystery Island on Dec 26, 08 9:33 PM
One more thing - if you're worried about doing the game all over again with the free trial, don't be 'cuz you'll play from where you left off last which is the mosaic room. Good thing, eh?

 
 
 posted in The Treasures of Mystery Island on Dec 26, 08 9:19 PM
Hi,

After being frustrated with the game's being frozen up every time I put the tile on the unorganized mosiac poster, I decided to check the other company's free trial of this same game and see if I have the same problem or not. To my surprise, under their free trial, I was able to put on the tile and after leaving the room and return to it, it showed something on the alter. So I guess it's a glitch under BFG program.

You can bypass the glitch by downloading a free trial from another company by googling the game's name.

Best luck!
 
 
 posted in Monster Quest on Dec 25, 08 2:42 AM
Hi,

I downloaded the demo and in the second case (I think, regarding the sea dinosaur like monster) and i was left with a rusty key. I tried to open the locked chest or safe in the middle of the office but nothing happens. I'm puzzled as to where do the key belongs to. Does anyone figure it out?

Thanks! Merry Christmas and happy 2009!

Sherales
 
 
 posted in Redrum ™ on Nov 3, 08 8:10 PM
Yikes! I was stunned to finish the whole game with one minute left in the demo and it definitely was the shortest game I've ever played in an hour (in this case, 59 minutes). I'm glad I didn't purchase it or I'll be so mad at myself for a month!

If you want a challenging and fun HOG, wait for either Ravenhurst or Hidden Expedition or similar games that has more than 10-15 levels - they're worth a coupon!

 
 
 posted in Samantha Swift and the Hidden Roses of Athena on Oct 26, 08 11:15 PM
Hi,

By the time, I clicked on the staff, my inventory is already full. I couldn't get rid of one thing so I can get the staff. How do I get one thing out of the inventory to make room for the staff?

Thanks!
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator