Posts created by lilliemae

 
 
 posted in Mortimer Beckett and the Secrets of Spooky Manor on May 26, 16 9:19 PM
Hi Arnold, Go to mansion picture and find Indian room, Pick up starter, it will store in the objects on the right. then go to ghost machine room and put on pic of machine. It should fire off right away..good luck
 
 
 posted in Phantasmat: Town of Lost Hope Collector's Edition on Apr 10, 16 2:15 PM
I am stuck in the play park out side the school. I finished the game on the tree, got the lubricant, but am unable to go forward. Game says to move on. I am unable to place the pump top. I can't move on. Can't fix the ladder on tree. Oh boy ! Had to quit last game too. I am so disappointed. Help
 
 
I have same problem as all above and below. Using windows 10. Just got shut out of Myths, Born of clay and fire few days ago. Whats up? Both very good games and was enjoying them. Please send a fix. If all of us with different systems are having problems, it just might be you guys.
 
 
regarding the sword fight in the cathedral. Have followed every reply. No luck at all. I have reset and repeated many times. Was enjoying this game and now can not go on. Anyone with some sage advice help me please. Lilliemae
 
 
 posted in Spirit of Revenge: Gem Fury Collector's Edition on Dec 14, 15 6:30 PM
playing with windows 10. same problems as all the others.
 
 
I can not get through the flower game. It either never ends or when I try to skip the game freezes. Can not get past it. Please don't tell me start all over. This will be the fourth game that I had to abandon due to glitches. What happened to quality control. I love my games and would hate to not be able to play.
 
 
 posted in Mystery Tales: Alaskan Wild Collector's Edition on Sep 1, 15 4:16 PM
I am trying to place elevator key so I can get arrow head. No can do. It just sends me up. Cant go on.. Bummer. this game, which I liked has lots of glitches.. Log is annoying. However this arrowhead thing is shutting me down. Help
 
 
 posted in Emberwing: Lost Legacy Collector's Edition on Mar 18, 14 6:47 PM
lknight8, I had the same problem.. I uninstalled the game and reinstalled.. I did not lose my place and was able to fix the pipe. The cursor is still futsy!
 
 
 posted in Fallen: The Flowers of Evil on Jan 3, 13 4:29 PM
Friends, Have any of you checked behind the chest in the dining room? There is a cracked wall. Use your wedge and hammer to chizel out , shoot forgot what it was, anyway I was off and running, got all rivits out, handcuffs to statue and mask to bed. Try maybe will help. Lilliemae
 
 
 posted in Snark Busters: High Society on May 25, 12 1:56 PM
I am almost done with Robot world. However I do not have the schematic. It is not in the big robots hand and I have already taken the wheel to the little robot. I have the matches, but there is no place to put them. How do I get the schematic to start the experiment. Sorry have looked all over and don't know what to do. Thanks for any help. lilliemae
 
 
 posted in House of 1000 Doors: Family Secret Collector's Edition on Dec 26, 11 2:23 PM
I have tried and tried to arrange his arms to no avail. Also have no skip button on this mini game . There is just no position that triggers my ability to pick up the picture. Please Help.
 
 
 posted in Awakening: Moonfell Wood on Dec 27, 10 10:32 AM
I didn't know to take it when solved the puzzel. Now can not not go back. The scene will not open to allow me to get the silver key. Help!
 
 
 posted in Lost Lagoon: The Trail of Destiny on May 18, 10 12:11 PM
Dear Tigris,
I have tried several times to pick up the deer in the small hidden object scene. The little black box that usually shows the shape of the object does not display. The game will not let me have the deer and lift the tamborine. Whar now. Thank you for your help.
 
 
 posted in Lost Lagoon: The Trail of Destiny on May 18, 10 10:33 AM
In the scene where you need to find the deer, the small hidden object area, the black box that gives you the clues does not show anything. No image appears on it. I cant move on in the game Any suggestions?
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator