Posts created by Mazou884

 posted in Rescue Team 7 on Jul 20, 17 6:42 PM
Julesyhedgehog's advice is spot on. I just want to add a little tip that helped me finish in good time: it is not necessary to repair a road bump to the left of the fire hub. This saves a little wood and food and really helped in the end. Great game!
 posted in Claws & Feathers 2 on Jul 20, 17 9:51 AM
A big thank you from me too, AdeptStudios. I keep replaying these games, they are different and very enjoyable. For the first time, I'll be wishing for mid-August to arrive quickly!
 posted in Cursed on Jan 8, 17 7:01 AM
Just adding to the statistics here. Playing on a new PC that came with Win 10. This is the standard now and has been for a while already. I did not even think to check for Win 10 compatibility before buying a new release. And it repeatedly freezes at about 2/3 into the story. Too bad, I was really enjoying it.
 posted in Fire on Mar 26, 16 11:07 AM
A belated 'thank you' danimojo11. I've been away for a little while, and had not checked the forum. I will try that link.
 posted in Fire on Jan 26, 16 6:53 PM
Well, I found out a few more things. For instance, it is impossible to get the missing coins when replaying certain levels, since some actions must be done in a particular sequence. If we do B before A, we won't be able to get the coin. Even when restarting that world, it won't work. It will work only if starting over from scratch as a new 'diskette profile'. So much for exploration. Second observation : I left the Time Machine (with 2 coins obtained), and moved on to the Volcano (last) world, where I got all 3 coins. I then looked up a video to see where that Time Machine 3rd coin was (visually on the screen, no way I could have missed it). Went back to the game to replay that part and saw that the map now showed only one coin for the Volcano world! And that 3rd coin in Time Machine was still nowhere to be found. I should rename my post 'Mystery of the Disappearing Coins'. I'll eventually start the whole game completely over with a new 'diskette', and follow a walkthrough religiously for those tricky areas. What fun is that? Still, I love this game, it's a breath of fresh air. More, please.
 posted in Fire on Jan 26, 16 10:36 AM
Like many, I got to love this game and almost passed it by, I have been replaying it, trying to earn the 3 coins on each level. A big thank you to Bartsister for helping find the walkthrough. But even with that, I must be hibernating with all the snow, brain frozen and all, I just cannot get that 3rd coin in the Time Travel section. Any suggestions? It does drive one crazy, doesn't it

UPDATE (see post below)
 posted in The Last Dream on Jan 1, 16 1:30 PM
Well, congratulations are in order! Thank you for sharing this info, Pckiller, it just adds to the experience.
 posted in Claws & Feathers 2 on Aug 15, 15 9:10 AM
Roxanne601, I second all the grateful people. My best effort took 32 moves, it was also the only gold star left to get, no video available for that level. Like another player said here, thank you so much for taking the time to write it down step by step.
The easiest way was to ignore the skiers, but get the skis in the tray, and wait until they got to one heart, then hurry to give the skis to them. I don't remember having to ignore counter people, I believe there were enough skiers. The difficulty was to really see the one heart when two skiers are waiting. Their heart meters overlap.
I played this challenge today and did not have any problems. All I had to do is select all the most expensive items on the menu. They were all available. Something must have been fixed. I hope it works for all from now on.
I kept failing this also, until I realised that the slush machine product was not considered a drink, but ice cream. Once I gave this to the kids who ordered it, I was able to pass the challenge.
 posted in Delicious: Emily's Home Sweet Home Collector's Edition on Jul 1, 15 11:33 AM
Use soup making as a quick fix: make maximum soups, take them on you tray, then delete them. Repeat as often as necessary.
 posted in Runefall on Feb 14, 15 10:26 AM
Use your jumping device, aim the highlighted square on a 'blank' part of the map where you think there might be a hidden area and travel there. If there is, it will appear and you will be transported to it. If there isn't, you will land on an uncovered area nearby. I found this worked best after previously uncovering all the 'normal' areas first. This gives a better idea of where the hidden ones may be located. Just have to be careful not to unblock the very last rune. You can come back to it after you've found the hidden areas and then end the level. Worked for me!
The Bonus Game is unlocked from the 'Play Game' screen, after completing the main game. It's not found in the Extras.
 posted in Dreampath: The Two Kingdoms on Jul 27, 14 8:36 AM
Just wanted to put this title out in case potential players might turn away after seing all the locked technical problems posts (from the same person). I did not play the CE version, but this is the SE version we're talking about here and it seems to have worked just fine for many of us. This was one of the best (and longest) games I have played in a while, yes blue and purple, cute animal helper and all. But I really enjoyed it and thought it deserved a better reputation. The forum main page does not do it justice.
 posted in Cruel Games: Red Riding Hood on Mar 23, 14 8:02 AM
This game is being offered as Catch of the Week, for week of March 17, 2014. I also figured that after a year, the issues would be fixed. Well, from the start, there's still NO SOUND. After all the silence, writing this in caps makes me feel better! My computer works well with everything, it's not the problem. Can we also assume that the other bugs are still there? Too bad, it looks like a good game. I also did not expect that from this developper. I emailed BFG, we'll see what happens.

Amended Post : Fair is fair, must mention this. I did not re-install, just got back to the game later, nothing to lose. The sound was working. Tested further by leaving and starting again, it still works. Will it stay that way? I'll keep my fingers crossed.
 posted in Mystery Expedition: Prisoners of Ice on Mar 8, 14 8:06 PM
I had no problem with the bear in front of the cave. Find the tusk, crush it in the mortar (in room before the kitchen), boil water (need coal, pail and matches) in a pot on the kitchen stove, pour powdered tusk in there and put this in a potion bottle. All the items were fairly easy to find, no glitch there at least for me. Now, I did get stuck big time on the mechanic-prisoner problem. Mitch04 in another post said to start the game over under a new profile. I did this (oh joy!), but did not re-install. It worked, the prisoner accepted the key. Thank you mitch04! It is a good game, too bad about these glitches.
 posted in Mystery Expedition: Prisoners of Ice on Mar 8, 14 7:47 PM
In another post about this, Mitch04 suggested we just start over under a new profile. I didn't re-install the game, just created a new profile (yes, it's a pain to start over), but IT WORKED. The prisoner-mechanic accepted the key. I hope this works for all. Quite a good game if all the issues are resolved.
 posted in Mystery Expedition: Prisoners of Ice on Mar 8, 14 7:39 PM
As Mitch04 said in another post, start the game again under a new profile. Yes, too bad we have to start over, but I tried, and the mechanic-prisoner did accept the key. Yay! I did not have to re-install the game. It is a good one to keep if all works well.
 posted in Mystery Expedition: Prisoners of Ice on Mar 8, 14 7:33 PM
mitch04 wrote:Good news I have managed to crack the problem with the key. Unfortunately it means starting the game again, but its appears to be the only way around the problem. You need to go to the profile section at the start of the game and put in a different profile name. I did and I have been able to free the mechanic. Good luck!

THIS WORKED for me! Thank you Mitch04. It's a good game, I'm happy to keep it.
Go to:   
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator