Posts created by Mamayaya

 posted in Arvale: Treasure of Memories on Aug 26, 17 10:12 AM
He's one of 3 men talking in one of the houses. I searched forever before I saw him. He is young.
 posted in Arvale: Treasure of Memories on Aug 26, 17 10:10 AM
You have to slide mine carts on the buttons because they all have to have weight on them to open the door.
 posted in Arvale: Treasure of Memories on Aug 26, 17 10:08 AM
I have played through the game and really liked the way all the loose ends fit together to the conclusion. But, early in the game, I cannot solve the 4 well puzzle in the Zomfot Desert. The problem is that only one well is blocked but the other two outside the gate are flowing? The gate continues to be locked. Is there a solution? I hate leaving anything unsolved.
 posted in PuppetShow: The Face of Humanity on Jan 3, 17 8:08 AM
I finally figured out that you can use the mechanical mouse. The trick is to know just where to place it so it works. I had played this game once before and had no problems.
 posted in PuppetShow: The Face of Humanity on Jan 2, 17 4:08 PM
I was able to scare away all the crows except the one holding the blood and key chain that I'm trying to take to make the scepter work on the cat puppet. I'm missing something somewhere. Any clues?
 posted in PuppetShow: Her Cruel Collection on Dec 22, 16 10:24 AM
I found the game frustrating and hard to play in places. The first time I tried to play it, I got stuck with providing light in the cave, so I could go no further. I finally started over and couldn't get past the second room of the hospital because I never found the candle and can't get any new sparkles anywhere else. Got a pan off the head of a lamp. Got the torch made except for the oil, which I can't find. I assumed I could fill the pan with water SOMEWHERE to make something from the dry plaster. Anyways, I now feel this game is a big waste of money.
 posted in PuppetShow: Her Cruel Collection on Dec 22, 16 8:54 AM
So you two may be able to tell me where I can find some oil for a torch.
 posted in PuppetShow: Bloody Rosie on Dec 21, 16 4:34 PM
I found my mistake. Had to restart the game though because you have to look out the window BEFORE you fix the winch to pull the theater guy in. There is solvent in the window. If you pull him in, you can't get back to that screen again. Must be a clinch because I played it on easy.
 posted in PuppetShow: Bloody Rosie on Dec 19, 16 9:20 PM
I have one ballerina and 2 out of 3 walnuts so I can't go further in the game. I've released the theatre owner's puppet but can't get any other interaction going at all. Any hints?
 posted in Aveyond 4: Shadow of the Mist on Jun 25, 16 10:03 AM
I'm having trouble killing those buggers. Any help?
 posted in Aveyond 4: Shadow of the Mist on Jun 25, 16 10:01 AM
I have a problem with getting a full screen with Windows 10. This is true for lots of my games, especially this and other role playing games. Is there a solution?
 posted in Aveyond 4: Shadow of the Mist on Jun 25, 16 9:56 AM
I also found one in Dragon Shadows (?) by the kobolds. It has money so I've been searching for magic & skills, maybe. I don't have a guide.
 posted in Chimeras: Tune Of Revenge on Aug 2, 14 12:55 PM
I don't know whether it's my new computer (Windows 8) but the pointer bounced around the entire game and everything dragged along at a snail's pace. I got very frustrated and almost asked for my money back. But, the story and the graphics held my interest long enough to complete the game. Those were worth the game. I rather enjoyed the fake British accents. It was different and entertaining. But I'm sorry to say I would not recommend this game to other folks because of the slow, slow pace. I'd have to say 4 out of 10.
 posted in Adelantado Trilogy: Book One on Jun 29, 14 6:05 AM
For me, the technical difficulties with the constant flickering screen got in the way of playing the game - On Windows 8 & up. I played it over a year ago on Vista and had no problems. Book Two had some screen problems on my old computer so I held off buying Book Three. Now that I have a new, improved Windows program, I played Book Two. Enjoyed it so much I wanted to go back to Book One and encountered serious screen flickering which makes the game unplayable. I see no point in buying Book Three because it will probably only play on Windows 10.1. Not much of a Trilogy. I am extremely disappointed.
 posted in Adelantado Trilogy: Book One on Jun 28, 14 6:19 PM
Thanks for the warning about the incurable flickering problem. I finally got a new computer with Windows 8.1 and played book 2 & enjoyed it so much I went back to book 1. I've uninstalled & reinstalled several times but could not cure the problem. I tried playing with the flickering until I got a headache & neck ache! I'd even looked online at this site but there were so many technical issues, I gave up & tried again to uninstall/reinstall. Glad I started at page 4 of the technical issues and found we have a problem with no good solution. I'm very disappointed now and don't want to try Book 3 since I can't have the complete set (Books 1-3) to play. Grumble. Grumble.
 posted in A Princess' Tale on Apr 30, 14 8:12 AM
I really HATE chests I can't open!!!!! If you go further down that hallway, past the skelton). I keep hitting a wall that just says "chest?" but that's it. It really drives me crazy but I finally gave up on it. Don't need it to finish the game but hate being tortured with the possibilities.
 posted in A Princess' Tale on Apr 10, 14 9:32 AM
This may be a late response but I just started playing the game. I found that, if you go to the head of the bed, the game freezes but doesn't if you stop beside Vincent & talk to him first. Don't know why.
 posted in My Tribe on May 30, 13 6:38 PM
Yeah, I've changed hair color for others. It just doesn't work on my scared gray person. Also, did you know that using a moonstone on a person changes the hairstyle & sometimes the color. Thanks for your input!
 posted in My Tribe on May 30, 13 6:35 PM
Sounds like a technical glitch. I'd delete the game then reinstall it from BF. If that doesn't work, I'd do a message to the BF technical team. They are usually really prompt & helpful. Good luck. It's is pretty good game.
 posted in My Tribe on May 16, 13 7:12 AM
I don't think there is anything to color the hair. I've tried everything. The moonstone only changes the hairstyle. Youth potion does nothing. I colored with the berries but had no luck. Maybe we need to let this character open all the crates until she/he finds the bones again and scares her/him back to color????

On the fatigue issue: Have you tried placing them in the huts until each is rested? I haven't run into that problem myself...yet, and this is a replay for me.
Go to:   
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator