Posts created by Dentistmom

 
 
 posted in Lost Lands: The Golden Curse Collector's Edition on Dec 24, 15 12:35 PM
SingleChic976 wrote:IT'S NOT A GLITCH!!! I too had the same trouble at first. Then I went back and re-played the entire game to get to the bonus chapter and this time I followed the directions to the recipe EXACTLY as written. Follow the steps below....

No, this IS a glitch. You shouldn't have to play a game over from the beginning just to do something in a different order to finish. They need to fix this!
 
 
 posted in Grim Tales: Color of Fright Collector's Edition on Dec 8, 14 3:36 PM
No, my key has a loop on top. This must be a bug in the game, my hint button won't work at this point.
 
 
 posted in Grim Tales: Color of Fright Collector's Edition on Nov 28, 14 9:08 AM
Stuck with the tri-part key, I think I have all three parts but when I click on the key in my inventory which shows the "you need to do something here" cursor, I get this message in the top of the screen:
bbt_inventoryext_deploy_inv_brokentriplekey_use_keypart_1_cr
The only other things in my inventory are a broken statue and a green eye. When I click on the hint button anywhere else it tells me to go to the director's office. Inside the director's office the hint button does nothing. Please advise. Thanks.
 
 
 posted in Ominous Objects: Family Portrait Collector's Edition on Jul 29, 14 6:02 PM
how do I get rid of the vine in the cellar?
 
 
 posted in Off the Record: The Italian Affair Collector's Edition on May 18, 14 5:20 AM
Cant seem to work the mini game with the pink, green and blue tiles. There are two empty spaces, and two spaces with two tiles on top of each other. I can't seem to unstack the two that are on top of each other and can't seem to place any tile into the empty spaces. What am I doing wrong???
 
 
I'm at the point, according to the strategy guide, where I'm supposed to put the laurel wreath on the statue in the bonus chapter, but it won't accept it. When I go to the close up of the statue holding the gold ball, there is an outline of the laurel wreath place on the statue, but my cursor doesn't change when I hover over it and I can't place the laurel wreath there. ???
 
 
 posted in Resurrection, New Mexico Collector's Edition on Jul 14, 12 10:31 AM
I started putting the phone together and then left. Now I have the card cover, but where's my phone? It's not on the floor in the first room and it's not in my inventory. I need to finish putting it together so I can charge it. (I already turned on the power via the windmill.) Help please! and Thank you!
 
 
 posted in Dark Tales: Edgar Allan Poe's The Premature Burial on Nov 12, 11 5:23 AM
OK, I just answered my own question. It's in the scene as shown in the walkthrough (thru the city gates, over the fence toward the sleeping dog). Guess I tried there too soon or something. Great game!
 
 
 posted in Dark Tales: Edgar Allan Poe's The Premature Burial on Nov 12, 11 5:15 AM
yes, where IS the wrench? According to the walkthrough it's given to you after an HOS. Not for me! Anyone?
 
 
 posted in Urban Legends: The Maze on Sep 30, 11 2:53 PM
What do I use to turn the valve in the boiler room to start the flow in the pipe which I have fixed? It says it will take a lot of force to turn it but the only thing I have nearly suited for that is a sledgehammer and it doesn't turn the valve. Thank you. Love the game!
 
 
I got to the cabin and finished the cabinet door puzzle (although I had to use SKIP even though I had the right side picture done, nothing else would allow me to proceed), but then I started walking toward the farm and now I can't access my inventory. It just won't pop up. I've walked back to the main street and still mhy inventory remains hidden. ANyone else have this problem?
 
 
 posted in Mystery Trackers: The Void on Apr 26, 11 2:39 PM
All I have are a glove and a gold bar in my inventory. I need to get a fuse for the coke machine, find a key for the subway car, and break into the magazine stand. I think I'm stuck! Can someone give me a hint please and thank you.
 
 
Hi! I'm on the pirate ship, at the dining table with the headless pirates. I'm supposed to put the skulls on the right bodies, but the heads are all one group in my inventory, not individual skulls, and I can't pick them up. Please help. Thanks!! PS I really enjoyed this game, loved the live action film mixed in.
 
 
Thanks!
 
 
the bar lady told me but I forgot I guess. Where is it?
 
 
 posted in Dark Tales: ™ Edgar Allan Poe's The Black Cat on Oct 23, 10 10:22 AM
Thank you, I got it! I never tried the rapier.
 
 
 posted in Dark Tales: ™ Edgar Allan Poe's The Black Cat on Oct 22, 10 2:23 PM
How do I blow up the carriage? I have a pistol and I think I'm supposed to place it somewhere and then attach yarn to it to pull the trigger from a distance?
Also why do some of the scenes slow down excruciatingly, some kind of computer- speed deficit thing?
 
 
 posted in Azada ™: Ancient Magic on Aug 30, 08 9:37 AM
I found a bunch of objects on the first page with the professor but now I'm stuck. The other pages are still dark. What do I do now? Thanks!
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator