Posts created by Varley

 
 
I can't even get past the GM. The game is pending in GM, status is "waiting to download." GM shuts down every time I try to activate the download process. GeezeLouise. Can I just have my hard-earned money back? I am not interested in becoming a computer engineer -- I play these games for ENTERTAINMENT, not education.
And for the record, I did not see warnings about system requirements, or recommendations that I play the trial version FIRST, until AFTER I had given BFG my money.


ToniD - I had the problem with the GM hesitating to download. For me it turned out to be my firewall waiting for me to give permission for the game to change some settings. So congratulations to you to have high security on your machine - probably! :-)

But if you don't have some kid around to check your settings, I know if you go to customer service and ask for your money back, they will probably do that. I've emailed them in the past with problems and they are ALWAYS nice and good to me and always try to help.

At the top of any page, on the top at the extreme right side is the ?Help button. Click that. Depending on what you want and what time it is you can either live chat or email from that page (bottom left).

Hope this helps!

 
 
 posted in Grim Tales: The Bride on Oct 9, 11 1:14 AM
Guys, I feel your pain. I just finished the game and thank goodness, did not have a problem on THIS puzzle.

I do not think reinstalling the game changes a thing. MAYBE deleting previous profiles will help. But I do think you will need to start anew.

SPOILER?
If you have the oil and the lever, apply the oil first to the center of the mechanism. Then apply the lever to the right side. If the game accepts your moves,

---> a cutscene will show the lever being pulled.

You may need to look at the paper in the room - I think? - before doing the activity. I seem to remember there's a page somewhere that shows the oil and lever on the machine. But I'm sorry, I just don't remember for sure. And I think the problems are with the puzzles themselves, not gameplay.

You all may want to read other posts especially under the technical problems. They may show you what to watch out for and to be careful to have all pieces for all puzzles - just to be sure! - before trying one. (SPOILER? click the scene up to three times to get all the text.)

I saw someone gave a great piece of advice. If you're not willing to go through the whole thing over again with a new profile, be sure to wait until the skip button is fully loaded before tackling a puzzle. But it's not a guarantee ....

Do a lot of cursor waving in each location before doing anything. Keep track of things that haven't been done in any location - there are lots of medallions and keys! And if you write down the steps you take and the darned thing crashes or freezes, you can send it in to the customer support folks (green envelope over there on the right! then 'contact' on the next page. )

Good luck, all!
 
 
 posted in Grim Tales: The Bride on Oct 9, 11 12:43 AM
For what it's worth, I too had the sliding puzzle problem the RIP/gravestone puzzle hanging where no other action was possible except bringing up the task manager (ctrl+alt+delete in XP) or shutting off the computer. I wrote to customer service and my experience may (or may not) help others.

My experience has been on the version released Sept. 17, 2011.

It had nothing to do with drivers or profiles, game play up to the puzzle or (as far as I can tell) firewall or virus protection - at least on my machine. My take is that it is either putting one piece into place at the start or (more likely?) moving 1 piece multiple times causes the program to become confused.

And yes, if I alt+tab out of the game and back in, I see the Pause notice, but that's to be expected. I haven't seen it without leaving the program.

Anyway, for at least my machine I can guarantee that this sequence will cause the game to hang:

green right, yellow down, Gd, Rd, Gl, Bd, Br, Bd, Bl.
So don't do that!

As far as mechanism one goes, the lever/hoist. I did not have that problem. Have the oil AND the lever in inventory. Apply oil to center of machine. Apply lever to right side. If it works, the cutscene will show the lever being pulled.

Another problem I had that I haven't seen elsewhere was the well vials problem. When you get to that puzzle, be sure to read the Info first. I didn't and was just playing around. Of course, the darned thing froze. But in this one I was lucky. The skip button worked as well as the menu button. So you can get past this one if it happens to you. I'm convinced it's the sequence of steps that cause these puzzles to freeze. (of course, only the programmer knows for sure ..... )

Good luck all! It's actually a fun game.
 
 
 posted in Grim Tales: The Bride on Oct 9, 11 12:01 AM
Hey Rue23! At first, when I saw this thread, I was hoping it was the development team trying to see if anything was still a problem after the September 17 release. (I'll still hope they see this ).

I just posted a review but as far as the puzzles are concerned, here's my experience.

It took me three profiles to finally get past the RIP/gravestone puzzles. I can guarantee these steps will hang your game so don't do them.

Gr, Yd, Gd, Rd, Gl, Bd, Br, Bd, Bl (color direction)

I was curious, and I know some QA, so after I finished I tried some tests. At first I thought it was clicking the peg then arrow then same peg already hilighted and arrow, but that doesn't seem to be it. I'm almost convinced it's putting the Yellow peg in place immediately although it could be blue moved multiple times. I am tired and figured one certain crash is enough. (I also tried streamlining everything in the game leading up to the puzzle - taking absolute minimum steps to get to that puzzle vs. looking at and touching everything, no skipping dialog .... That kind of thing didn't seem to have an affect on the puzzle itself.

I finished all the puzzles in the advanced mode except that one I was forced to skip and two I skipped voluntarily. The one I was forced to skip was at the well - the 4 vial puzzle. I chose to skip some puzzle behind snow - I could NOT see the pieces well enough to determine what went where. SPOILER? This puzzle turned out to be a spider. The other one was near the end - the one in Father's room sorta like the RIP puzzle. (I hate to admit it, but by that time I felt the game had gone on forever and I didn't want to spend another 10 minutes on a puzzle.)

BTW, I've seen some people put spoilers in that can't be seen unless you run the cursor over it. Anyone know how to do that?

SPOILER. I was just playing around with the vial puzzle - for most of these puzzles the Info button was unnecessary. I thought for this one the goal was to get the same level of liquid. So I put in according to the color scheme at the top: one color in the first vial, two in the second, don't remember the third, and two of the same color in the fourth. I think I filled the second vial last. At that point, the game hung. Thank goodness the SKIP button was still active (unlike the RIP puzzle) and I was able to go on. I wasn't happy though.

more useless info to come
 
 
 posted in Grim Tales: The Bride on Oct 8, 11 11:42 PM
I think the game could have benefited in including a map and/or a to do list. The player doesn't have to use them, but I think it would be appreciated by casual gamers.

I found the diary to be useless.

If you leave the game while sitting on a cutscene, you will find that after two minutes it will continue on without you - even though there is a 'click to continue.' Now, I ASK you ---- WHY? Who's in a hurry here?

Hint refreshes in about 30 seconds. But I only tested it once so it may stay that way or get longer if you use it.

My impression is that multiple people performed the programming and they didn't speak to each other. And really weird when Luisa calls out, "Luisa, you're here!"

And yet, despite it all, I was attracted to play. The game didn't hold my attention as some do, but I wanted to play it. But I also felt the developers wanted to give the player his money's worth - it just wasn't clear to them what exactly that is. Although I liked it, they maybe went overboard with features - lots of HOG and puzzles - and not enough game - the compelling story. (not to say I need a story to play! )

I played in advanced mode, said no to interactive tutor. Did not use the hint on HOGs and finished all but three puzzles (two I intentionally skipped, one was forced upon me). I WAS disappointed in two of them. For one puzzle, the only way I could advance in the game was to skip the puzzle. For another, the board was so obscured I couldn't see to play. (For the third, I was just plain lazy. ) If you are willing to risk the game freezing or crashing, you will find this game to be a long play. There may be multiple reasons for this.

I'd say puzzles range from beginner/activity to intermediate+. I did NOT see that the puzzles became harder with play. I was pleased to see that the puzzles were built so that, with some study, they were not too hard - and didn't require a whole lot of steps to complete. But having said that, I know that at least one puzzle took me 10 minutes to figure out. If you have that kind of patience and time - you will enjoy.

Story was almost as if they'd started with one and then changed their minds. Previous reviews are correct - the ending is disappointing and very abrupt.

My notes say I played 10 hours over 6 days. WOW. I downloaded after the Sept. 17 new release and still had a problem with the RIP puzzle. (I have a guaranteed 'will hang the game' solution to RIP written up elsewhere.)
 
 
 posted in Grim Tales: The Bride on Oct 8, 11 11:03 PM
Grim Tales: The Bride
BFG and Elephant Games

There are three modes: casual, advanced and hardcore. There are no voices and very little if any animation as I recall.

I liked and hated this game. First the crash, hang/freeze issues. Some people managed to play with no snags. Alas, I was not one of them but I can rejoice because the major problem was near the start. Besides the 4 HOUR download! (I'm blaming that on the new GM.)

Terms were not used consistantly. A cup was a mug or a goblet. A chest might also be called a cask. Box was also called trunk. Cupboard was also cabinet. And was Tom Soer supposed to be Tom Sawyer? I hoped it was a joke. HOGs were not consistent. Some were just beautiful, clear, and a joy. Some were murky, obscured playing area and items, used color on color, size distortion, and ambiguous descriptions. But a really good thing - no penalty for incorrect or rapid click (I just hate that! It's MY game and I'll click when I want to. )

Hint wasn't. It was a direction, not a hint. I used it once and when it told me exactly what to do, that was it.

Music was unobtrusive since you only heard about 30 seconds worth on the occasion of entering certain locations. Sound effects were consistent with location.

Most, but not all puzzles had reset buttons. I think most had an Info bar which was supposed to tell you the objective of the puzzle. I found at least two unhelpful.

I liked the puzzles. There was a puzzle or HOG every time you turned around - the game was just brimming with them. Good thing because the story left a bit to be desired.

I did NOT like the feeling that every item you have to find is a key or a medallion. No, there were other items, just didn't seem like it. And it also felt like back and forth to two locations too many times. On the other hand, most of the locations were just beautiful.

I also liked the fact that you couldn't always use an item immediately after you found it. But this caused two other problems; if you only play a few hours a week, you will need to keep track of locations AND what is needed in each. BTW, don't use a term without an adjective or you'll find you have 6 locations that need 6 keys and you have 1 key in inventory. :-) Now what?

more to come....
 
 
 posted in Magic Encyclopedia: Moon Light on Sep 15, 11 9:00 PM
CleoLadyCat, Thank you for the subject!!!! Do you do this every day? I LOVE it! Also, Genkicoll does a list for all the new games. In chit chat corner forum. I believe she does it by month.

These MUST be labors of love! Thanks! And thank you all for your reviews. I'm going to try it.
 
 
 posted in Nightmare Realm on Jul 30, 11 9:19 PM
PuzzleDone. I think the answer to the GM is here http://forums.bigfishgames.com/forums/show/2156.page in one of the top two threads. (lots of pages! :-( ) I think I read you only have to have IE 6 or greater and it does NOT have to be your default browser.

Thanks everyone for such quick reviews! I am certainly going to purchase this one. Can't wait.
 
 
 posted in Hallowed Legends: Samhain on May 2, 11 3:14 AM
For the most part, single sparkles go away when you no longer need to go to any particular location. They always go away for completed HOGs. This game is directed: you can only do certain things after you have done other things. And you only get certain items you need by doing certain things that are only provided
to you if you have done other things .... Another good thing for at least beginners: locations are no longer accessible if you have gained every object you need/can get. These locations dismiss themselves once you have clicked on the item(s) you need.

There was only one resource hog in the game that I noticed. This kind of activity (eg. water moving, fire billowing) caused my (old) laptop pause and resulted in cursor stutter and it slowed way way way down. This was near the end game. SPOILER - skip to next paragraph!!!!!!! It was fire in the warehouse and you
only needed to get one item - keypad - and then use one item - sand - on the location.

And I do have to admit that I referred to the walk through once. Therefore I'd rate this game at least challenging and wouldn't recommend it to beginners. However, intermediate and even expert players would probably enjoy this game. I hate to say it: I didn't feel any real urge to play this game. But once I started, I was engrossed. This game was easily put down; however I did feel a desire to come back and finish it. I can't explain the ambivalence. I know, right now, I want to play it again. After a few days, who knows?

I would recommend this game to those who like a challenge. Who prefer an adventure game over a HOG. Someone who likes challenging puzzles, and wouldn't mind the theme. Someone who likes puzzles. This is not a fluffy game. I very much liked it and look forward to playing it again. (BTW, don't remember any snakes. There's only one spider, I think, and it's knitted.) No children are depicted. Don't remember reading any other phobias.

Similar games: not sure of any right now. However, adventure games I liked include the Treasure Seekers, Clumseys, Mystery Case Files and Murder She Wrote. And RTR, the best! Maybe Shivers or Siberia.

(inspired by Genkicoll, thank you. I never would have reviewed without her encouragement.) So you all have her to thank for this overly long review. :-)

 
 
 posted in Hallowed Legends: Samhain on May 2, 11 3:06 AM
Certainly experienced or expert level for at least half of them. (the other half were as one normally expects: like master mind solvable in 6 steps or a row/column/diagonal puzzle. I don't remember any ridiculously easy puzzles (that I call activities) like color by number.) Puzzles are skippable after only a few minutes. There is an i(nformation) button to click if you need the very basics of the goal. I found this information less than satisfactory several times (so ended up skipping) nd at least in 2 cases it was downright annoying since 'info' followed my cursor around no matter what I did - even resorting to closing the program. I shied away at one puzzle that a lot of people had a problem with and simply skipped it. probably a mistake and I should have tried it. So basically, I think the puzzles were good ones and it was a combination of lack of real information as to goal AND my impatience that made me skip some - 4 I think.

The downside: sorry to say it was the sound effects and music. Sound effects included howling monkeys and dogs. Yikes! Enough said! Music became repetitious and annoying even though I could tell there was an effort to make it varied. The music wasn't bad. Just not sustainable. Sound effects were unfortunate.

I liked the graphics and the different locations. I didn't feel they were 'strange' mainly because of the cutscenes. I didn't have a feeling of disconnect with the locations, HOGs, puzzles or separate areas.

There are two pieces of advice I'd give to anyone playing this game. First, keep notes. Note your location and indented below each one, note the challenge(s) and what might be needed to solve. Having said this - small sorta SPOILER - if you can't figure out what you need, if you use an incorrect object on a problem/task
the text will tell you what you DO need. Any kind of note system would be helpful even though there are maybe 8 locations per area. Maybe a few more. The journal is good, but when you have gained an item, it's nice to be able to remember where it might be useful. If you have an A+ memory, forget this advice. :-) I found this game to be average in my note system: Three 8.5x11 face sheets and 1 for figuring/estimation/deduction. So 2 pieces of paper needed. Front and back. Maybe 3 (and I'm not telling) :-). Line out each item when done. This may be good advice for all adventure gamers. Wish I knew. :-)

sigh, more
 
 
 posted in Hallowed Legends: Samhain on May 2, 11 2:59 AM
BFG and Elephant Games about 5 hours over 6 days
I'd classify as adventure with HOGs and puzzles/mini-games
Animated, colored cutscenes, text. No voice.

You are some woman looking for her ex-husband Robert. (why bother?) He disappeared in Cornwall while you were talking to him on the phone. So you go to Cornwall to look for him. (again, why bother?) He is with a group of people that are on the trail of some demon. You are the idiot who wants to save him.

Options include sound, music, screen size, custom cursor, mode, credits. Mode can be set to casual or advanced. As usual, casual means hints refresh faster, puzzles/mini-games are skippable (faster?), a single sparkle indicates an area to be explored, and multiple sparkles are used to indicate HOGs (hidden object game scenes). I played in casual mode.

Off the main window are options, strategy guide (calls on internet), achievements (18 possible), credits, quit. At the beginning of the game, the tutor is offered.

Play area: text is shown at top and has to be clicked away. Central bottom is the hint circle. To the left of it is the inventory (clickable) box. To the right of it is the clickable journal. HOG text list is to the right when needed. At top right of the play area is the menu button that leads to options and/or quit. Games are automatically saved on exit.

HOGS. Scenes are clear and easily viewed. Some color on color used (cheating, in my opinion). Some small items used (items are smaller than you would normally expect). Otherwise is straightforward mostly except that a few text items are misleading (eg. "badge" used for ID badge or a metal wearable object or "horn" as a bullhorn or trumpet or antler - that type of thing). I did not notice any intentionally misleading text - only some that may mean other than what comes to mind first.
There is no penalty for rapid incorrect clicks. Hint refreshes in 30 seconds. There are about 4 HOGs per area. Areas are separated by cutscenes and there are maybe 6 cutscenes. There are at least 4 puzzles per area.

Puzzles/mini-games. I must admit I had to skip several. Puzzles are usually my forte and I can't explain it. I don't know if they were harder than usual or if it was that I was tired (I hope). Whatever the reason, I do know that I ran out of patience. Perhaps some were unusual. In any case, I would rate the puzzles as being beyond a beginner. <<more>>
 
 
 posted in Hallowed Legends: Samhain on Apr 26, 11 10:21 PM
LilyPad99

You might be able to tell when the trial was loaded via the date on the program folder. Depending on your operating system, the instructions may be different. For XP:

find My Computer. It's either on your desktop or an entry on the Start button. Click (or double click) it so that a window opens. Then select/click Drive C (under hard disk drive and is labelled 'local'). Then select the folder called Program Files. Then find the folder labelled Hallowed Legends - Samhain. Look at the modified date. That should be the date it was loaded on the machine.

This is not a guaranteed solution. A second download may have advanced the date. Also, if you do not see a folder mentioned above it may be because you have your setting to not show dates or certain types of folders. That is more a technical issue rather than a game issue. (if you Google something like "can't see dates on folders" you'll end up at TechSpot or another computer guru site that can help you.)

Another way to check would be to go thru the Start, Help. Performance. ... System Restore. (or right clicking My Computer. Then select Properties.) Your computer is probably set up to create a restore point before installing any downloads. By reading the titles of the restore points you may be able to determine when the game was installed.
 
 
 posted in Big Brain Wolf on Dec 26, 10 9:41 AM
I am having trouble retrieving saved games. I have had to restart 3 times and that's not fun. Since I've seen lots of views to the "Oh No I have done that already" and to the technical issues post here, I just can't believe I'm the only one even though I haven't seen any one else reporting this problem.

Please don't refer me to reinstall, be an Admin, upgrade drivers.... default, generic help page.

I'd like to know where and under what name the saved game resides. I run CCleaner and other s/w and I am guessing the file is being deleted.

Except for the saved game problem, this is a fun and humorous game and I'm looking forward to playing it - but not in one marathon run. :-)

Thanks for your support.
 
 
 posted in Mystery Case Files: Huntsville ™ on Jul 13, 10 9:00 PM
This is a timed hidden objects game (HOG).

You are a detective solving multiple crimes (aka levels) in Huntsville.

The object of the game is to find X objects in Y minutes in Z locations while still leaving time to complete a 10x8? swap tile puzzle. The tile puzzle exposes the villain. Very cute and nice humorous stories.

I needed 4-4.5 minutes to do the 'swap tiles' puzzle at the end of each level. The problem is, at level 4 you get 13 minutes to find about 32 objects. At level 5, you get 17 minutes to find 40 objects in 5 locations (8 per) and still have to reserve yourself 4 minutes to do the puzzle! NO THANKS! I quit in the middle of level 5 - I think there are 12 or so levels.

There are only three hints per level. One good thing. You see rooms several times, so if you can play continuously, you may remember where some objects are.

To exit, you must be "in" an investigation/level/crime. And the clock starts ticking immediately. I stopped at the start of level 4 and lost 20? seconds trying to exit out of the game. (someone said you can use the ESC key to immediately leave. That may help.) You also lose a second or two waiting for objects to fall into your briefcase. No rapid click/select is allowed. You also lose time if you wait for their 'congratulations' or 'move on to next location' messages. You ALSO lose time sitting on the map! I think I also lost time while going to the main menu to quit! There is a pause button but the screen is completely obscured if you use it.

I hope I NEVER see this one again. What a waste of money and I wish I'd never purchased this one. Return to Ravenhurst and Dire Grove were so good. This game is too frantic and frustrating for me.

I think this game came out around 2006 and the developers realized their mistake. If a player wants a timed game, all one has to do is buy a clock! If you enjoy a timed game, try Haunted Hotel which is more generous with time and has 3 silhouetted bonus objects per ROOM which buys you 1 minute per object.

Hint: The second you finish a location, IMMEDIATELY click the Map button. Don't wait for any messages, And don't tarry on the map. Click a site and move on.

 
 
 posted in Millennium Secrets: Emerald Curse on Jul 4, 10 11:58 PM
I have to say Genkicoll recommended this game, so I thought I'd check it out. She was SO right! http://forums.bigfishgames.com/posts/list/87823.page#1616174

In this game there will be a lot of cursor waving and yes, opening drawers and doors to look for hidden items. This game does not present a text list of items as in a HOG, it is more an adventure game with HOG like qualities where dialog/monologue and thought guide your actions.

The game uses a game engine, so the characters are 'animated'. Hints are garnered by finding x number of bonus y items in each set of locations. Hints are given three at a time. So apparently, to get hints at all, you must find all y items to get 3 hints. I did not see a way to get one hint at a time. A location is comprised of 4-5 areas. Turning is achieved by clicking or double clicking turn arrows at right or left. A double click takes you immediately to the next area. Single click is slower.

The music features flute and guitar. Menu is regular options. The game features casual or advanced mode. In casual, which is what I played, locations of interest are indicated only after the cursor passes over them.

The storyline is good although there may be a little emphasis on cutscenes. Items are described in text at the top of the screen. I appreciated the fact that, once a site within a location is finished, there are no more sparkles. Except for items of story interest - like pictures - which the player will immediately be able to recognize.

There are mini-puzzles scattered within locations - in the demo all were very easy. Pattern matching, Master Mind look-alike, and jigsaw for example. There is a skip button that slowly loads, but most people won't need it. The only problem may be for the color-blind.

For the most part, the scenes were easy to see - bright and clear.

At the end of one hour's play I was wondering where the time went. I had planned to play for half that time. A definite buy for me.
 
 
 posted in Strange Cases - The Lighthouse Mystery on Jun 24, 10 9:34 PM
Joymul,
For all the newer games - past several months? - BFG has added a thread for reviews.

From the Games Forum, once you choose your game, that game's forum page is shown. The first post/thread is the welcome, then the second is "Your Comments and Reviews for ...". Easy to miss since the word review is somewhat buried.

Happy playing.
 
 
 posted in Buried in Time on Jun 24, 10 9:07 PM
I demoed this game. I've never played anything like it, but I thought sim/straregy/time management were all applicable.

The player has a small team of archeologists to manage. The stated object of the game is to find a diamond.

At the bottom of the screen is a fast forward button and a scrollable map inset along with progress bars for hunger, sleepiness, and skill proficiency (I think).

At the top are worker icons and text instructions and cues. Worker icons can be clicked to locate a worker. Each worker has two skills. There is also a dog, Rex, that barks when he finds a place to be dug and a cook that feeds all. One receives cash for artifacts, which need to be dug up, brushed/polished and then analysed and flowers that are to be sold to the fortune teller. Workers give audible cues when a task is completed and the player can then put them on another job by clicking and dragging the avatar. Text along the top can be clicked to locate items. Workers work, eat, and sleep and it is up to the player to track all workers.

Cash is spent on hiring new workers or buying upgrade equipment. Puzzles seem to progress in level of difficulty.

This seemed to be a cute game story with clear graphics and untimed. It may appeal to a relaxed player, but not one who was not willing to pay attention to the game.

One draw back after installation is the initial unpack time (over two minutes) and then load/initialize time, again over two minutes.
 
 
 posted in Midnight Mysteries: Salem Witch Trials on Jun 18, 10 6:41 AM
medview2 wrote:If I missed this question in the forum, I apologize. I find that when I exit out of the game and then go back to play again, I am exactly where I was the very first time I exited out! (which was when the bridge broke and I had 3 clovers) The first time this happened I decided to just replay, but then I went a lot farther in the game and it is just too annoying to do it again and know that I will have to start all over (yet again) once I exit. Did anyone have this problem?


I saw similar issues under the tech problems thread. You might need to report it - I didn't see any solution.

There was a solution for a different problem, but it might work for you since it seems most of these problems are being generated by the game manager. Somewhere around page 1 Manuel suggests running the game directly.

This would require you to go to C:\Program Files\Midnight Mysteries 2 - Salem Witch Trials. Then double click the file Midnight Mysteries Salem Witch Trials.exe

You may not see the .exe part depending on how your computer is set up.

If you didn't understand this explanation just report the problem.

Good luck.
 
 
 posted in The Heritage on Jun 18, 10 5:56 AM
by BrutoMemo Entertainment and Seven Sails

This game is a fragmented hidden object game (FROG). The player is presented with a game play location that includes area sparkles, single sparkles, and silhouettes. The fragments to find are at the bottom, per scene, 5 objects each with 4 pieces. Below that are the inventory objects created once all the pieces are found. Also on the play area are menu, hint and a heart icon. The menu includes resume, options and exit with an automatic save. The icon is used to repeat storyline text. Hint refresh rate is one minute and is only indicated visually.

My computer had a hard time displaying the cutscenes and storyline text but that was after having played several demos in a row. The initial cutscene's music was too loud and the monologue was too soft to hear clearly. Options on the main menu allow adjustment to sound, music, full screen and the custom cursor, but that was too late. There was no voice other than the cutscene during the hour.

The scenes are mostly bright and most objects are easy to find by simply clicking on items that look odd in the scene. Some items are small. Some scenes are paired with another scene. After finishing the initial scene, a set of instructions are given, which seems a little on the late side. However, even one who has never played this kind of game before will find it relatively easy to figure out how to play.
Once all the fragments are found, the inventory item is placed on the corresponding silhouette to usually reveal another fragment. Random clicking is not penalized. Inventory items in the drawer are placed on silhouettes, they are small, and they may be difficult to see when white.

There are puzzles involved that required a little thinking once all the fragments are found in a scene. These can not be skipped, have no hints, but they all follow the same formula. Once a scene or pair is completed, there are mini games which are also fairly easy. These can be skipped after one minute.

The game is directed with only one or two scenes available at a time. Cursor waving is required. There are few distractions within the scenes. The storyline is advanced through text.

This game may appeal to a beginner or casual player, however, some visual acuity is required. The walkthrough is available at http://www.bigfishgames.com/blog/the-heritage-walkthrough/
 
 
 posted in The Heritage on Jun 18, 10 5:35 AM
Do you have the latest version? If you're not sure, check out the forum main page. If you think you have the latest version, report it in the technical issues.

I am so sorry to hear this. I hope your data is still saved and they can get it back for you.
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator