Posts created by Gembirdie

 posted in Moai V: New Generation on Feb 3, 18 9:10 PM
The arrow is not close to the top. It is on the left edge of the screen, just above the middle. When you move your mouse over it, it comes out and shows you the sign of the spell. This spell seems to multiply the food production in the bakeries...

Hope this helps...
 posted in Arvale: Treasure of Memories on Aug 17, 16 7:24 PM
Hello everybody! I loved this RPG game, and there is a lot of really funny dialogue in it. The plot has some nice surprises, and I think its really worth playing.

However, if, like me, you like keyboard controls, be forewarned that sometimes they don't work. At least twice during the gameplay, a door or a fireplace wouldn't open to the next screen. The solution is simple - just enable the mouse again, and try again - it'll work.

Hope this helps, and you'll have as much fun playing this game as I did!
 posted in Shrouded Tales: The Spellbound Land on Dec 17, 15 8:24 PM
Can anybody explain the rules for the dice game? I couldn't figure it out, and finally had to skip it entirely...
 posted in Pahelika: Revelations on Jul 1, 15 8:16 PM
The same thing happened to me, but I was able to remember the name. It's "Rulade".
I hope this will help anybody else with that problem...
 posted in Royal Envoy 2 on Jun 11, 15 7:40 PM
I've noticed among the locked threads a question about how to pass level 63.
I just did it with three stars. Here is how I did it:
- First, I tried to get as much of the gold as I could - typically around 800 pieces of gold. Then I opened the two chests and built one cabin. That gave me enough gold to pay the pirate in the lower right corner. I started logging the little forest, and opened the treasure chest.
- With the treasure in that corner, I could build two more cabins and a garden for each of the cabins. This gives enough happiness points to talk with the leprechaun and unlock those treasures.
- As soon as the leprechaun is gone, I destroyed all three cabins and started building updated mansions with gardens everywhere, even behind the little forest that hid the pirate.
- I earned enough money to pay the 100'000 pieces of gold to the pirate making the smoke, and freed the workers blocked by the tree.
- Then I destroyed the mansion closest to the castle and built a sawmill there. As soon as I had more than 5000 wood, I sent the workers to work on the lava levee, and destroyed all the mansions except one.
- I immediately replaced the destroyed mansions with one house of each type that I updated and built a garden around as fast as possible. And there you go!

If you do it this way, and as long as you keep at it, you should have no trouble getting the three gold stars.

Good luck!
(P.S. Just ignore the pirate who wants 50'000 pieces of gold. Don't try to pay him...)
 posted in My Singing Monsters on Jun 7, 15 8:12 AM
Thanks FishyFemale.
The problem is resolved, even if I don't know why or how. I haven't even restarted my computer.
Oh well - I'll take it anyway...
 posted in My Singing Monsters on Jun 6, 15 7:27 AM
Hi everybody.

Anybody else have trouble? I've not been able to get back to my game for three days, it always says it can't make the connection. Is it only me, or does anybody else have the same problem?

I'm almost finished with the game, so this is pretty discouraging...
 posted in Times of Vikings on May 6, 15 9:31 PM
Hi everybody!

Can somebody tell me what the characters are saying? It drives me crazy to hear the same two sentences over and over and never understand what they mean. If I could mute them, I would!
 posted in Victorian Mysteries: Woman in White on Apr 10, 15 10:39 PM
You've mixed all the colors, put them into the box next to the painting, but your brush never picks up any paint. What's wrong???

Well, it took me a long time to get it, but as long as you've not found the second part of the painting chart, nothing happens. It's a little tricky to find, but go back to the parlor, and search again - you've overlooked something.

Hope this helps. Cheers!
 posted in Wild Tribe on Apr 3, 15 9:36 PM
Take a zebra and drop him on the bush with the blue berries at the top center of the screen. He'll collect some herbs, and then you can drop him on the sick person.

Good luck!
 posted in My Singing Monsters on Jan 19, 15 8:52 AM
Yes, it's the same for me - since yesterday. It seems to happen from time to time, and then you'll be able to access your game once more. I'm just thinking that the game is being updated (maybe not, but that keeps me from getting frustrated...)

 posted in The Mystery of the Dragon Prince on Oct 3, 14 9:32 PM
You get the perfume when you've repaired the mirror...
 posted in The Mystery of the Dragon Prince on Oct 3, 14 9:31 PM
It's in the trophy room, underneath something else...
 posted in The Mystery of the Dragon Prince on Oct 3, 14 9:29 PM
To go back, you have to go towards the bottom of the screen, until you see an icon depicting two feet pop up. Sometimes you have to search a bit for it to come up. Click on the icon.

Other times there's a window open on top of the main one, and you have to click on the main one to get the other to close again. Usually, that's to the left or right of that top window.

Just click all over - there are no penalties for clicking - and you'll figure it out.

Hope this helps...
 posted in The Mystery of the Dragon Prince on Oct 3, 14 9:19 PM
That's one of the things that are a bit annoying in this game: certain things need to be done in a specific order. For example, you can only put the pan in the sink after having turned on the water.
It's the same with the pieces of glass - you can pick them up only after having found the mirror that needs to be repaired...

So, continue playing, and you'll get to it eventually.

Hope this helps!
 posted in The Mystery of the Dragon Prince on Oct 3, 14 9:15 PM
The pink and white flower is actually dry and grey - you'll find it behind the troll, on the table.

Good luck!
 posted in The Mystery of the Dragon Prince on Oct 3, 14 9:13 PM
Before you can get through the waterlogged door to the left, you have to repair the pipes in the cellar to the right - find the pipe and the valve, and put them in their correct places. As soon as you've done that, the water clears and you can open the left door.

Hope this helps...
 posted in Tricks and Treats on Sep 28, 14 9:47 PM
In my opinion, it's impossible. And since it seems that you can't replay the levels at the end of the game, that makes it doubly impossible.

Quite a disappointment, I must say...
 posted in Scratches Director's Cut on Sep 11, 14 6:37 PM
I clicked on the shiny object in the greenhouse and had it disappear before I opened the water in the drain and trimmed the fallen plant. Anyway - it doesn't reappear in the pond. I've tried going back and reading the letter, doing the phone calls, even tried to flush the drain twice more - the object never appears in the pond.

Did anybody else have that problem, and how did you solve it?

Any help will be appreciated...
 posted in Sable Maze: Sullivan River on Jul 27, 14 7:19 PM
I had the same problem, even with the hints going back and forth between archery range and art building.
Just go back to the excavation site between the waterfall, and click on the left waterfall - the trigger point seems to be pretty high up.

Hope this helps.
Go to:   
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator