Posts created by LMSchwartz01

 
 
 posted in Lost Grimoires 2: Shard of Mystery Collector's Edition on Feb 25, 18 3:36 PM
I also have the problem with the alchemy kit and map stuck. I am at the point where I need to make glue to stick the door lever together. It keeps saying, "I should focus on something else," but there isn't really anything left to focus on.
 
 
 posted in Love Chronicles: Death's Embrace Collector's Edition on Jul 10, 17 3:11 PM
I have been to the witch and am now trying to get past the guards to go to the tower. The map says I need to go underneath the bridge, but I can find nothing there to do. The top of the bridge near the crane has a claw that I assume should attach to my rope, but I cannot pick it up. The crane says I should raise the net, but it will not let me do anything, and the blue demon Hint says it needs an elixir in order to give me more hints. There doesn't seem to be a walkthrough or help. This is a poorly edited game.
 
 
 posted in Mystery Tales: The Hangman Returns Collector's Edition on Jan 27, 17 9:01 AM
I tried several times to download this game and it says I have already timed out on my trial game, but since it was supposed to be new yesterday and I never even got to open it, this is untrue.
 
 
I am in the Bonus game. I have reached the final scene at the Great Terrace. I have the calibration knobs, skull, shattered memory, memory crystal, one of the shaped vials in my inventory, but the screen is frozen with the medallion and the ghost showing. I cannot get rid of them. The map shows this is the only active scene. I am running Windows 8.1.
 
 
 posted in Dark Realm: Princess of Ice on Jan 6, 16 10:15 AM
I made it all the way to the throne room and destroyed the orb, but after going through the door, nothing happens. The screen pauses as if it is going to change scenes but remains black. The cut scene is missing and the game cannot be finished.
 
 
 posted in Lost Lands: The Golden Curse Collector's Edition on Dec 31, 15 8:17 AM
After several tries, and reinstallation, this bug is still there. There are also posts with the same problem on the tech board. This is a serious and annoying bug.
 
 
 posted in Lost Lands: The Golden Curse Collector's Edition on Nov 18, 15 9:56 AM
This is a beautiful and well-done game. Unfortunately, the glitch in the Bonus game (see the forum protests) means that it cannot be finished as is.
 
 
 posted in Lost Lands: The Golden Curse Collector's Edition on Nov 16, 15 4:50 PM
I am in the Bonus game. I have all of the ingredients in the mortar for the tea, and the mushroom juice and elixir in the bottle. It still will not let me take the mortar to the teapot and the pestle does nothing.
 
 
 posted in Dark Romance: The Swan Sonata Collector's Edition on Nov 4, 15 12:53 PM
I got through the gate by giving it the basket of apples before knocking. However, I am now in the castle and only have one button for the vase and no mug. The Strategy Guide says they should be near the suit of armor. That no longer opens after I got the sword. The map does not list any areas with something to do, and Hints (annoyingly need to be recharged even after a negative search) has said there is nothing to do in every scene.

The Bonus game is unplayable.
 
 
 posted in Mystery Crusaders: Resurgence of the Templars on Oct 18, 15 4:17 PM
The CE version of this worked fine in Windows 8.1, but the newer, standard version opens in a small window on the upper left of the screen. It is too small to read, even with "Wide-screen" checked.
 
 
 posted in Beyond: Light Advent on Aug 25, 15 1:40 PM
Several games lately, including this one, load fine but then the screen starts flashing repeatedly and does not stop. I have to do a CTL-ALT-DEL to unload the game.

I am running Windows 8.1 on a 64-bit machine in 32-bit mode.
 
 
 posted in Reflections of Life: Tree of Dreams Collector's Edition on Jun 22, 14 12:34 PM
I did very well on the demo game, but when the game re-installed after I bought it, I couldn't get out of the bedroom. There was no down arrow anywhere. Hints said that I had nothing to do in the bedroom, but the map showed that I had things to do in the bedroom said I could not go back to the Front Room to use the mirror. Starting over with a new name and working exactly to the Strategy Guide description worked, but I think there must be programming problems in this game.
 
 
 posted in Haunted Train: Spirits of Charon on Feb 9, 14 4:18 PM
faboomama wrote:Laughing SO HARD right now. I tried to play the CE when it first came out and couldn't get past the train dude once I opened the door. Game would shut down with an access error. Just started the SE and the same exact thing happened in the same exact place. What a joke these games are becoming.


I also could not get the CE game to work. In this game (Standard), I talked to the conductor ("train dude") and opened the window for the map (with nothing on it except pix of the train cars), but the HOP in the luggage will not open. Hints are stuck. This game still has major technical problems.
 
 
 posted in Haunted Halls: Nightmare Dwellers on Dec 31, 13 10:28 AM
jparslow wrote:crashes at the scene where you put diamond on the mirror


Crashes when you put the carnelian (final gem) into the mirror. Gets an Error message and the cursor separates from the game cursor. A small white "cursor" arrow moves with the mouse (my normal system cursor is different), but the screen freezes and the game cursor is frozen, as well. I have uninstalled and re-installed the game without any noticeable difference.

 
 
 posted in Paranormal State: Poison Spring on Dec 17, 13 1:28 PM
This game still does not run, even after two delete and re-installs. The original game let me go through the manikins, finding all but one of the spots with the EMF. Then there was a crash and an "ERROR: Null" message. Now the manikins still say they need to be checked with the EMF, but the EMF says it does not need to be used. Periodically I still randomly get the "Null" message.
 
 
 posted in League of Light: Dark Omens Collector's Edition on Aug 2, 13 10:05 AM
I, too, am stuck at the demon knight. He took my eagle emblem and will not die. I have uninstalled and reinstalled twice with no luck. I even tried going to different scenes and then going back to the knight with no luck.
 
 
 posted in Natural Threat: Ominous Shores on Mar 1, 12 4:15 PM
Like the others on this forum, I have been having trouble with this game. The final blow came unexpectedly. I had been having trouble with the minigames freezing and playing poorly. Then I finally achieved water lily seeds, planted them in the water, walked over and played, then returned. Unexpectedly the game froze, taking down Microsoft Office with it and leaving a DMP file on my desktop. I repaired Office but when I try to play Natural Threat again (even after reinstalling), It put me back before the water lilies with only a pair of pliers and now none of the actions I had done before will let me in so I have no way of finishing.
 
 
 posted in Amulet of Time: Shadow of la Rochelle on Feb 14, 12 10:27 AM
LKlimo wrote:
iluvcatsuk wrote:The game downloads and plays perfectly except from the words at top of the screen, ie. tasks and objectives. All I get is something that looks like a barcode. I have reinstalled it but no change. Does this right itself if I download the full version and is anyone else experiencing this?




I am also getting the bar code at the top instead of words for the tasks and objectives. A problem with a fix????


I get no text either with characters' speech or for instructions for tasks and objectives. I don't get a bar code per se, just a bunch of colored vertical lines on a blue background. This is a pity. I was prepared to like this game.
 
 
 posted in Otherworld: Spring of Shadows Collector's Edition on Jan 25, 12 11:26 AM
I went through the game and had a few glitches, as others have mentioned, but it was all good until the Epilogue. Some of the puzzles didn't work as they should -- having to click multiple times on an item and slow play -- but after I got into the burrow and picked up the shoe laces, the game kicked me out of the burrow and I could not pick up the pole ("poker"). Now wen I get back into the burrow, the poker is not there and I cannot proceed without it.
 
 
 posted in Redemption Cemetery: Children's Plight on Sep 19, 11 2:51 PM
Mr_Russ wrote:
beckykay wrote:I'm unable to click on any of the graves at the cemetery. I got the hydra head out of the hole, and the manhole cover went on, but now I'm unable to do anything else in the game so it's a real dead-end for me!!!! would I purchase it? wouldn't even consider it.
The manhole cover should be clickable. It shows you the orientation of the 5 hydra heads - two pointing left, two pointing right and the middle one looking forwards. You should have two heads to add to the three already on the plinth.


It took multiple random clicking on the statue at the back left, but I finally got the grave to come up. Interestingly, the Hints said, "Search somewhere else" in every single scene, including the graveyard.
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator